MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027107Community[OCCT] OCCT:Shape Healingpublic2016-01-24 10:352016-04-20 15:50
ReporterRoman Lygin 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0027107: ShapeAnalysis_Surface should use GeomAdaptor_Surface for surface evaluation
DescriptionDue to 0024682 when cache class has been moved out of B-Splines all classes regularly evaluating NURBS should be migrated to use of Geom[2d]Adaptor to prevent performance drop.

ShapeAnalysis_Surface is an example of such. It already has a field myAdSur of the GeomAdaptor_HSurface type, which can be used exclusively for evaluation instead of another field mySurf of Geom_Surface type. The latter field can be phased out completely, and the adapter can be used to return a surface when needed.

Methods Value(), SurfaceNewton(), etc should be migrated to using myAdSur.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024682closedbugmaster Open CASCADE Move out B-spline cache from curves and surfaces to dedicated classes BSplCLib_Cache and BSplSLib_Cache 

-  Notes
(0050727)
git (administrator)
2016-02-15 07:24

Branch CR27107 has been created by abv.

SHA-1: 1e46b0896d50444a583d218facfdc18aacf633dc


Detailed log of new commits:

Author: abv
Date: Sun Feb 14 11:16:24 2016 +0300

    0027107: ShapeAnalysis_Surface should use GeomAdaptor_Surface for surface evaluation
    
    ShapeAnalysis_Surface is improved to use adaptor for evaluation of points on a surface.
    Useless field myExtSur is removed.
    DE tests are amended according to induced changes (number of edges varied).
(0050739)
abv (manager)
2016-02-15 11:45

I have pushed the fix to CR27107, please review.

There is no visible improvement of overall performance on tests, however there is improvement of reading from STEP on big files:

model | master | CR27107
--------------------------
LP1 | 43 sec | 33 sec
LP2 | 138 sec | 113 sec
LP3 | 861 sec | 744 sec
(0050740)
gka (developer)
2016-02-15 11:50

Branch CR27107 is ready to be tested
(0050812)
mkv (tester)
2016-02-16 14:30

Dear BugMaster,
Branch CR27107 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 1e46b0896d50444a583d218facfdc18aacf633dc

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 36 (36 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
http://occt-tests/CR27107-master-products-64/Debian70-64/summary.html [^]
Failed:
  bfit pnt1000 A7
  parasolid doc_3 E4
  sat doc_5 H6
http://occt-tests/CR27107-master-products-64/Windows-64-VC10/summary.html [^]
Failed:
  parasolid doc_3 C3
  parasolid doc_3 E4
  sat doc_5 H6

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 90229624 / 89373244 [+0.96%]
Total CPU difference: 19315.409999999927 / 19290.359999999968 [+0.13%]

Testing on Windows:
occt component :
Total MEMORY difference: 57358789 / 57383005 [-0.04%]
Total CPU difference: 17907.775992698877 / 18533.5584040989 [-3.38%]

There are no differences in images found by testdiff.
(0050813)
mkv (tester)
2016-02-16 14:31

Dear abv,
Branch CR27107 has been rejected due to:
- regressions/differences/improvements
(0050949)
abv (manager)
2016-02-18 14:34

The differences are due to variation of results on labile test cases. The tests are corrected in branch CR27107 Products. Please re-test Products only with these changes.
(0050978)
mkv (tester)
2016-02-18 18:12

Dear BugMaster,
Branch CR27107 is TESTED.
(0052897)
git (administrator)
2016-04-17 13:40

Branch CR27107 has been deleted by kgv.

SHA-1: 1e46b0896d50444a583d218facfdc18aacf633dc

- Related Changesets
occt: master 84eca96b
Timestamp: 2016-02-14 08:16:24
Author: abv
Committer: abv
Details ] Diff ]
0027107: ShapeAnalysis_Surface should use GeomAdaptor_Surface for surface evaluation

ShapeAnalysis_Surface is improved to use adaptor for evaluation of points on a surface.
Useless field myExtSur is removed.
DE tests are amended according to induced changes (number of edges varied).
mod - src/ShapeAnalysis/ShapeAnalysis_Surface.cxx Diff ] File ]
mod - src/ShapeAnalysis/ShapeAnalysis_Surface.hxx Diff ] File ]
mod - src/ShapeAnalysis/ShapeAnalysis_Surface.lxx Diff ] File ]
mod - tests/de/iges_1/N9 Diff ] File ]
mod - tests/de/iges_1/P5 Diff ] File ]
mod - tests/de/iges_1/R8 Diff ] File ]
mod - tests/de/step_3/E6 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-01-24 10:35 Roman Lygin New Issue
2016-01-24 10:35 Roman Lygin Assigned To => gka
2016-01-24 10:35 Roman Lygin Relationship added related to 0024682
2016-02-15 07:24 git Note Added: 0050727
2016-02-15 11:45 abv Note Added: 0050739
2016-02-15 11:45 abv Status new => resolved
2016-02-15 11:45 abv Target Version 7.1.0 => 7.0.0
2016-02-15 11:50 gka Note Added: 0050740
2016-02-15 11:50 gka Assigned To gka => bugmaster
2016-02-15 11:50 gka Status resolved => reviewed
2016-02-15 13:02 mkv Assigned To bugmaster => mkv
2016-02-16 14:30 mkv Note Added: 0050812
2016-02-16 14:31 mkv Note Added: 0050813
2016-02-16 14:31 mkv Assigned To mkv => abv
2016-02-16 14:31 mkv Status reviewed => assigned
2016-02-16 14:31 mkv Test case number => Not needed
2016-02-18 14:34 abv Note Added: 0050949
2016-02-18 14:34 abv Assigned To abv => mkv
2016-02-18 14:34 abv Status assigned => feedback
2016-02-18 18:12 mkv Note Added: 0050978
2016-02-18 18:12 mkv Status feedback => tested
2016-02-18 18:13 mkv Assigned To mkv => bugmaster
2016-02-21 08:52 abv Changeset attached => occt master 84eca96b
2016-02-21 08:52 abv Assigned To bugmaster => abv
2016-02-21 08:52 abv Status tested => verified
2016-02-21 08:52 abv Resolution open => fixed
2016-04-17 13:40 git Note Added: 0052897
2016-04-20 15:43 user533 Fixed in Version => 7.0.0
2016-04-20 15:50 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker