MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027027Community[OCCT] OCCT:Configurationpublic2015-12-22 13:582016-04-20 15:49
Reportermartinsiggel 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0027027: Cannot build static libraries with BUILD_LIBRARY_TYPE=Static
DescriptionI tried to build static opencascade libraries on windows with cmake. The setting BUILD_LIBRARY_TYPE does not have any effect. In any case, shared libraries are created.

In CMakeLists.txt, the variable BUILD_SHARED_LIBS is unset. This (non existing) variable is however overridden for each toolkit as add_library is always used with the option SHARED.

To fix this issue, each call too add_library should remove the SHARED argument.
Steps To ReproduceNot required / already fixed
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0049697)
martinsiggel (developer)
2016-01-04 16:53
edited on: 2016-01-04 16:54

This issue seems to be already fixed in the occt 7.0 beta

(0049725)
abv (manager)
2016-01-08 09:58

Ivan, please confirm that it is fixed
(0049835)
ibs (developer)
2016-01-13 17:49

abv, this issue has been fixed in 7.0 beta
(0049887)
abv (manager)
2016-01-15 13:32

Igor, please switch it to Verified

- Issue History
Date Modified Username Field Change
2015-12-22 13:58 martinsiggel New Issue
2015-12-22 13:58 martinsiggel Assigned To => bugmaster
2015-12-26 09:42 abv Assigned To bugmaster => ibs
2015-12-26 09:42 abv Status new => assigned
2016-01-04 16:53 martinsiggel Note Added: 0049697
2016-01-04 16:54 martinsiggel Note Edited: 0049697 View Revisions
2016-01-06 12:44 martinsiggel Assigned To ibs => bugmaster
2016-01-06 12:44 martinsiggel Status assigned => resolved
2016-01-06 12:44 martinsiggel Steps to Reproduce Updated View Revisions
2016-01-08 09:58 abv Assigned To bugmaster => ibs
2016-01-08 09:58 abv Note Added: 0049725
2016-01-13 17:49 ibs Note Added: 0049835
2016-01-13 17:49 ibs Assigned To ibs => abv
2016-01-13 17:49 ibs Status resolved => feedback
2016-01-15 13:32 abv Assigned To abv => bugmaster
2016-01-15 13:32 abv Note Added: 0049887
2016-01-15 15:08 bugmaster Status feedback => tested
2016-01-15 15:08 bugmaster Status tested => verified
2016-01-15 15:08 bugmaster Resolution open => fixed
2016-04-20 15:43 user533 Fixed in Version => 7.0.0
2016-04-20 15:49 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker