MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027018Open CASCADE[OCCT] OCCT:Documentationpublic2015-12-21 10:462017-09-29 16:29
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0027018: Documentation - blockquotes are incorrectly formatted in PDF
DescriptionDoxygen support insertion of text block as blockquotes, with the following format:

> Text...
>
> Another paragraph...

These blockquotes are rendered correctly in HTML output, but are formatted incorrectly in PDF:

a) First line in the paragraph has indentation -- this breaks layout
b) Empty lines get lost (seem to be interpreted as separation of paragraphs)

See attached document, example at page 7
Steps To Reproducegendoc.bat -overview -pdf -ug=dev_guides/contribution_workflow/contribution_workflow.md
TagsNo tags attached.
Test case numberNot required
Attached Filespdf file icon occt_contribution_workflow.pdf (341,039 bytes) 2015-12-21 10:46
png file icon wo_patch.png (13,212 bytes) 2016-12-16 13:02
png file icon with_patch.png (12,839 bytes) 2016-12-16 13:02

- Relationships

-  Notes
(0061724)
git (administrator)
2016-12-16 12:53

Branch CR27018 has been created by ski.

SHA-1: ea0c0f3ba35986042dda713324f6382bc4b201bf


Detailed log of new commits:

Author: ski
Date: Thu Dec 15 12:44:36 2016 +0300

    0027018: Documentation - blockquotes are incorrectly formatted in PDF
    
    Corrected block quotes in documentation for correct format in PDF files.
(0061725)
ski (developer)
2016-12-16 13:02

I have checked Doxygen documentation and it seems that we should use ">" character instead "> " for empty lines in text block formatted as blockquotes, because "> " means the end of current blockquotes item:

"Note that doxygen requires that you put a space after the (last) > character to avoid false positives, i.e. when writing" (see https://www.stack.nl/~dimitri/doxygen/manual/markdown.html#md_blockquotes [^])

Attached images show the difference between ">" and "> " cases.
(0061726)
ski (developer)
2016-12-16 13:05

Dear ysn,

please review.
(0067012)
ysn (developer)
2017-06-02 12:18

Yes, this is the solution.

There seems to be no difference between the branch and the current master, so no integration is required.
(0067023)
ski (developer)
2017-06-02 14:19

Dear bugmaster,

please close the issue.
(0067025)
abv (manager)
2017-06-02 15:03

There IS the difference: exactly a space removed after ">" in Contribution Workflow document. Apart of this fix, please also:

- Make sure that Documentation guide describes how to add blockquotes properly, taking into account that issue

- Check for possible other cases of incorrectly formatted blockquotes across the doc
(0069706)
ysn (developer)
2017-08-21 13:10

Fixed in branch CR27018_1.
AFAIK, we don't use block-quotes anywhere except for coding rules.
(0069725)
git (administrator)
2017-08-21 17:39

Branch CR27018_1 has been created by abv.

SHA-1: f996248950a820b16d41acc6244643bb6e132d65


Detailed log of new commits:

Author: ysn
Date: Mon Aug 21 13:08:27 2017 +0300

    0027018: Documentation - blockquotes are incorrectly formatted in PDF
    
    Trailing space is removed after ">" to avoid breaking the quote block in PDF output.
    
    A section about quotes are added in the documentation guide.
(0069726)
abv (manager)
2017-08-21 17:39

Please integrate branch CR27018_1; no testing is needed
(0069892)
git (administrator)
2017-08-25 16:13

Branch CR27018 has been deleted by kgv.

SHA-1: ea0c0f3ba35986042dda713324f6382bc4b201bf
(0069893)
git (administrator)
2017-08-25 16:13

Branch CR27018_1 has been deleted by kgv.

SHA-1: f996248950a820b16d41acc6244643bb6e132d65

- Related Changesets
occt: master a41ccd91
Timestamp: 2017-08-21 10:08:27
Author: ysn
Committer: bugmaster
Details ] Diff ]
0027018: Documentation - blockquotes are incorrectly formatted in PDF

Trailing space is removed after ">" to avoid breaking the quote block in PDF output.

A section about quotes are added in the documentation guide.
mod - dox/dev_guides/contribution_workflow/contribution_workflow.md Diff ] File ]
mod - dox/dev_guides/documentation/documentation.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-12-21 10:46 abv New Issue
2015-12-21 10:46 abv Assigned To => ysn
2015-12-21 10:46 abv File Added: occt_contribution_workflow.pdf
2015-12-21 10:46 abv Target Version 7.0.0 => 7.1.0
2016-11-22 10:55 kgv Summary Documentation -- blockquotes are incorrectly formatted in PDF => Documentation - blockquotes are incorrectly formatted in PDF
2016-11-22 11:07 abv Assigned To ysn => ski
2016-11-22 11:07 abv Status new => assigned
2016-11-22 11:07 abv Target Version 7.1.0 => 7.2.0
2016-12-16 12:53 git Note Added: 0061724
2016-12-16 13:02 ski Note Added: 0061725
2016-12-16 13:02 ski File Added: wo_patch.png
2016-12-16 13:02 ski File Added: with_patch.png
2016-12-16 13:05 ski Note Added: 0061726
2016-12-16 13:05 ski Assigned To ski => ysn
2016-12-16 13:05 ski Status assigned => resolved
2017-06-02 12:18 ysn Note Added: 0067012
2017-06-02 12:18 ysn Assigned To ysn => ski
2017-06-02 12:18 ysn Status resolved => reviewed
2017-06-02 14:19 ski Note Added: 0067023
2017-06-02 14:19 ski Assigned To ski => bugmaster
2017-06-02 14:19 ski Status reviewed => feedback
2017-06-02 15:03 abv Note Added: 0067025
2017-06-02 15:03 abv Assigned To bugmaster => ysn
2017-06-02 15:03 abv Status feedback => assigned
2017-08-21 13:10 ysn Note Added: 0069706
2017-08-21 13:11 ysn Assigned To ysn => abv
2017-08-21 13:11 ysn Status assigned => resolved
2017-08-21 17:39 git Note Added: 0069725
2017-08-21 17:39 abv Note Added: 0069726
2017-08-21 17:39 abv Assigned To abv => bugmaster
2017-08-21 17:39 abv Status resolved => reviewed
2017-08-21 21:47 bugmaster Status reviewed => tested
2017-08-24 12:42 bugmaster Test case number => Not required
2017-08-25 15:02 bugmaster Changeset attached => occt master a41ccd91
2017-08-25 15:02 bugmaster Status tested => verified
2017-08-25 15:02 bugmaster Resolution open => fixed
2017-08-25 16:13 git Note Added: 0069892
2017-08-25 16:13 git Note Added: 0069893
2017-09-29 16:17 user533 Fixed in Version => 7.2.0
2017-09-29 16:29 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker