MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026993Open CASCADE[OCCT] OCCT:Configurationpublic2015-12-14 16:122016-04-20 15:50
Reporteribs 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] Unscheduled 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026993: Configuration, CMake - use the abstraction level of VTK instead CSF_VTK for their libraries
DescriptionCMake procedure of VTK offers sufficient level of abstraction of VTK libraries. There is no need to use CSF_VTK variable in CMake build procedure.
Steps To Reproducebuild occt with vtk support
TagsNo tags attached.
Test case number
Attached Files

- Relationships
parent of 0026968newski Configuration, Tcl - the usage of CSF_ variables should be revised in connection with CMake build procedure 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0049111)
git (administrator)
2015-12-14 17:16

Branch CR26993 has been created by ibs.

SHA-1: 54e2e8d8f9c32b8616e30c2907ee526cd2250daf


Detailed log of new commits:

Author: ibs
Date: Mon Dec 14 12:42:05 2015 +0300

    0026993: Configuration, CMake - use the abstraction level of VTK instead CSF_VTK for their libraries
    
    CSF_VTK removed from CMake meta-projects (this variable is left in EXTERNLIB because it is used by genproj.tcl)
    USE_VTK shown if toolkits using VTK involved in the solution
    VTK_DIR removed from the advanced variables
    
    Warning messages 'Warning. .../a.hxx~ is not involved into .../FILES' renamed with 'Warning: File .../a.hxx~ is not listed in .../FILES'
(0049310)
git (administrator)
2015-12-18 16:21

Branch CR26993 has been updated forcibly by ibs.

SHA-1: 4439f64f8fb57c43bffb8a9381457bcebc45c7a8
(0049311)
ibs (developer)
2015-12-18 16:34

dear ski, please review CR26993 branch of OCCT git
(0049342)
git (administrator)
2015-12-21 11:03

Branch CR26993 has been updated forcibly by ibs.

SHA-1: 19e1bb3c46b00eea18e75347b4351efaf84c2ff1
(0049358)
ski (developer)
2015-12-21 14:10

No remarks, please proceed.
(0049452)
bugmaster (administrator)
2015-12-22 15:02

Integrated with 27025
(0053004)
git (administrator)
2016-04-17 13:54

Branch CR26993 has been deleted by kgv.

SHA-1: 19e1bb3c46b00eea18e75347b4351efaf84c2ff1

- Related Changesets
occt: master a6874708
Timestamp: 2015-12-14 09:42:05
Author: ibs
Committer: bugmaster
Details ] Diff ]
0026993: Configuration, CMake - use the abstraction level of VTK instead CSF_VTK for their libraries

CSF_VTK removed from CMake meta-projects (this variable is left in EXTERNLIB because it is used by genproj.tcl)
USE_VTK shown if toolkits using VTK involved in the solution
VTK_DIR removed from the advanced variables

Warning messages 'Warning. .../a.hxx~ is not involved into .../FILES' renamed with 'Warning: File .../a.hxx~ is not listed in .../FILES'
mod - adm/cmake/occt_csf.cmake Diff ] File ]
mod - adm/cmake/occt_defs_flags.cmake Diff ] File ]
mod - adm/cmake/occt_macros.cmake Diff ] File ]
mod - adm/cmake/occt_toolkit.cmake Diff ] File ]
mod - adm/cmake/tcl.cmake Diff ] File ]
mod - adm/cmake/vtk.cmake Diff ] File ]
mod - CMakeLists.txt Diff ] File ]
mod - src/TKIVtk/EXTERNLIB Diff ] File ]
mod - src/TKIVtkDraw/EXTERNLIB Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-12-14 16:12 ibs New Issue
2015-12-14 16:12 ibs Assigned To => ibs
2015-12-14 16:21 ibs Relationship added parent of 0026968
2015-12-14 17:16 git Note Added: 0049111
2015-12-18 16:21 git Note Added: 0049310
2015-12-18 16:34 ibs Note Added: 0049311
2015-12-18 16:34 ibs Assigned To ibs => ski
2015-12-18 16:34 ibs Status new => resolved
2015-12-18 16:34 ibs Steps to Reproduce Updated View Revisions
2015-12-21 11:03 git Note Added: 0049342
2015-12-21 14:10 ski Note Added: 0049358
2015-12-21 14:10 ski Assigned To ski => bugmaster
2015-12-21 14:10 ski Status resolved => reviewed
2015-12-22 15:02 bugmaster Note Added: 0049452
2015-12-22 15:02 bugmaster Status reviewed => tested
2015-12-25 19:04 bugmaster Changeset attached => occt master a6874708
2015-12-25 19:04 bugmaster Status tested => verified
2015-12-25 19:04 bugmaster Resolution open => fixed
2016-04-17 13:54 git Note Added: 0053004
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker