MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026947Community[OCCT] OCCT:Data Exchangepublic2015-12-03 12:312016-04-20 15:50
ReporterIstvan Csanady 
Assigned Tobugmaster 
PriorityhighSeverityjust a question 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026947: Data exchange can not be compiled without visualisation any more
DescriptionXCAFDimTolObjects_DimensionModifiersSequence.hxx is now included in STEPConstruct_GDTProperty.hxx, thus the DataExchange framework now depends on the XCAF and thus the visualization modules. I think this is not a desired behavior. It was a really nice feature of OCCT that DataExchange could work without compiling higher level CAF/visualization etc. frameworks.
Steps To ReproduceBranch CR26947 is ready to be reviewed
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0048724)
Istvan Csanady (developer)
2015-12-03 12:33

Note: since DataExchange does not depend on the STEPConstruct_GDTProperty at all, this class could be moved to XCAF, right?
(0049282)
git (administrator)
2015-12-18 14:23

Branch CR26947 has been created by gka.

SHA-1: aaf696153a6099b89b668bc7dd6e7e8197f4e620


Detailed log of new commits:

Author: gka
Date: Fri Dec 18 14:23:26 2015 +0300

    0026947: Data exchange can not be compiled without visualization anyomre
    
    Dependence between STEP translator and visualization occurred due to addition class STEPConstruct_GDTProperty using enumeration from package XCAFDimTolObject.
    In order to avoid this dependence class STEPConstruct_GDTProperty was moved in package STEPCAFControl and was renamed to STEPCAFControl_GDTProperty.
(0049327)
git (administrator)
2015-12-20 15:39

Branch CR26947 has been updated forcibly by abv.

SHA-1: e251fc58c974f288c072fcd698b161c0eb0c235c
(0049328)
abv (manager)
2015-12-20 15:41

No remarks, please test. It is sufficient to check only compilation, as no changes have been made in the code. Branch CR26947 is rebased on current master.
(0052993)
git (administrator)
2016-04-17 13:54

Branch CR26947 has been deleted by kgv.

SHA-1: e251fc58c974f288c072fcd698b161c0eb0c235c

- Related Changesets
occt: master 727b5ad9
Timestamp: 2015-12-18 11:23:26
Author: gka
Committer: bugmaster
Details ] Diff ]
0026947: Data exchange can not be compiled without visualization anyomre

Dependence between STEP translator and visualization occurred due to addition class STEPConstruct_GDTProperty using enumeration from package XCAFDimTolObject.
In order to avoid this dependence class STEPConstruct_GDTProperty was moved in package STEPCAFControl and was renamed to STEPCAFControl_GDTProperty.
mod - src/STEPCAFControl/FILES Diff ] File ]
mod - src/STEPCAFControl/STEPCAFControl_Reader.cxx Diff ] File ]
mod - src/STEPCAFControl/STEPCAFControl_Writer.cxx Diff ] File ]
mod - src/STEPConstruct/FILES Diff ] File ]
mod - src/StepDimTol/FILES Diff ] File ]
mod - src/XDEDRAW/XDEDRAW_GDTs.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-12-03 12:31 Istvan Csanady New Issue
2015-12-03 12:31 Istvan Csanady Assigned To => gka
2015-12-03 12:33 Istvan Csanady Note Added: 0048724
2015-12-18 10:33 abv Priority normal => high
2015-12-18 10:33 abv Status new => assigned
2015-12-18 10:51 abv Summary Data exchange can not be compiled without visualisation anyomre => Data exchange can not be compiled without visualisation any more
2015-12-18 14:23 git Note Added: 0049282
2015-12-18 14:25 gka Assigned To gka => abv
2015-12-18 14:25 gka Status assigned => resolved
2015-12-18 14:25 gka Steps to Reproduce Updated View Revisions
2015-12-20 15:39 git Note Added: 0049327
2015-12-20 15:41 abv Note Added: 0049328
2015-12-20 15:41 abv Assigned To abv => bugmaster
2015-12-20 15:41 abv Status resolved => reviewed
2015-12-21 15:07 bugmaster Status reviewed => tested
2015-12-25 19:04 bugmaster Changeset attached => occt master 727b5ad9
2015-12-25 19:04 bugmaster Status tested => verified
2015-12-25 19:04 bugmaster Resolution open => fixed
2016-04-17 13:54 git Note Added: 0052993
2016-04-20 15:42 user533 Fixed in Version => 7.0.0
2016-04-20 15:50 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker