MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026928Community[OCCT] OCCT:Meshpublic2015-11-25 15:272018-11-11 12:01
ReporterMarkus 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0026928: Edges are meshed too coarsly
DescriptionIn the appended case, the edges seem to be discretized too coarsly by BRepMesh_IncrementalMesh. It is especially visible because the corresponding surface, which is created from the edges by ThruSections is meshed much finer.

If you meassure the distance between the curve and its tessellation, it seems to be bigger than the linear deflection.
Steps To Reproducebugs moddata_3 bug27356


#manual steps
restore comp.brep c

vinit

vdisplay c

vfit

vsetdispmode c 1

# These are the Parameters the shape was originally meshed with => no Change
incmesh c 0.715 -a 11.459

vdisplay -redisplay c

incmesh c 0.5 -a 11.459

vdisplay -redisplay c

incmesh c 0.3 -a 11.459

vdisplay -redisplay c

incmesh c 0.1 -a 11.459

vdisplay -redisplay c
# only here the curve looks better
TagsNo tags attached.
Test case numberbugs mesh bug26928
Attached Files? file icon comp.brep (73,602 bytes) 2015-11-25 15:27
png file icon too coarse edges.png (16,840 bytes) 2015-11-25 15:28

- Relationships
related to 0026532closedbugmaster Community Meshing of edge with minSize parameter leads to incorrect result 
child of 0027356closedbugmaster Open CASCADE BRepTools::Clean() does not clean free edges from Poly_Polygon3D 

-  Notes
(0048569)
Timo (developer)
2015-11-25 15:38

This problem is similar to 0026532 because in both cases edges are meshed too coarsly. But the current Problem has nothing to do with the minSize parameter.
(0052404)
oan (developer)
2016-04-05 17:14

Initial shape contains triangulation for face and 3D polygon for free edges. 3D polygons has deflection 0.184044204640587 that is less than values specified in "steps to reproduce" - 0.715, 0.5, 0.3. BRepMesh checks deflection of existing polygonal data and generates new one only if it is greater than specified value. That is why much more appropriate polygons are generated when value 0.1 is used. Like this, it is necessary to clean up all existing data before call to incmesh in order to produce correct result.
(0069421)
mkv (tester)
2017-08-15 18:55

Problem described in issue is reproduced on current state of OCCT.
(0080659)
oan (developer)
2018-11-02 18:30

Please check on current master.
(0080835)
nbv (developer)
2018-11-07 15:53

The problem is still reproduced. See http://occt-tests/IR-2018-11-02-OCCT/Windows-64-VC14/bugs/mesh/bug26928.html [^]
(0080847)
oan (developer)
2018-11-07 16:24

Please note that results are different comparing to scenario given in Steps To Reproduce.
(0080848)
nbv (developer)
2018-11-07 16:57

Dear Markus,

In the current Dev version, you should use "tclean" command to vanish existing mesh (already stored in the file). After that, the shape will look OK.
(0080851)
git (administrator)
2018-11-07 17:00

Branch CR26928 has been created by nbv.

SHA-1: 35bac4e9707e66d025daafecd9ac5ed1166d991d


Detailed log of new commits:

Author: nbv
Date: Wed Nov 7 16:56:57 2018 +0300

    0026928: Edges are meshed too coarsly
    
    Adding test case for the problem.
    The issue has been fixed by a patch for #26106.
(0080873)
git (administrator)
2018-11-07 17:27

Branch CR26928 has been updated forcibly by nbv.

SHA-1: 4cc36b23a46a182998326841c3dd6e55edcee296
(0080881)
git (administrator)
2018-11-07 17:54

Branch CR26928 has been updated forcibly by nbv.

SHA-1: dd76be461adefc1407021cc40d4907f20100f90f
(0080898)
git (administrator)
2018-11-07 18:15

Branch CR26928 has been updated forcibly by nbv.

SHA-1: ec90ab79cf7abd7673e263bd554824643ad7f0ba
(0080899)
nbv (developer)
2018-11-07 18:16

Dear Mikhail,

Please review the branch CR26928.

Test results are here:
Windows: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]

Linux: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]
(0080926)
msv (developer)
2018-11-08 11:40

Please redesign the test:
- remove checkcolor command
- make view showing more detailed picture.
(0080932)
git (administrator)
2018-11-08 12:25

Branch CR26928 has been updated forcibly by nbv.

SHA-1: 962b8ae099daad74abff5f2dfdae341fa45d7d7a
(0080934)
nbv (developer)
2018-11-08 12:28

Done. Please review the branch CR26928 again.
(0080975)
msv (developer)
2018-11-08 17:19

Reviewed.
(0080981)
bugmaster (administrator)
2018-11-08 17:41

Update testing case
(0081028)
git (administrator)
2018-11-11 12:01

Branch CR26928 has been deleted by inv.

SHA-1: 962b8ae099daad74abff5f2dfdae341fa45d7d7a

- Related Changesets
occt: master 080fcebf
Timestamp: 2018-11-07 13:56:57
Author: nbv
Committer: bugmaster
Details ] Diff ]
0026928: Edges are meshed too coarsly

Adding test case for the problem.
The issue has been fixed by a patch for #26106.
mod - tests/bugs/mesh/bug26928 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-25 15:27 Timo New Issue
2015-11-25 15:27 Timo Assigned To => oan
2015-11-25 15:27 Timo File Added: comp.brep
2015-11-25 15:28 Timo File Added: too coarse edges.png
2015-11-25 15:29 Timo Relationship added related to 0026532
2015-11-25 15:38 Timo Note Added: 0048569
2015-12-18 11:50 abv Target Version 7.0.0 => 7.1.0
2016-04-05 17:04 oan Relationship added child of 0027356
2016-04-05 17:14 oan Note Added: 0052404
2016-04-15 18:17 oan Steps to Reproduce Updated View Revisions
2016-11-03 17:21 abv Target Version 7.1.0 => 7.2.0
2017-05-31 15:38 Timo Reporter Timo => Markus
2017-07-20 12:43 oan Target Version 7.2.0 => 7.3.0
2017-08-15 18:55 mkv Test case number => bugs mesh bug26928
2017-08-15 18:55 mkv Note Added: 0069421
2018-02-08 22:40 abv Target Version 7.3.0 => 7.4.0*
2018-11-02 18:30 oan Note Added: 0080659
2018-11-02 18:30 oan Assigned To oan => bugmaster
2018-11-02 18:30 oan Status new => feedback
2018-11-07 15:53 nbv Assigned To bugmaster => oan
2018-11-07 15:53 nbv Note Added: 0080835
2018-11-07 16:24 oan Note Added: 0080847
2018-11-07 16:25 oan Assigned To oan => nbv
2018-11-07 16:33 nbv Steps to Reproduce Updated View Revisions
2018-11-07 16:57 nbv Note Added: 0080848
2018-11-07 17:00 git Note Added: 0080851
2018-11-07 17:27 git Note Added: 0080873
2018-11-07 17:54 git Note Added: 0080881
2018-11-07 18:15 git Note Added: 0080898
2018-11-07 18:16 nbv Note Added: 0080899
2018-11-07 18:16 nbv Assigned To nbv => msv
2018-11-07 18:16 nbv Status feedback => resolved
2018-11-08 11:40 msv Note Added: 0080926
2018-11-08 11:40 msv Assigned To msv => nbv
2018-11-08 11:40 msv Status resolved => assigned
2018-11-08 12:25 git Note Added: 0080932
2018-11-08 12:28 nbv Note Added: 0080934
2018-11-08 12:28 nbv Assigned To nbv => msv
2018-11-08 12:28 nbv Status assigned => resolved
2018-11-08 17:19 msv Note Added: 0080975
2018-11-08 17:19 msv Assigned To msv => bugmaster
2018-11-08 17:19 msv Status resolved => reviewed
2018-11-08 17:41 bugmaster Note Added: 0080981
2018-11-08 17:41 bugmaster Status reviewed => tested
2018-11-11 11:52 bugmaster Changeset attached => occt master 080fcebf
2018-11-11 11:52 bugmaster Status tested => verified
2018-11-11 11:52 bugmaster Resolution open => fixed
2018-11-11 12:01 git Note Added: 0081028


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker