MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026918Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2015-11-24 10:292016-12-09 16:37
Reporternbv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0026918: GeomLib_CheckCurveOnSurface cannot compute distance if 3D-curve is periodic
DescriptionThe reason is in the method GeomLib_CheckCurveOnSurface::Perform(...).

Check

  if( (myCurve->FirstParameter() > myFirst) ||
      (myCurve->LastParameter() < myLast) ||
      (thePCurve->FirstParameter() > myFirst) ||
      (thePCurve->LastParameter() < myLast))
  {
    myErrorStatus = 2;
    return;
  }

Sometimes, on periodic curves this condition returns TRUE (see Steps To Reproduce).
Steps To Reproducetest bugs modalg_2 bug22967
explode result f
explode result_1 e

xdistef result_1_1 result_1
#Tolerance cannot be computed

explode result_2 e
xdistef result_2_3 result_2
#Tolerance cannot be computed

explode result_3 e
xdistef result_3_2 result_3
#Tolerance cannot be computed

xdistef result_3_3 result_3
#Tolerance cannot be computed

explode result_4 e
xdistef result_4_1 result_4
#Tolerance cannot be computed

explode result_5 e
xdistef result_5_1 result_5
#Tolerance cannot be computed
TagsNo tags attached.
Test case numberbugs modalg_2 bug22967
Attached Files

- Relationships

-  Notes
(0052512)
nbv (developer)
2016-04-08 11:08

Dear Mikhail,

The problem is not reproduced on the current MASTER.
(0052633)
msv (developer)
2016-04-12 17:14

Please create test case.
(0052639)
git (administrator)
2016-04-12 18:16

Branch CR26918 has been created by nbv.

SHA-1: 0d7e463ecbdc334bc954253dc2ae005143c63d1e


Detailed log of new commits:

Author: nbv
Date: Tue Apr 12 18:16:00 2016 +0300

    0026918: GeomLib_CheckCurveOnSurface cannot compute distance if 3D-curve is periodic
    
    Creation of test case for this issue.
(0052640)
nbv (developer)
2016-04-12 18:16

Dear Mikhail,

Please review CR26918 branch.
(0052656)
msv (developer)
2016-04-13 00:49

Reviewed.
Dear bugmaster, please check the test case and integrate.
(0052677)
mkv (tester)
2016-04-13 17:03

Dear BugMaster,
following test case is good

bugs modalg_2 bug22967: BAD (known problem)
(0052678)
mkv (tester)
2016-04-13 17:04

Dear BugMaster,
Branch CR26918 is TESTED.
(0053187)
git (administrator)
2016-04-17 14:31

Branch CR26918 has been deleted by kgv.

SHA-1: 0d7e463ecbdc334bc954253dc2ae005143c63d1e

- Related Changesets
occt: master 309bad28
Timestamp: 2016-04-12 15:16:00
Author: nbv
Committer: bugmaster
Details ] Diff ]
0026918: GeomLib_CheckCurveOnSurface cannot compute distance if 3D-curve is periodic

Creation of test case for this issue.
mod - tests/bugs/modalg_2/bug22967 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-24 10:29 nbv New Issue
2015-11-24 10:29 nbv Assigned To => msv
2015-11-24 10:30 nbv Relationship added related to 0025709
2016-02-05 16:40 nbv Relationship added related to 0027129
2016-04-08 11:06 nbv Steps to Reproduce Updated View Revisions
2016-04-08 11:08 nbv Note Added: 0052512
2016-04-08 11:08 nbv Status new => resolved
2016-04-12 17:14 msv Note Added: 0052633
2016-04-12 17:14 msv Assigned To msv => nbv
2016-04-12 17:14 msv Status resolved => assigned
2016-04-12 18:16 git Note Added: 0052639
2016-04-12 18:16 nbv Note Added: 0052640
2016-04-12 18:16 nbv Assigned To nbv => msv
2016-04-12 18:16 nbv Status assigned => resolved
2016-04-13 00:49 msv Note Added: 0052656
2016-04-13 00:49 msv Assigned To msv => bugmaster
2016-04-13 00:49 msv Status resolved => reviewed
2016-04-13 10:49 mkv Assigned To bugmaster => mkv
2016-04-13 17:03 mkv Note Added: 0052677
2016-04-13 17:04 mkv Note Added: 0052678
2016-04-13 17:04 mkv Assigned To mkv => bugmaster
2016-04-13 17:04 mkv Status reviewed => tested
2016-04-13 17:04 mkv Test case number => bugs modalg_2 bug22967
2016-04-15 12:16 bugmaster Changeset attached => occt master 309bad28
2016-04-15 12:16 bugmaster Status tested => verified
2016-04-15 12:16 bugmaster Resolution open => fixed
2016-04-17 14:31 git Note Added: 0053187
2016-12-09 16:33 user533 Status verified => closed
2016-12-09 16:37 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker