MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026889Community[OCCT] OCCT:Meshpublic2015-11-17 20:032018-11-11 12:00
ReporterIstvan Csanady 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0026889: Very poor mesh result from shape
DescriptionAfter importing and visualizing the attached STEP file, the resulting mesh is very poor. The geometry is created in OCCT, and the same happens when it is imported from .brep file format.
Steps To ReproduceTest case has already been created.
TagsNo tags attached.
Test case numberbugs mesh bug26889, perf/mesh/bug26889_1
Attached Files? file icon export.step (189,761 bytes) 2015-11-17 20:03
png file icon bug26889-draw.png (109,721 bytes) 2015-11-17 22:42
jpg file icon IMG_0002.jpg (507,336 bytes) 2015-11-18 11:31
jpg file icon IMG_0003.jpg (600,144 bytes) 2015-11-18 11:31

- Relationships
duplicate of 0026965verifiedbugmaster Community BRepMesh_IncrementalMesh hangs, and consumes infinite memory 

-  Notes
(0048323)
abv (manager)
2015-11-17 23:26
edited on: 2015-11-17 23:26

I do not see any essential problem with the mesh, see attached image (made by displaying shape in DRAW). However, IMHO the mesh takes too long to be built (~ 60 sec with default parameters on my machine: CPU i7-4790 3.2GHz, Win 10, VC10 x64 Release). With command incmesh:

| Deflection | CPU, sec |
-------------------------
| 1.0 | 4.5 |
| 0.1 | 36 |
| 0.01 | 990 |

(0048336)
Istvan Csanady (developer)
2015-11-18 11:31
edited on: 2015-11-18 11:35

It is slow for me too, and the memory consumption is extremely high as well. See the attached images for the result I get. Deflection value is 0.1

(0069367)
mkv (tester)
2017-08-14 20:42

Problem described in issue is reproduced on current state of OCCT.
(0080663)
oan (developer)
2018-11-02 18:44

On Master version:

| Deflection | CPU, sec |
-------------------------
| 1.0 | 3.2 |
| 0.1 | 15.7 |
| 0.01 | 100.7 |

On IR-2018-11-02 version:
| Deflection | CPU, sec |
-------------------------
| 1.0 | 3.7 |
| 0.1 | 8.9 |
| 0.01 | 51.6 |
(0080751)
abv (manager)
2018-11-06 14:54

I propose we shall close this issue, adding a test case to measure performance with deflections as used above (1.0, 0.1, 0.01).
(0080827)
git (administrator)
2018-11-07 14:25

Branch CR26889 has been created by nbv.

SHA-1: ad2d4e206ececb10f5c8b5333968f93b527035ce


Detailed log of new commits:

Author: nbv
Date: Wed Nov 7 14:19:10 2018 +0300

    0026889: Very poor mesh result from shape
    
    Only test cases have been created.
(0080861)
git (administrator)
2018-11-07 17:18

Branch CR26889 has been updated forcibly by nbv.

SHA-1: 47f0cdd04f9815a15f3aeb15a434c1ea6c0e8820
(0080862)
git (administrator)
2018-11-07 17:19

Branch CR26889 has been updated by nbv.

SHA-1: cc7530b768c2d668420489fdfe20ec30a7cf954b


No new revisions were added by this update.

(0080878)
git (administrator)
2018-11-07 17:50

Branch CR26889 has been updated forcibly by nbv.

SHA-1: affac322f69e29ff6eb975777ebf45dfe5eda03f
(0080896)
nbv (developer)
2018-11-07 18:12

Dear Mikhail,

Please review the branch CR26889.

Test results are here:
Windows: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]

Linux: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]
(0080917)
msv (developer)
2018-11-08 10:41

- Remove dlog commands
- Update the header
(0080918)
nbv (developer)
2018-11-08 10:56

Done. Please review CR26889 again.
(0080919)
git (administrator)
2018-11-08 10:56

Branch CR26889 has been updated forcibly by nbv.

SHA-1: 5b82ae176fb59a61e9e816cc48cb6dac784cdbd9
(0080931)
msv (developer)
2018-11-08 12:20

Reviewed.
(0080935)
msv (developer)
2018-11-08 12:31

The test gives warning
Warning, unknown argument '-AUTOTRIAN'
So, the command was not done.
(0080951)
git (administrator)
2018-11-08 14:31

Branch CR26889 has been updated forcibly by nbv.

SHA-1: 8b0959cdda25077ffae2f8f1e89f3591a668be33
(0080953)
nbv (developer)
2018-11-08 14:31

Done. Please review CR26889 again.
(0080984)
msv (developer)
2018-11-08 18:14

Reviewed.
(0081026)
git (administrator)
2018-11-11 12:00

Branch CR26889 has been deleted by inv.

SHA-1: 8b0959cdda25077ffae2f8f1e89f3591a668be33

- Related Changesets
occt: master a385e6d1
Timestamp: 2018-11-07 11:19:10
Author: nbv
Committer: bugmaster
Details ] Diff ]
0026889: Very poor mesh result from shape

Adding test case for the problem.
The issue has been fixed by a patch for #26106.
add - tests/perf/mesh/bug26889_1 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-17 20:03 Istvan Csanady New Issue
2015-11-17 20:03 Istvan Csanady Assigned To => msv
2015-11-17 20:03 Istvan Csanady File Added: export.step
2015-11-17 22:41 abv Target Version 7.0.0 => 7.1.0
2015-11-17 22:42 abv File Added: bug26889-draw.png
2015-11-17 23:26 abv Note Added: 0048323
2015-11-17 23:26 abv Note Edited: 0048323 View Revisions
2015-11-18 10:34 msv Assigned To msv => oan
2015-11-18 10:34 msv Category OCCT:Modeling Algorithms => OCCT:Mesh
2015-11-18 11:31 Istvan Csanady File Added: IMG_0002.jpg
2015-11-18 11:31 Istvan Csanady File Added: IMG_0003.jpg
2015-11-18 11:31 Istvan Csanady Note Added: 0048336
2015-11-18 11:35 Istvan Csanady Note Edited: 0048336 View Revisions
2016-02-08 14:06 oan Relationship added duplicate of 0026965
2016-10-25 17:42 oan Target Version 7.1.0 => 7.2.0
2016-11-01 13:52 oan Relationship added related to 0026106
2017-07-20 12:43 oan Target Version 7.2.0 => 7.3.0
2017-08-14 20:42 mkv Test case number => bugs mesh bug26889
2017-08-14 20:42 mkv Note Added: 0069367
2018-02-25 21:14 abv Target Version 7.3.0 => 7.4.0*
2018-11-02 18:44 oan Note Added: 0080663
2018-11-02 18:44 oan Assigned To oan => abv
2018-11-02 18:44 oan Status new => feedback
2018-11-06 14:53 abv Assigned To abv => msv
2018-11-06 14:54 abv Note Added: 0080751
2018-11-06 15:53 msv Assigned To msv => nbv
2018-11-07 14:25 git Note Added: 0080827
2018-11-07 17:18 git Note Added: 0080861
2018-11-07 17:19 git Note Added: 0080862
2018-11-07 17:50 git Note Added: 0080878
2018-11-07 18:12 nbv Note Added: 0080896
2018-11-07 18:12 nbv Assigned To nbv => msv
2018-11-07 18:12 nbv Status feedback => resolved
2018-11-07 18:12 nbv Steps to Reproduce Updated View Revisions
2018-11-08 10:41 msv Note Added: 0080917
2018-11-08 10:41 msv Assigned To msv => nbv
2018-11-08 10:41 msv Status resolved => assigned
2018-11-08 10:56 nbv Note Added: 0080918
2018-11-08 10:56 git Note Added: 0080919
2018-11-08 10:56 nbv Assigned To nbv => msv
2018-11-08 10:56 nbv Status assigned => resolved
2018-11-08 12:20 msv Note Added: 0080931
2018-11-08 12:20 msv Assigned To msv => bugmaster
2018-11-08 12:20 msv Status resolved => reviewed
2018-11-08 12:31 msv Note Added: 0080935
2018-11-08 12:31 msv Assigned To bugmaster => nbv
2018-11-08 12:31 msv Status reviewed => assigned
2018-11-08 14:31 git Note Added: 0080951
2018-11-08 14:31 nbv Note Added: 0080953
2018-11-08 14:31 nbv Status assigned => resolved
2018-11-08 14:50 nbv Assigned To nbv => msv
2018-11-08 18:14 msv Note Added: 0080984
2018-11-08 18:14 msv Assigned To msv => bugmaster
2018-11-08 18:14 msv Status resolved => reviewed
2018-11-09 15:07 bugmaster Test case number bugs mesh bug26889 => bugs mesh bug26889, perf/mesh/bug26889_1
2018-11-09 15:08 bugmaster Status reviewed => tested
2018-11-11 11:52 bugmaster Changeset attached => occt master a385e6d1
2018-11-11 11:52 bugmaster Status tested => verified
2018-11-11 11:52 bugmaster Resolution open => fixed
2018-11-11 12:00 git Note Added: 0081026


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker