MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026854Open CASCADE[OCCT] OCCT:Configurationpublic2015-11-09 07:472016-04-20 15:51
Reporterabv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026854: Use -Wextra with GCC
DescriptionNow only a few GCC warnings appear during OCCT build, and it is reasonable to enable option -Wextra for GCC to see additional warnings, which often can help to spot problematic places in the code.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0025078closedabv Community Coding rules - eliminate GCC warning -Wclobbered 
related to 0026852closedabv Open CASCADE Coding - compiler warnings issued by GCC 5.2.1 
related to 0026850closedabv Open CASCADE Replace nested instantiations of TCollection generic classes by NCollection templates 
related to 0026783closedabv Open CASCADE Coding rules - eliminate GCC warning -Wunused-but-set-parameter 
related to 0026861closedbugmaster Open CASCADE Configuration, CMake - enable -Wall warnings when using CLang 

-  Notes
(0047934)
git (administrator)
2015-11-09 07:48

Branch CR26854 has been created by abv.

SHA-1: 3ffdbb1fb6c5b4232bd93d764fc282bff01f4585


Detailed log of new commits:

Author: abv
Date: Mon Nov 9 07:47:29 2015 +0300

    0026854: Use -Wextra with GCC
    
    Added option -Wextra for GCC compilation
(0047935)
abv (manager)
2015-11-09 07:50

Fix pushed to CR26854, please review
(0047937)
git (administrator)
2015-11-09 09:35

Branch CR26854 has been updated forcibly by abv.

SHA-1: 7cf5ebc97c77e9473a3018a4acea927aa9b1defa
(0047953)
git (administrator)
2015-11-09 15:05

Branch CR26854 has been updated forcibly by abv.

SHA-1: 7dc2c1656acaf938ba302521ab7741af3947a4a7
(0048006)
mkv (tester)
2015-11-10 15:15

Dear BugMaster,
Branch CR26854 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 7dc2c1656acaf938ba302521ab7741af3947a4a7

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 137 (149 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 93063261 / 92254766 [+0.88%]
Total CPU difference: 19772.27999999972 / 19653.97999999985 [+0.60%]
products component :
Total MEMORY difference: 26222725 / 26273564 [-0.19%]
Total CPU difference: 7446.710000000005 / 7540.919999999997 [-1.25%]

Testing on Windows:
occt component :
http://occt-tests/CR26854-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]
CPU bugs vis bug24412_2: 1.4196091 / 0.1248008 [+1037.50%]
CPU bugs vis bug24133_2: 0.8580055 / 0.2028013 [+323.08%]

Total MEMORY difference: 58029997 / 58100259 [-0.12%]
Total CPU difference: 18396.99512869884 / 18063.71459229889 [+1.85%]
products component :
Total MEMORY difference: 17113291 / 17173078 [-0.35%]
Total CPU difference: 5655.675854099972 / 5625.708061999975 [+0.53%]

There are no differences in images found by testdiff.
(0048007)
mkv (tester)
2015-11-10 15:16

Dear abv,
Branch CR26854 has been rejected due to:
- CPU problem
(0048013)
mkv (tester)
2015-11-10 16:24

Dear BugMaster,
0026780 was not fixed in branch CR26854 :

http://jenkins-test-03.nnov.opencascade.com:8080/view/Warnings/job/CR26854+master-OCCT-MacOS-opt-compile/3/warnings17Result/file.244059283/ [^]
ViewerTest.cxx:5753, GNU C Compiler 4 (gcc), Priority: Normal
illegal character encoding in string literal [-Winvalid-source-encoding]
ViewerTest.cxx:5758, GNU C Compiler 4 (gcc), Priority: Normal
illegal character encoding in string literal [-Winvalid-source-encoding]

http://jenkins-test-03.nnov.opencascade.com:8080/view/Warnings/job/CR26854+master-OCCT-MacOS-opt-compile/3/warnings17Result/file.2061097649/ [^]
Font_TextFormatter.cxx:49, GNU C Compiler 4 (gcc), Priority: Normal
unused function 'floor' [-Wunused-function]

http://jenkins-test-03.nnov.opencascade.com:8080/view/Warnings/job/CR26854+master-OCCT-MacOS-opt-compile/3/warnings17Result/file.-1096960260/ [^]
TopOpeBRep_FFDumper.hxx:81, GNU C Compiler 4 (gcc), Priority: Normal
private field 'myEn1' is not used [-Wunused-private-field]
TopOpeBRep_FFDumper.hxx:82, GNU C Compiler 4 (gcc), Priority: Normal
private field 'myEn2' is not used [-Wunused-private-field]
TopOpeBRep_FFDumper.hxx:83, GNU C Compiler 4 (gcc), Priority: Normal
private field 'myLineIndex' is not used [-Wunused-private-field][ 41%] Building CXX object src/TKBool/CMakeFiles/TKBool.dir/__/TopOpeBRep/TopOpeBRep_GeomTool.cxx.o
(0048037)
git (administrator)
2015-11-11 09:32

Branch CR26854 has been updated by abv.

SHA-1: c8aa73241b80a1e6683e60e5968f9e9da60079c9


Detailed log of new commits:

Author: abv
Date: Wed Nov 11 09:32:41 2015 +0300

    0026780: Coding rules - eliminate warnings on Linux and Mac
    
    Fixed a few remaining warnings found by GCC, CLang, and VC++ 14 (recent changes)

(0048039)
git (administrator)
2015-11-11 09:43

Branch CR26854 has been updated forcibly by abv.

SHA-1: f2139a7f0fb5cb3851cbb192d585121c641270f6
(0048044)
git (administrator)
2015-11-11 10:59

Branch CR26854_1 has been created by inv.

SHA-1: f2139a7f0fb5cb3851cbb192d585121c641270f6


No new revisions were added by this update.
(0048061)
mkv (tester)
2015-11-11 14:33

Dear BugMaster,
following issues are fixed in branch CR26854_1 :
0024567
0025078
0026178
0026780
0026783
0026843
0026850
0026852
(0053126)
git (administrator)
2016-04-17 14:19

Branch CR26854 has been deleted by kgv.

SHA-1: f2139a7f0fb5cb3851cbb192d585121c641270f6
(0053127)
git (administrator)
2016-04-17 14:19

Branch CR26854_1 has been deleted by kgv.

SHA-1: f2139a7f0fb5cb3851cbb192d585121c641270f6

- Related Changesets
occt: master 7dc2c165
Timestamp: 2015-11-09 04:47:29
Author: abv
Committer: abv
Details ] Diff ]
0026854: Use -Wextra with GCC

Added option -Wextra for GCC compilation
mod - adm/cmake/occt_defs_flags.cmake Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-09 07:47 abv New Issue
2015-11-09 07:47 abv Assigned To => bugmaster
2015-11-09 07:48 git Note Added: 0047934
2015-11-09 07:48 abv Relationship added related to 0025078
2015-11-09 07:48 abv Relationship added related to 0026852
2015-11-09 07:49 abv Relationship added related to 0026850
2015-11-09 07:49 abv Relationship added related to 0026783
2015-11-09 07:50 abv Note Added: 0047935
2015-11-09 07:50 abv Status new => resolved
2015-11-09 07:50 abv Steps to Reproduce Updated View Revisions
2015-11-09 09:35 git Note Added: 0047937
2015-11-09 09:37 kgv Status resolved => reviewed
2015-11-09 13:56 bugmaster Assigned To bugmaster => mkv
2015-11-09 15:05 git Note Added: 0047953
2015-11-10 15:15 mkv Note Added: 0048006
2015-11-10 15:16 mkv Note Added: 0048007
2015-11-10 15:16 mkv Assigned To mkv => abv
2015-11-10 15:16 mkv Status reviewed => feedback
2015-11-10 15:16 mkv Test case number => Not needed
2015-11-10 16:24 mkv Note Added: 0048013
2015-11-11 09:32 git Note Added: 0048037
2015-11-11 09:43 git Note Added: 0048039
2015-11-11 09:55 kgv Relationship added related to 0026861
2015-11-11 10:59 git Note Added: 0048044
2015-11-11 14:33 mkv Note Added: 0048061
2015-11-13 11:53 abv Changeset attached => occt master 7dc2c165
2015-11-13 11:53 abv Status feedback => verified
2015-11-13 11:53 abv Resolution open => fixed
2016-04-17 14:19 git Note Added: 0053126
2016-04-17 14:19 git Note Added: 0053127
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:51 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker