View Issue Details

IDProjectCategoryView StatusLast Update
0026848Open CASCADEOCCT:Modeling Algorithmspublic2016-04-20 15:50
Reporteraml Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version6.9.1 
Target Version7.0.0Fixed in Version7.0.0 
Summary0026848: Result of BO depends on arguments order
DescriptionAfter integration 25929 there is new regression. It is necessary to fix it.
Steps To Reproducetake shapes from test "bugs modalg_3 bug600"

bcommon result a b - OK
bcommon result b a - BAD
TagsNo tags attached.
Test case numberbugs modalg_3 bug600, modalg_6 bug26848

Relationships

related to 0025929 closedbugmaster Make Approx_ComputeLine algorithm adaptive 

Activities

nbv

2015-12-07 15:54

developer   ~0048803

Dear Mikhail,

I think we should close this issue because the problem is not reproduced on the current MASTER.

msv

2015-12-07 16:56

developer   ~0048813

Dear bugmaster, please close this bug.

bugmaster

2015-12-08 10:21

administrator   ~0048824

Dear APV,

Please create testing case

nbv

2015-12-08 10:24

developer   ~0048825

Last edited: 2015-12-08 10:25

Dear Alexey,

I think, we shall correct existing test case "bugs modalg_3 bug600". We do not need in creation new one.

msv

2015-12-08 11:54

developer   ~0048827

Dear Nikolay, please propose your version of this test case in a new branch.

git

2015-12-08 13:58

administrator   ~0048838

Branch CR26848 has been created by nbv.

SHA-1: 7df6d82f2652cc1b9c21f07d8c6f83561bf244d5


Detailed log of new commits:

Author: nbv
Date: Tue Dec 8 13:52:30 2015 +0300

    0026848: Result of BO depends on arguments order
    
    Creation test case for this issue

nbv

2015-12-08 13:59

developer   ~0048839

Dear Mikhail,

Please review CR26848 branch

git

2015-12-08 14:26

administrator   ~0048850

Branch CR26848 has been updated forcibly by nbv.

SHA-1: 9d9311ce0eeb8203ec14b42ce3c39bef8c167a48

msv

2015-12-08 14:28

developer   ~0048851

Reviewed.

git

2015-12-10 16:50

administrator   ~0048987

Branch CR26848 has been updated by mkv.

SHA-1: 50297f0ca8efe6a95b5f9e3f8ae45442e892f9fb


Detailed log of new commits:

Author: mkv
Date: Thu Dec 10 16:50:01 2015 +0300

    Test cases for CR26848

mkv

2015-12-10 17:07

tester   ~0048989

Dear BugMaster,

Its are OK:
http://occt-tests/CR26949-master-occt-64/Debian70-64/bugs/modalg_3/bug600.html
http://occt-tests/CR26949-master-occt-64/Windows-64-VC10/bugs/modalg_3/bug600.html
bugs modalg_3 bug600: OK

http://occt-tests/CR26949-master-occt-64/Debian70-64/bugs/modalg_6/bug26848.html
http://occt-tests/CR26949-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug26848.html
bugs modalg_6 bug26848: OK


Branch CR26848 is TESTED.

git

2016-04-17 14:01

administrator   ~0053025

Branch CR26848 has been deleted by kgv.

SHA-1: 50297f0ca8efe6a95b5f9e3f8ae45442e892f9fb

Related Changesets

occt: master ed9ce677

2015-12-08 10:52:30

nbv


Committer: bugmaster Details Diff
0026848: Result of BO depends on arguments order

Correction test case for this issue

Test cases for CR26848
Affected Issues
0026848
mod - tests/bugs/modalg_3/bug600 Diff File
add - tests/bugs/modalg_6/bug26848 Diff File

Issue History

Date Modified Username Field Change
2015-11-06 13:20 aml New Issue
2015-11-06 13:20 aml Assigned To => msv
2015-11-06 13:20 aml Relationship added related to 0025929
2015-12-07 15:54 nbv Note Added: 0048803
2015-12-07 15:54 nbv Status new => feedback
2015-12-07 16:56 msv Note Added: 0048813
2015-12-07 16:56 msv Assigned To msv => bugmaster
2015-12-07 16:56 msv Resolution open => unable to reproduce
2015-12-08 10:21 bugmaster Note Added: 0048824
2015-12-08 10:21 bugmaster Assigned To bugmaster => apv
2015-12-08 10:21 bugmaster Status feedback => assigned
2015-12-08 10:22 bugmaster Assigned To apv => msv
2015-12-08 10:22 bugmaster Status assigned => resolved
2015-12-08 10:22 bugmaster Assigned To msv => bugmaster
2015-12-08 10:22 bugmaster Status resolved => reviewed
2015-12-08 10:23 bugmaster Assigned To bugmaster => apv
2015-12-08 10:23 bugmaster Status reviewed => feedback
2015-12-08 10:24 nbv Note Added: 0048825
2015-12-08 10:25 nbv Note Edited: 0048825
2015-12-08 11:54 msv Note Added: 0048827
2015-12-08 11:54 msv Assigned To apv => nbv
2015-12-08 11:54 msv Status feedback => assigned
2015-12-08 13:58 git Note Added: 0048838
2015-12-08 13:59 nbv Note Added: 0048839
2015-12-08 13:59 nbv Assigned To nbv => msv
2015-12-08 13:59 nbv Status assigned => resolved
2015-12-08 14:26 git Note Added: 0048850
2015-12-08 14:28 msv Note Added: 0048851
2015-12-08 14:28 msv Assigned To msv => bugmaster
2015-12-08 14:28 msv Status resolved => reviewed
2015-12-08 15:36 mkv Assigned To bugmaster => mkv
2015-12-10 16:50 git Note Added: 0048987
2015-12-10 17:07 mkv Note Added: 0048989
2015-12-10 17:07 mkv Assigned To mkv => bugmaster
2015-12-10 17:07 mkv Status reviewed => tested
2015-12-10 17:07 mkv Test case number => bugs modalg_3 bug600, modalg_6 bug26848
2015-12-18 15:25 bugmaster Changeset attached => occt master ed9ce677
2015-12-18 15:25 bugmaster Status tested => verified
2015-12-18 15:25 bugmaster Resolution unable to reproduce => fixed
2016-04-17 14:01 git Note Added: 0053025
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed