MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026838Open CASCADE[OCCT] OCCT:Modeling Datapublic2015-11-03 15:442016-04-20 15:50
Reporterazv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026838: Using GeomEvaluators for calculation of values of curves
DescriptionDuring implementation of adaptors (issue 0026252) for complex surfaces (Offset surface, surface of extrusion, surface of revolution) there was introduced a conception of GeomEvaluators to unify calculation of values for such kinds of surfaces.

It is proposed to update offset curves to use evaluators too and get rid of CSLib_Offset namespace, which was implemented in scope of issue 0024682 and will be obsolete when evaluators will be implemented.
Steps To ReproduceNot Applicable
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0026252closedbugmaster GeomAdaptor_Surface should use inner adaptor to calculate values of complex surfaces 

-  Notes
(0047758)
git (administrator)
2015-11-03 15:57

Branch CR26838 has been created by azv.

SHA-1: 7a5dfa347dcd3fe576e3e6f6fcbd00adbaaf7dda


Detailed log of new commits:

Author: azv
Date: Tue Nov 3 15:56:18 2015 +0300

    0026838: Using GeomEvaluators for calculation of values of curves
    
    1. Implemented evaluators for 2D and 3D offset curves
    2. Removed obsolete namespace CSLib_Offset
(0047759)
azv (developer)
2015-11-03 15:59

Dear Mikhail,

Please review branch CR26838.

Please note that this branch is based on CR26252_3 and CR23620 branches to avoid merging conflicts later. So, I suppose to test it after corresponding issues will be tested.
(0047846)
msv (developer)
2015-11-05 17:34

src\GeomAdaptor\GeomAdaptor_Curve.cxx

1) In the line:
575: if ((theU == myFirst || theU == myLast) && !aBspl.IsNull())
swap checking of conditions: first check handle and then check double comparison.

2) In the line:
585: if (theU == myLast)
Add 'else' statement to avoid extra comparison.
(0047857)
git (administrator)
2015-11-06 08:36

Branch CR26838 has been updated by azv.

SHA-1: b199f4abdbbb5106bfc4f2541fbb871df7cc31b9


Detailed log of new commits:

Author: azv
Date: Fri Nov 6 08:35:53 2015 +0300

    Remarks

(0047860)
git (administrator)
2015-11-06 08:50

Branch CR26838_1 has been created by azv.

SHA-1: 2803cfb51b287b5dde30f627a363c12c9688f464


Detailed log of new commits:

Author: azv
Date: Fri Nov 6 08:49:50 2015 +0300

    0026838: Using GeomEvaluators for calculation of values of curves
    
    1. Implemented evaluators for 2D and 3D offset curves
    2. Removed obsolete namespace CSLib_Offset
(0047861)
azv (developer)
2015-11-06 08:51

Dear Mikhail,

Remarks are taken into account. Please review branch CR26838_1.
(0047862)
msv (developer)
2015-11-06 09:40

Reviewed.
(0047864)
azv (developer)
2015-11-06 09:46

Branch CR26838_1 may be tested in cooperation with CR23620, but not earlier the issue 0026252 will be set to TESTED state.
(0048223)
git (administrator)
2015-11-16 15:59

Branch CR26838_1 has been updated forcibly by azv.

SHA-1: bac8fa53acb5436d6a83f0f580199a71c0fb023c
(0048327)
git (administrator)
2015-11-18 10:13

Branch CR26838_1 has been updated forcibly by azv.

SHA-1: 54ae6df45ac7fd68bc99815b83cdf383ca4d7c16
(0048329)
azv (developer)
2015-11-18 10:17

Branch CR26838_1 has been rebased on CR23620.

Please, test it in cooperation with CR23620 after the issue 0026252 will be moved to TESTED state.
(0048425)
git (administrator)
2015-11-20 15:49

Branch CR26838_1 has been updated forcibly by apv.

SHA-1: 5e773b70d0ff59e8837780605fedccc9124c84a5
(0048426)
apv (tester)
2015-11-20 15:51

Branch CR26838_1 has been rebased on the current master
(0048486)
git (administrator)
2015-11-23 15:34

Branch CR26838_1 has been updated by apv.

SHA-1: 17e3488d64791539eedc18348095ab8e765aa5a4


Detailed log of new commits:

Author: apv
Date: Mon Nov 23 15:34:25 2015 +0300

    Update of UDLIST (adding no-cdl-pack Geom2dEvaluator)

(0048506)
apv (tester)
2015-11-24 12:00

Dear BugMaster,

Branch CR26838_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 17e3488d64791539eedc18348095ab8e765aa5a4

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 127 (127 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR26838-1-master-products-64/Debian70-64/summary.html [^]
http://occt-tests/CR26838-1-master-products-64/Windows-64-VC10/summary.html [^]
bfit pnt1000 A7
omf_advanced_meshfuse ZG8
sat doc_1 A9 (Linux only)

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92904702 / 93579741 [-0.72%]
Total CPU difference: 20228.749999999935 / 19980.21999999995 [+1.24%]

Testing on Windows:
Total MEMORY difference: 57806776 / 58422467 [-1.05%]
Total CPU difference: 19295.529688499115 / 18555.460944498842 [+3.99%]

There are differences in images found by testdiff:
http://occt-tests/CR26838-1-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR26838-1-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]
chamfer equal_dist E8
chamfer dist_angle E8
(0048507)
apv (tester)
2015-11-24 12:01

Dear azv,

Branch CR26838_1 has been rejected due to:
- regressions
- differences in images
(0048574)
azv (developer)
2015-11-25 17:01

Dear Alexey,

bfit pnt1000 A7
had different reference data on Linux and Windows. Now the results are closer on both platforms. So, please, update test case.

omf_advanced_meshfuse ZG8
has a difference just in mesh area. Please, update a tolerance of checking mesh validity.

sat doc_1 A9
now it works as on Windows, please update it.

New pictures provided in
chamfer equal_dist E8
chamfer dist_angle E8
may be taken as reference data. Now they are correlate with test chamfer dist_dist E8.
(0048604)
apv (tester)
2015-11-26 14:08

Branch CR26838 has been created in products git-repository
(0048605)
apv (tester)
2015-11-26 14:08

Test-cases in products git-repository have been updated according to the new behavior
(0048607)
git (administrator)
2015-11-26 14:42

Branch CR26838_2 has been created by azv.

SHA-1: f766977cc96231fde02ac9aa525966a4ff05178c


Detailed log of new commits:

Author: apv
Date: Mon Nov 23 15:34:25 2015 +0300

    Update of UDLIST (adding no-cdl-pack Geom2dEvaluator)
    
    Update TKG2d/CMakeLists.txt after rebase

Author: azv
Date: Fri Nov 6 08:49:50 2015 +0300

    0026838: Using GeomEvaluators for calculation of values of curves
    
    1. Implemented evaluators for 2D and 3D offset curves
    2. Removed obsolete namespace CSLib_Offset

Author: azv
Date: Mon Nov 2 09:33:04 2015 +0300

    0023620: Follow up of 0022939 - make Bezier curve/surface evaluation thread-safe
    
    1. Remove cache from Geom_BezierCurve, Geom2d_BezierCurve and Geom_BezierSurface
    2. Add cache for Bezier curves into GeomAdaptor_Curve, Geom2dAdaptor_Curve and GeomAdaptor_Surface
    3. Update comments in corresponding cache classes
    4. Avoid frequent down-casting to B-splines in adaptors
(0053058)
git (administrator)
2016-04-17 14:07

Branch CR26838 has been deleted by kgv.

SHA-1: b199f4abdbbb5106bfc4f2541fbb871df7cc31b9
(0053059)
git (administrator)
2016-04-17 14:07

Branch CR26838_1 has been deleted by kgv.

SHA-1: 17e3488d64791539eedc18348095ab8e765aa5a4
(0053060)
git (administrator)
2016-04-17 14:07

Branch CR26838_2 has been deleted by kgv.

SHA-1: f766977cc96231fde02ac9aa525966a4ff05178c

- Related Changesets
occt: master d660a72a
Timestamp: 2015-11-06 05:49:50
Author: azv
Committer: bugmaster
Details ] Diff ]
0026838: Using GeomEvaluators for calculation of values of curves

1. Implemented evaluators for 2D and 3D offset curves
2. Removed obsolete namespace CSLib_Offset

Update of UDLIST (adding no-cdl-pack Geom2dEvaluator)

Update TKG2d/CMakeLists.txt after rebase

Correction compilation in debug mode
mod - adm/UDLIST Diff ] File ]
rm - src/CSLib/CSLib_Offset.cxx Diff ] File ]
rm - src/CSLib/CSLib_Offset.hxx Diff ] File ]
mod - src/CSLib/FILES Diff ] File ]
mod - src/Geom/Geom_OffsetCurve.cxx Diff ] File ]
mod - src/Geom/Geom_OffsetCurve.hxx Diff ] File ]
mod - src/Geom2d/Geom2d_OffsetCurve.cxx Diff ] File ]
mod - src/Geom2d/Geom2d_OffsetCurve.hxx Diff ] File ]
mod - src/Geom2dAdaptor/Geom2dAdaptor_Curve.cxx Diff ] File ]
mod - src/Geom2dAdaptor/Geom2dAdaptor_Curve.hxx Diff ] File ]
add - src/Geom2dEvaluator/FILES Diff ] File ]
add - src/Geom2dEvaluator/Geom2dEvaluator_Curve.hxx Diff ] File ]
add - src/Geom2dEvaluator/Geom2dEvaluator_OffsetCurve.cxx Diff ] File ]
add - src/Geom2dEvaluator/Geom2dEvaluator_OffsetCurve.hxx Diff ] File ]
mod - src/GeomAdaptor/GeomAdaptor_Curve.cxx Diff ] File ]
mod - src/GeomAdaptor/GeomAdaptor_Curve.hxx Diff ] File ]
mod - src/GeomAdaptor/GeomAdaptor_Surface.hxx Diff ] File ]
mod - src/GeomEvaluator/FILES Diff ] File ]
add - src/GeomEvaluator/GeomEvaluator_Curve.hxx Diff ] File ]
add - src/GeomEvaluator/GeomEvaluator_OffsetCurve.cxx Diff ] File ]
add - src/GeomEvaluator/GeomEvaluator_OffsetCurve.hxx Diff ] File ]
mod - src/TKG2d/PACKAGES Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-03 15:44 azv New Issue
2015-11-03 15:44 azv Assigned To => msv
2015-11-03 15:44 azv Assigned To msv => azv
2015-11-03 15:44 azv Relationship added related to 0026252
2015-11-03 15:57 git Note Added: 0047758
2015-11-03 15:59 azv Note Added: 0047759
2015-11-03 15:59 azv Assigned To azv => msv
2015-11-03 15:59 azv Status new => resolved
2015-11-05 17:34 msv Note Added: 0047846
2015-11-05 17:34 msv Assigned To msv => azv
2015-11-05 17:34 msv Status resolved => assigned
2015-11-06 08:36 git Note Added: 0047857
2015-11-06 08:50 git Note Added: 0047860
2015-11-06 08:51 azv Note Added: 0047861
2015-11-06 08:51 azv Assigned To azv => msv
2015-11-06 08:51 azv Status assigned => resolved
2015-11-06 09:40 msv Note Added: 0047862
2015-11-06 09:40 msv Assigned To msv => bugmaster
2015-11-06 09:40 msv Status resolved => reviewed
2015-11-06 09:45 azv Assigned To bugmaster => azv
2015-11-06 09:46 azv Note Added: 0047864
2015-11-16 15:59 git Note Added: 0048223
2015-11-18 10:13 git Note Added: 0048327
2015-11-18 10:17 azv Assigned To azv => bugmaster
2015-11-18 10:17 azv Note Added: 0048329
2015-11-20 15:26 apv Assigned To bugmaster => apv
2015-11-20 15:49 git Note Added: 0048425
2015-11-20 15:51 apv Note Added: 0048426
2015-11-23 13:37 apv Test case number => Not needed
2015-11-23 15:34 git Note Added: 0048486
2015-11-24 12:00 apv Note Added: 0048506
2015-11-24 12:00 apv Assigned To apv => azv
2015-11-24 12:00 apv Status reviewed => assigned
2015-11-24 12:01 apv Note Added: 0048507
2015-11-25 17:01 azv Note Added: 0048574
2015-11-25 17:01 azv Assigned To azv => apv
2015-11-25 17:01 azv Status assigned => feedback
2015-11-26 14:08 apv Note Added: 0048604
2015-11-26 14:08 apv Note Added: 0048605
2015-11-26 14:08 apv Assigned To apv => bugmaster
2015-11-26 14:08 apv Status feedback => tested
2015-11-26 14:42 git Note Added: 0048607
2015-11-27 12:21 bugmaster Changeset attached => occt master d660a72a
2015-11-27 12:21 bugmaster Status tested => verified
2015-11-27 12:21 bugmaster Resolution open => fixed
2016-04-17 14:07 git Note Added: 0053058
2016-04-17 14:07 git Note Added: 0053059
2016-04-17 14:07 git Note Added: 0053060
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker