View Issue Details

IDProjectCategoryView StatusLast Update
0026827Open CASCADEOCCT:Data Exchangepublic2020-11-11 14:55
ReporterikaAssigned Toabv  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Target Version7.0.0Fixed in Version7.0.0 
Summary0026827: Position and orientation for GD&T frames
DescriptionIt is need to implement possibility to read from STEP and store in XCAF position and orientation of Feature Control Frames for Dimensions, Tolerances and Datums.

Reading necessary information from STEP:
- Create new STEP entities;
- Update STEPCAFControl_Reader.

Processing and storage data in XCAF.
Steps To Reproducenot required
TagsNo tags attached.
Test case numberNot needed

Activities

git

2015-10-30 13:02

administrator   ~0047646

Branch CR26827 has been created by ika.

SHA-1: e9dbf329899da555595bfccd0395469fab3e18b2


Detailed log of new commits:

Author: ika
Date: Fri Oct 30 13:01:56 2015 +0300

    0026827: Position and orientation for GD&T frames
    
    Add STEP entities:
    StepAP242_DraughtingModelItemAssociation
    StepVisual_AnnotationOccurrence
    StepVisual_AnnotationCurveOccurrence
    StepVisual_AnnotationPlane
    StepVisual_DraughtingCallout
    StepVisual_AnnotationPlaneElement
    StepVisual_DraughtingCalloutElement

Author: ink
Date: Thu Oct 29 11:21:20 2015 +0300

    fix compilation warning

Author: mkv
Date: Wed Oct 28 14:43:50 2015 +0300

    Small correction of test cases for issue CR26689

Author: ika
Date: Tue Oct 27 11:32:06 2015 +0300

    Fix compilation error.
    Update test case (direction can be exist only for Oriented dimension).
    Small correction.

Author: ika
Date: Thu Oct 22 13:41:35 2015 +0300

    Fix compilation errors.

Author: ink
Date: Tue Oct 20 14:30:39 2015 +0300

    corrected remarks

Author: ink
Date: Fri Oct 16 15:03:41 2015 +0300

    added tests, corrected remarks

Author: ink
Date: Thu Oct 8 14:39:25 2015 +0300

    Small corrections

Author: ink
Date: Tue Sep 15 14:58:17 2015 +0300

    0026689: Necessary to improve STEPCAFControl_Reader to read GD&T data from STEP model(AP242).

git

2015-11-02 11:28

administrator   ~0047698

Branch CR26827 has been updated by ink.

SHA-1: dd49d3b85f8c1e056910bc1070a3dfeb68ce5d0d


Detailed log of new commits:

Author: ink
Date: Mon Nov 2 11:28:33 2015 +0300

    Changed the structure of XCAF to save the position of PMI data.

git

2015-11-02 16:46

administrator   ~0047723

Branch CR26827 has been updated forcibly by ika.

SHA-1: 798483f0ae59925e850ac160823f93d28540698f

git

2015-11-03 10:48

administrator   ~0047742

Branch CR26827 has been updated by ink.

SHA-1: d83945965dc65379d486694c518ba2772e612ce1


Detailed log of new commits:

Author: ink
Date: Tue Nov 3 10:48:27 2015 +0300

    Small corrections

git

2015-11-03 17:47

administrator   ~0047770

Branch CR26827 has been updated forcibly by ika.

SHA-1: 4e95256fc8062ec5e83ba9a3a5d8009b2759973e

git

2015-11-26 17:26

administrator   ~0048616

Branch CR26827_new has been created by ika.

SHA-1: 11511841e974deea8c29b64f9bf1270a725cd891


Detailed log of new commits:

Author: ika
Date: Tue Nov 3 17:47:18 2015 +0300

    small corrections

Author: ika
Date: Fri Oct 30 13:01:56 2015 +0300

    0026827: Position and orientation for GD&T frames
    
    Add STEP entities:
    - StepAP242_DraughtingModelItemAssociation
    - StepVisual_AnnotationOccurrence
    - StepVisual_AnnotationCurveOccurrence
    - StepVisual_AnnotationPlane
    - StepVisual_DraughtingCallout
    - StepVisual_AnnotationPlaneElement
    - StepVisual_DraughtingCalloutElement
    
    Changed the structure of XCAF to save the position of PMI data.
    
    Add function to read orientation of GDT frame and connection point and set them to XCAF.

git

2015-12-07 14:05

administrator   ~0048793

Branch CR26827_2 has been created by kgv.

SHA-1: fa80c0ab16f08d8e825e622414913d88f84e4fec


Detailed log of new commits:

Author: ika
Date: Fri Oct 30 13:01:56 2015 +0300

    0026827: Position and orientation for GD&T frames
    
    Add STEP entities:
    - StepAP242_DraughtingModelItemAssociation
    - StepVisual_AnnotationOccurrence
    - StepVisual_AnnotationCurveOccurrence
    - StepVisual_AnnotationPlane
    - StepVisual_DraughtingCallout
    - StepVisual_AnnotationPlaneElement
    - StepVisual_DraughtingCalloutElement
    
    Changed the structure of XCAF to save the position of PMI data.
    
    Add function to read orientation of GDT frame and connection point and set them to XCAF.

git

2015-12-15 18:49

administrator   ~0049182

Branch CR26827_2 has been updated by ibs.

SHA-1: c8c0ad015630e8a53cc66603b60d7018db6aaf15


Detailed log of new commits:

Author: ibs
Date: Tue Dec 15 18:49:27 2015 +0300

    XCAFDimTolObjects_GeomToleranceObject has been extended with point: GetPoint2, SetPoint2, HasPoint2 methods have been implemented

git

2015-12-16 12:16

administrator   ~0049195

Branch CR26827_ibs has been created by ibs.

SHA-1: 4836beac7425ef4f99ad375f1560151f6ee6e67e


Detailed log of new commits:

Author: ibs
Date: Tue Dec 15 18:49:27 2015 +0300

    XCAFDimTolObjects_ GeomToleranceObject, DatumObject, DimensionObject has been extended with point: GetPoint2, SetPoint2, HasPoint2 methods have been implemented

git

2015-12-16 17:27

administrator   ~0049216

Branch CR26827_2 has been updated forcibly by ibs.

SHA-1: fa80c0ab16f08d8e825e622414913d88f84e4fec

git

2015-12-16 17:27

administrator   ~0049217

Branch CR26827_ibs has been updated by ibs.

SHA-1: 4b564bb187d75f352f514086007bde38e07cb679


Detailed log of new commits:

Author: ibs
Date: Wed Dec 16 17:18:57 2015 +0300

    GetObject2 - duplicate of GetObject with other name has been added to avoid GetObject macro

git

2015-12-17 15:57

administrator   ~0049246

Branch CR26827_ibs has been updated by ibs.

SHA-1: 887014197ba0009c2c72764f59d927ce9ec1e561


Detailed log of new commits:

Author: ibs
Date: Thu Dec 17 15:35:09 2015 +0300

    drivers for BinMXCAFDoc_GeomToleranceDriver and BinMXCAFDoc_DimensionDriver attributes are added

git

2015-12-17 17:22

administrator   ~0049248

Branch CR26827_ibs has been updated forcibly by ibs.

SHA-1: 9cdeda1983956dd2b59b5b94f3ee35ad6954034f

git

2016-02-25 13:06

administrator   ~0051108

Branch CR26827_1 has been created by ika.

SHA-1: 354ca1d7e3be4aefd5e28c556c4d2393b654610b


Detailed log of new commits:

Author: gka
Date: Mon Jan 18 19:32:22 2016 +0300

    0026827: Position and orientation for GD&T frames
    
    Implementation of graphical annotations of the PMI read from STEP
    Addition TKTopAlgo for correct building of the component

ika

2016-02-25 13:10

developer   ~0051109

Last edited: 2016-02-25 13:12

Fix warnings,
update some comments,
rebase all changes on current master.

Dear GKA,
could you please review changes in branch CR26827_1?

gka

2016-02-25 14:24

developer   ~0051113

Branch CR26827_1 is ready to be tested

mkv

2016-02-26 13:48

tester   ~0051161

Dear BugMaster,
Branch CR26827_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 354ca1d7e3be4aefd5e28c556c4d2393b654610b

Number of compiler warnings:

occt component :
Linux: 1 (0 on master)
Windows: 0 (0 on master)
MacOS : 2 (0 on master)

products component :
Linux: 41 (41 on master)
Windows: 0 (0 on master)

There is new additional compilation warning on Linux platform:
http://jenkins-test-01.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_17008/job/CR26827-1-master_build_occt_linux/1/warnings17Result/
STEPCAFControl_Reader.cxx:283, GNU C Compiler 4 (gcc), Priority: Normal
'numsize' defined but not used [-Wunused-variable]

There are new additional compilation warnings on MacOS platform:
http://jenkins-test-01.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_17008/job/CR26827-1-master_prepare_build_occt_MacOS/1/warnings7Result/
STEPCAFControl_Reader.cxx:283, Clang (LLVM based), Priority: Normal
unused variable 'numsize'
XCAFDimTolObjects_DimensionObject.hxx:186, Clang (LLVM based), Priority: Normal
private field 'myHasPnt' is not used

Regressions/Differences/Improvements:

Failed:
  bugs vis bug1188, bug9517, bug21091_3, bug21091_4, bug21091_5, bug21091_6, bug21091_8, bug21091_9, bug22337, bug23102, bug23804, bug23813, bug24376, bug24622, bug24725, bug24930, bug25340, bug25363, bug25369, bug25475, bug25544_graytexture, bug26357, bug26404, bug26424, bug26676, bug26719_1, bug26726, bug26975, bug27083
  demo samples dimensions, dimensionsglsl, materials, penrose, raytrace
  v3d glsl distinguish_off
  v3d materials bug24855, bug24872_1, bug24872_2
  v3d raytrace bug24130, bug24819, bug25201, bug25833, bug26070, bug26617, connected, plastic, refraction, textures

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 89979290 / 90533057 [-0.61%]
Total CPU difference: 19309.650000000023 / 19576.30000000011 [-1.36%]
products component :
Total MEMORY difference: 25942987 / 25882280 [+0.23%]
Total CPU difference: 5367.119999999979 / 5317.479999999984 [+0.93%]

Testing on Windows:
occt component :
Total MEMORY difference: 57475297 / 56809635 [+1.17%]
Total CPU difference: 18999.018587798615 / 17643.245096998766 [+7.68%]
products component :
Total MEMORY difference: 17832173 / 17401929 [+2.47%]
Total CPU difference: 5280.477848999956 / 5096.459069399955 [+3.61%]

There are no differences in images found by testdiff.

mkv

2016-02-26 13:48

tester   ~0051162

Dear ika,
Branch CR26827_1 has been rejected due to:
- additional warnings
- regressions/differences/improvements

git

2016-03-01 18:12

administrator   ~0051283

Branch CR26827_1 has been updated by ika.

SHA-1: b2df8be0f5cef8dc4b22dc037162e1cf89ed66d4


Detailed log of new commits:

Author: ika
Date: Tue Mar 1 18:10:55 2016 +0300

    0026827: Position and orientation for GD&T frames
    
    Fix warnings on Linux and MacOS.

ika

2016-03-01 18:24

developer   ~0051286

Dear MKV,

warnings were fixed.
Branch CR26827_1 is ready to be tested.

Regressions cannot be a result of changes in this issue, could not you please check, that these regressions really exist?

mkv

2016-03-03 13:13

tester   ~0051352

Dear BugMaster,
Branch CR26827_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: b2df8be0f5cef8dc4b22dc037162e1cf89ed66d4

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 41 (41 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 89949572 / 90001706 [-0.06%]
Total CPU difference: 19189.859999999953 / 19285.0 [-0.49%]
products component :
Total MEMORY difference: 25929791 / 25872807 [+0.22%]
Total CPU difference: 5387.480000000002 / 5316.139999999985 [+1.34%]

Testing on Windows:
occt component :
Total MEMORY difference: 57396535 / 57365464 [+0.05%]
Total CPU difference: 17894.047904699124 / 18587.39434919897 [-3.73%]
products component :
Total MEMORY difference: 17509187 / 17401929 [+0.62%]
Total CPU difference: 5227.203507499962 / 5096.459069399955 [+2.57%]

There are no differences in images found by testdiff.

mkv

2016-03-03 13:13

tester   ~0051353

Dear BugMaster,
Branch CR26827_1 is TESTED.

git

2016-04-17 13:07

administrator   ~0052800

Branch CR26827 has been deleted by kgv.

SHA-1: 4e95256fc8062ec5e83ba9a3a5d8009b2759973e

git

2016-04-17 13:07

administrator   ~0052801

Branch CR26827_1 has been deleted by kgv.

SHA-1: b2df8be0f5cef8dc4b22dc037162e1cf89ed66d4

git

2016-04-17 13:07

administrator   ~0052802

Branch CR26827_2 has been deleted by kgv.

SHA-1: fa80c0ab16f08d8e825e622414913d88f84e4fec

git

2016-04-17 13:07

administrator   ~0052803

Branch CR26827_ibs has been deleted by kgv.

SHA-1: 9cdeda1983956dd2b59b5b94f3ee35ad6954034f

git

2016-04-17 13:07

administrator   ~0052804

Branch CR26827_new has been deleted by kgv.

SHA-1: 11511841e974deea8c29b64f9bf1270a725cd891

Related Changesets

occt: master 5df609e7

2016-01-18 16:32:22

abv


Committer: abv Details Diff
0026827: Position and orientation for GD&T frames

Implementation of graphical annotations of the PMI read from STEP
Affected Issues
0026827
mod - src/BinMXCAFDoc/BinMXCAFDoc.cxx Diff File
mod - src/BinMXCAFDoc/BinMXCAFDoc.hxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_DimensionDriver.cxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_DimensionDriver.hxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_GeomToleranceDriver.cxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_GeomToleranceDriver.hxx Diff File
mod - src/BinMXCAFDoc/FILES Diff File
mod - src/RWStepAP214/RWStepAP214_GeneralModule.cxx Diff File
mod - src/RWStepAP214/RWStepAP214_ReadWriteModule.cxx Diff File
mod - src/RWStepAP242/FILES Diff File
add - src/RWStepAP242/RWStepAP242_RWDraughtingModelItemAssociation.cxx Diff File
add - src/RWStepAP242/RWStepAP242_RWDraughtingModelItemAssociation.hxx Diff File
mod - src/RWStepVisual/FILES Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationCurveOccurrence.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationCurveOccurrence.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationOccurrence.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationOccurrence.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationPlane.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWAnnotationPlane.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWCoordinatesList.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWCoordinatesList.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWDraughtingCallout.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWDraughtingCallout.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedAnnotationOccurrence.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedAnnotationOccurrence.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedCurveSet.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedCurveSet.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedGeometricSet.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedGeometricSet.hxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedItem.cxx Diff File
add - src/RWStepVisual/RWStepVisual_RWTessellatedItem.hxx Diff File
mod - src/StepAP214/StepAP214_Protocol.cxx Diff File
mod - src/StepAP242/FILES Diff File
add - src/StepAP242/StepAP242_DraughtingModelItemAssociation.cxx Diff File
add - src/StepAP242/StepAP242_DraughtingModelItemAssociation.hxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Reader.cxx Diff File
mod - src/StepDimTol/StepDimTol_ToleranceZone.hxx Diff File
mod - src/StepVisual/FILES Diff File
add - src/StepVisual/StepVisual_AnnotationCurveOccurrence.cxx Diff File
add - src/StepVisual/StepVisual_AnnotationCurveOccurrence.hxx Diff File
mod - src/StepVisual/StepVisual_AnnotationOccurrence.cxx Diff File
mod - src/StepVisual/StepVisual_AnnotationOccurrence.hxx Diff File
add - src/StepVisual/StepVisual_AnnotationPlane.cxx Diff File
add - src/StepVisual/StepVisual_AnnotationPlane.hxx Diff File
add - src/StepVisual/StepVisual_AnnotationPlaneElement.cxx Diff File
add - src/StepVisual/StepVisual_AnnotationPlaneElement.hxx Diff File
add - src/StepVisual/StepVisual_Array1OfAnnotationPlaneElement.hxx Diff File
add - src/StepVisual/StepVisual_Array1OfDraughtingCalloutElement.hxx Diff File
add - src/StepVisual/StepVisual_CoordinatesList.cxx Diff File
add - src/StepVisual/StepVisual_CoordinatesList.hxx Diff File
add - src/StepVisual/StepVisual_DraughtingCallout.cxx Diff File
add - src/StepVisual/StepVisual_DraughtingCallout.hxx Diff File
add - src/StepVisual/StepVisual_DraughtingCalloutElement.cxx Diff File
add - src/StepVisual/StepVisual_DraughtingCalloutElement.hxx Diff File
add - src/StepVisual/StepVisual_HArray1OfAnnotationPlaneElement.hxx Diff File
add - src/StepVisual/StepVisual_HArray1OfDraughtingCalloutElement.hxx Diff File
add - src/StepVisual/StepVisual_TessellatedAnnotationOccurrence.cxx Diff File
add - src/StepVisual/StepVisual_TessellatedAnnotationOccurrence.hxx Diff File
add - src/StepVisual/StepVisual_TessellatedCurveSet.cxx Diff File
add - src/StepVisual/StepVisual_TessellatedCurveSet.hxx Diff File
add - src/StepVisual/StepVisual_TessellatedGeometricSet.cxx Diff File
add - src/StepVisual/StepVisual_TessellatedGeometricSet.hxx Diff File
add - src/StepVisual/StepVisual_TessellatedItem.cxx Diff File
add - src/StepVisual/StepVisual_TessellatedItem.hxx Diff File
mod - src/TKXDESTEP/EXTERNLIB Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DatumObject.cxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DatumObject.hxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DimensionObject.cxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DimensionObject.hxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_GeomToleranceObject.cxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_GeomToleranceObject.hxx Diff File
mod - src/XCAFDoc/XCAFDoc_Datum.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_Datum.hxx Diff File
mod - src/XCAFDoc/XCAFDoc_Dimension.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DimTolTool.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DimTolTool.hxx Diff File
mod - src/XCAFDoc/XCAFDoc_GeomTolerance.cxx Diff File

Issue History

Date Modified Username Field Change
2015-10-29 15:59 ika New Issue
2015-10-29 15:59 ika Assigned To => ika
2015-10-30 13:02 git Note Added: 0047646
2015-11-02 11:28 git Note Added: 0047698
2015-11-02 16:46 git Note Added: 0047723
2015-11-03 10:48 git Note Added: 0047742
2015-11-03 17:47 git Note Added: 0047770
2015-11-26 17:26 git Note Added: 0048616
2015-12-07 14:05 git Note Added: 0048793
2015-12-15 18:49 git Note Added: 0049182
2015-12-16 12:16 git Note Added: 0049195
2015-12-16 17:27 git Note Added: 0049216
2015-12-16 17:27 git Note Added: 0049217
2015-12-17 15:57 git Note Added: 0049246
2015-12-17 17:22 git Note Added: 0049248
2015-12-18 12:35 abv Target Version 7.0.0 => 7.1.0
2016-02-25 13:06 git Note Added: 0051108
2016-02-25 13:10 ika Note Added: 0051109
2016-02-25 13:10 ika Assigned To ika => gka
2016-02-25 13:10 ika Status new => resolved
2016-02-25 13:10 ika Steps to Reproduce Updated
2016-02-25 13:12 ika Note Edited: 0051109
2016-02-25 14:24 gka Note Added: 0051113
2016-02-25 14:24 gka Assigned To gka => bugmaster
2016-02-25 14:24 gka Status resolved => reviewed
2016-02-25 16:34 mkv Assigned To bugmaster => mkv
2016-02-26 13:48 mkv Note Added: 0051161
2016-02-26 13:48 mkv Note Added: 0051162
2016-02-26 13:48 mkv Assigned To mkv => ika
2016-02-26 13:48 mkv Status reviewed => assigned
2016-02-26 13:49 mkv Test case number => Not needed
2016-03-01 18:12 git Note Added: 0051283
2016-03-01 18:24 ika Note Added: 0051286
2016-03-01 18:24 ika Assigned To ika => mkv
2016-03-01 18:24 ika Status assigned => feedback
2016-03-03 13:13 mkv Note Added: 0051352
2016-03-03 13:13 mkv Note Added: 0051353
2016-03-03 13:13 mkv Assigned To mkv => bugmaster
2016-03-03 13:13 mkv Status feedback => tested
2016-03-03 13:51 abv Target Version 7.1.0 => 7.0.0
2016-03-04 16:52 abv Changeset attached => occt master 5df609e7
2016-03-04 16:52 abv Assigned To bugmaster => abv
2016-03-04 16:52 abv Status tested => verified
2016-03-04 16:52 abv Resolution open => fixed
2016-04-17 13:07 git Note Added: 0052800
2016-04-17 13:07 git Note Added: 0052801
2016-04-17 13:07 git Note Added: 0052802
2016-04-17 13:07 git Note Added: 0052803
2016-04-17 13:07 git Note Added: 0052804
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:49 aiv Status verified => closed