View Issue Details

IDProjectCategoryView StatusLast Update
0026796Open CASCADEOCCT:Modeling Algorithmspublic2017-09-29 16:24
Reporteremv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version6.9.1 
Target Version7.2.0Fixed in Version7.2.0 
Summary0026796: The result of General Fuse operation is self-intersecting shape
DescriptionThe result of General Fuse operation is self-intersecting shape.
Steps To Reproducebox b1 10 10 10
box b2 10.00000018 0 0 10 10 10
explode b2 f
copy b2_1 f
trotate f 0 5 5 0 1 0 10
mksurface s f
mkface f s -100 100 -100 100

bclearobjects
bcleartools
baddobjects b1 b2 f
bfillds
bbuild r
bopcheck r
TagsNo tags attached.
Test case numberbugs modalg_6 bug26796

Relationships

related to 0026738 closedapn Open CASCADE Make Boolean operations safely treating arguments when running with fuzzy option 

Activities

git

2015-10-23 09:19

administrator   ~0047360

Branch CR26796 has been created by emv.

SHA-1: bce5924a5a3663e07f72bf6f2bf8ae807b8e1976


Detailed log of new commits:

Author: emv
Date: Fri Oct 23 09:18:57 2015 +0300

    0026796: The result of General Fuse operation is self-intersecting shape
    
    Compute correct tolerance values for intersections of type Line/Line, Line/Plane, Plane/Plane.
    Make intersections with additional tolerance Precision::Confusion().

emv

2015-10-23 09:26

developer   ~0047361

For completion of the fix development it is necessary to wait for the integration of the git branch CR26619 (issue #0026619). And may be this fix should be combined with the fix for the issue 0026738 as it deals with the same functionality and in nearly the same way as it should be done for 0026738, but without fuzzy.

emv

2016-10-28 11:37

developer   ~0059305

The fix for this issue has been integrated in frames of #0026619. It is not reproduced on current master.
Dear bugmaster, could you please create test case for it and integrate?

bugmaster

2017-02-28 14:02

administrator   ~0064025

Is it normal?

bopcheck r
 This shape seems to be OK.

checkshape r
On Shape faulty_1 :
BRepCheck_BadOrientationOfSubshape

Faulty shapes in variables faulty_1 to faulty_1

emv

2017-02-28 14:22

developer   ~0064026

It is normal for the face with no bounds and a hole. Creating such face without any Booleans will result in a same checkshape faulty. I have updated the script in the Steps To Reproduce section so it works and produce no faulty shapes.

git

2017-02-28 15:03

administrator   ~0064028

Branch CR26796_1 has been created by inv.

SHA-1: 1ad86ead4828dbe3a8ce6c8592bfadb9d027b2f5


Detailed log of new commits:

Author: bugmaster
Date: Tue Feb 28 15:02:55 2017 +0300

    0026796: The result of General Fuse operation is self-intersecting shape
    
    Adding test case

git

2017-03-20 14:33

administrator   ~0064468

Branch CR26796_1 has been deleted by inv.

SHA-1: 1ad86ead4828dbe3a8ce6c8592bfadb9d027b2f5

git

2017-03-20 14:37

administrator   ~0064530

Branch CR26796 has been deleted by inv.

SHA-1: bce5924a5a3663e07f72bf6f2bf8ae807b8e1976

Related Changesets

occt: master 0d0c99de

2017-02-28 12:02:55

bugmaster

Details Diff
0026796: The result of General Fuse operation is self-intersecting shape

Adding test case
Affected Issues
0026796
add - tests/bugs/modalg_6/bug26796 Diff File

Issue History

Date Modified Username Field Change
2015-10-22 08:30 emv New Issue
2015-10-22 08:30 emv Assigned To => emv
2015-10-23 09:19 git Note Added: 0047360
2015-10-23 09:19 emv Status new => assigned
2015-10-23 09:26 emv Relationship added related to 0026738
2015-10-23 09:26 emv Note Added: 0047361
2016-10-28 11:37 emv Note Added: 0059305
2016-10-28 11:37 emv Assigned To emv => bugmaster
2016-10-28 11:37 emv Status assigned => feedback
2016-11-24 14:20 apn Target Version 7.1.0 => 7.2.0
2017-02-28 14:00 bugmaster Assigned To bugmaster => emv
2017-02-28 14:02 bugmaster Note Added: 0064025
2017-02-28 14:15 emv Steps to Reproduce Updated
2017-02-28 14:22 emv Note Added: 0064026
2017-02-28 14:22 emv Assigned To emv => bugmaster
2017-02-28 15:03 git Note Added: 0064028
2017-02-28 15:04 bugmaster Status feedback => tested
2017-02-28 16:06 bugmaster Test case number => bugs modalg_6 bug26796
2017-03-03 16:25 bugmaster Changeset attached => occt master 0d0c99de
2017-03-03 16:25 bugmaster Status tested => verified
2017-03-03 16:25 bugmaster Resolution open => fixed
2017-03-20 14:33 git Note Added: 0064468
2017-03-20 14:37 git Note Added: 0064530
2017-09-29 16:20 aiv Fixed in Version => 7.2.0
2017-09-29 16:24 aiv Status verified => closed