MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026792Open CASCADE[OCCT] OCCT:Visualizationpublic2015-10-21 11:092016-04-20 15:50
Reporterapl 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026792: Visualization, Graphic3d - Z-fit support for transform persistence is missing after removing Visual3d_View
DescriptionSeveral lines of code of Visual3d_View::MinMaxValues implemented by #26344 are missing in current version after integration of 0024776. These lines enables support by z-fit procedure of zoom, rotate transform persistent objects.

The missing code should be merged back and test case added for this functionality.
Steps To Reproducepload ALL
box b 100 100 100
vdisplay b -trsfPers zoom
vzoom 0.01
vzfit
TagsNo tags attached.
Test case numberbugs vis bug26792
Attached Filespng file icon bug.png (702 bytes) 2015-10-21 11:09

- Relationships
parent of 0027061closedabv Community Compile failure due to BOM in OpenGl/OpenGl_BVHClipPrimitiveTrsfPersSet.cxx 
child of 0024776closedkgv Open CASCADE Visualization - inherit OpenGl_View from Graphic3d_CView 

-  Notes
(0047271)
git (administrator)
2015-10-21 13:26

Branch CR26792 has been created by apl.

SHA-1: 9e9f74621649332e8a704d1eb36f603939d769fa


Detailed log of new commits:

Author: apl
Date: Wed Oct 21 13:25:57 2015 +0300

    0026792: Visualization, Graphic3d - Z-fit support for transform persistence is missing after removing Visual3d_View
    
    Add missing code for z-fit support for zoom, rotate persistent object.
    Fixed wrong statement that should enable frustum culling optimization for zoom, rotate persistent object.
    Added non-regression test case for z-clipping of transform persistent objects.
(0047272)
apl (developer)
2015-10-21 13:26

Dear Kirill,

Please review the patch.
(0047305)
kgv (developer)
2015-10-21 19:26

Please test the patch.
(0047346)
git (administrator)
2015-10-22 17:30

Branch CR26792 has been updated forcibly by mkv.

SHA-1: 74cc8fbbb2d1eff5b75fa134188b66a19adfa210
(0047389)
mkv (tester)
2015-10-23 16:11

Dear BugMaster,
Branch CR26792 was rebased on branch IR-2015-10-22 of occt git-repository.
SHA-1: 74cc8fbbb2d1eff5b75fa134188b66a19adfa210
(0047390)
mkv (tester)
2015-10-23 16:12

Dear BugMaster,
Branch CR26792 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 74cc8fbbb2d1eff5b75fa134188b66a19adfa210

Number of compiler warnings:

occt component :
Linux: 1 (1 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR26792-master-occt-64/Debian70-64/bugs/vis/bug26792.html [^]
http://occt-tests/CR26792-master-occt-64/Windows-64-VC10/bugs/vis/bug26792.html [^]
bugs vis bug26792: OK

Testing on Linux:
occt component :
Total MEMORY difference: 92912829 / 92331080 [+0.63%]
Total CPU difference: 19673.739999999725 / 19731.34999999969 [-0.29%]
products component :
Total MEMORY difference: 26180396 / 26226349 [-0.18%]
Total CPU difference: 7750.079999999978 / 7363.820000000012 [+5.25%]

Testing on Windows:
occt component :
Total MEMORY difference: 58409217 / 58043302 [+0.63%]
Total CPU difference: 18161.324417998592 / 18133.197437699022 [+0.16%]
products component :
Total MEMORY difference: 17174870 / 17138954 [+0.21%]
Total CPU difference: 5588.080620799969 / 5652.477833599974 [-1.14%]

There are following differences in images found by testdiff.
http://occt-tests/CR26792-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR26792-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]

IMAGE bugs vis bug26719_2: bug26719_2_1.png differs
IMAGE bugs vis bug26719_2: bug26719_2_Driver1_Viewer1_View1.png differs
IMAGE bugs vis bug26719_2: bug26719_2_2.png differs
IMAGE bugs vis bug23120: bug23120_Driver1_Viewer1_View1.png differs

IMAGE v3d glsl stereo: stereo_anaglyph.png differs
IMAGE v3d glsl stereo: stereo_col.png differs
IMAGE v3d glsl stereo: stereo_overunder_anamorph.png differs
IMAGE v3d glsl stereo: stereo_sbs_anamorph.png differs
IMAGE v3d glsl texture_trsf: texture_trsf.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_scale_glsl.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_ffp.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_glsl.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_translate_ffp.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_translate_glsl.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_scale_ffp.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_identity_glsl.png differs
IMAGE v3d glsl texture_trsf: texture_trsf_identity_ffp.png differs

IMAGE caf presentation F3: F3.png differs
IMAGE caf presentation F4: F4.png differs
IMAGE caf presentation G1: G1.png differs
IMAGE caf presentation K1: K1.png differs
IMAGE caf presentation H1: H1.png differs
IMAGE caf presentation I1: I1.png differs
IMAGE caf presentation J1: J1.png differs
IMAGE caf presentation F2: F2.png differs

IMAGE bugs vis bug5988: bug5988_Driver1_Viewer1_View1.png differs
IMAGE bugs modalg_2 bug22196: bug22196_Driver1_Viewer1_View1.png differs
(0047392)
mkv (tester)
2015-10-23 16:13

Dear apl,
Branch CR26792 has been rejected due to:
- differences in images
(0048365)
git (administrator)
2015-11-19 11:17

Branch CR26792_1 has been created by apl.

SHA-1: 44334d077c1a950627efdb81001c173c411a2387


Detailed log of new commits:

Author: apl
Date: Thu Nov 19 11:16:14 2015 +0300

    0026792: Visualization, Graphic3d - Z-fit support for transform persistence is missing after removing Visual3d_View
    
    Add missing code for z-fit support for zoom, rotate persistent object.
    Fixed wrong statement that should enable frustum culling optimization for zoom, rotate persistent object.
    Fixed BVH_LinearBuilder.lxx to correctly control number of items in leaf node for a case of items with equal bounding boxes.
    Added non-regression test case for z-clipping of transform persistent objects.
(0048366)
apl (developer)
2015-11-19 11:18

Dear Kirill,

Please review branch CR26792_1. There is one more fix for BVH_LinearBuilder.
(0048367)
kgv (developer)
2015-11-19 11:26

Please test updated patch.
(0048429)
git (administrator)
2015-11-20 16:05

Branch CR26792_1 has been updated forcibly by apv.

SHA-1: 8489717ecbeb8e26d0e54c700d310f12459cb6a9
(0048430)
apv (tester)
2015-11-20 16:06

Branch CR25792_1 has been rebased on the current master
(0048474)
apv (tester)
2015-11-23 14:08

Dear BugMaster,

Branch CR26792_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 8489717ecbeb8e26d0e54c700d310f12459cb6a9

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 127 (127 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
bugs vis bug26792 - OK
http://occt-tests/CR26792-1-master-occt-64/Debian70-64/bugs/vis/bug26792.html [^]
http://occt-tests/CR26792-1-master-occt-64/Windows-64-VC10/bugs/vis/bug26792.html [^]

Testing on Linux:
Total MEMORY difference: 93273976 / 93571288 [-0.32%]
Total CPU difference: 19934.789999999786 / 19980.139999999952 [-0.23%]

Testing on Windows:
Total MEMORY difference: 58370922 / 58378770 [-0.01%]
Total CPU difference: 18489.30092039909 / 18194.47463049887 [+1.62%]
(0053097)
git (administrator)
2016-04-17 14:14

Branch CR26792 has been deleted by kgv.

SHA-1: 74cc8fbbb2d1eff5b75fa134188b66a19adfa210
(0053098)
git (administrator)
2016-04-17 14:14

Branch CR26792_1 has been deleted by kgv.

SHA-1: 8489717ecbeb8e26d0e54c700d310f12459cb6a9

- Related Changesets
occt: master 97f937cc
Timestamp: 2015-11-19 08:16:14
Author: apl
Committer: bugmaster
Details ] Diff ]
0026792: Visualization, Graphic3d - Z-fit support for transform persistence is missing after removing Visual3d_View

Add missing code for z-fit support for zoom, rotate persistent object.
Fixed wrong statement that should enable frustum culling optimization for zoom, rotate persistent object.
Fixed BVH_LinearBuilder.lxx to correctly control number of items in leaf node for a case of items with equal bounding boxes.
Added non-regression test case for z-clipping of transform persistent objects.
mod - src/BVH/BVH_LinearBuilder.lxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_BVHClipPrimitiveTrsfPersSet.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_BVHTreeSelector.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Layer.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Structure.hxx Diff ] File ]
add - tests/bugs/vis/bug26792 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-10-21 11:09 apl New Issue
2015-10-21 11:09 apl Assigned To => apl
2015-10-21 11:09 apl File Added: bug.png
2015-10-21 11:10 apl Relationship added related to 0026344
2015-10-21 11:10 apl Relationship added child of 0024776
2015-10-21 11:37 apl Steps to Reproduce Updated View Revisions
2015-10-21 11:37 apl Status new => assigned
2015-10-21 13:26 git Note Added: 0047271
2015-10-21 13:26 apl Note Added: 0047272
2015-10-21 13:26 apl Assigned To apl => kgv
2015-10-21 13:26 apl Status assigned => resolved
2015-10-21 19:26 kgv Note Added: 0047305
2015-10-21 19:26 kgv Assigned To kgv => bugmaster
2015-10-21 19:26 kgv Status resolved => reviewed
2015-10-22 14:33 mkv Assigned To bugmaster => mkv
2015-10-22 17:30 git Note Added: 0047346
2015-10-23 16:11 mkv Note Added: 0047389
2015-10-23 16:12 mkv Note Added: 0047390
2015-10-23 16:13 mkv Note Added: 0047392
2015-10-23 16:13 mkv Assigned To mkv => apl
2015-10-23 16:13 mkv Status reviewed => assigned
2015-10-23 16:13 mkv Test case number => bugs vis bug26792
2015-10-23 16:13 mkv Status assigned => feedback
2015-11-19 11:17 git Note Added: 0048365
2015-11-19 11:17 apl Status feedback => assigned
2015-11-19 11:18 apl Note Added: 0048366
2015-11-19 11:18 apl Assigned To apl => kgv
2015-11-19 11:18 apl Status assigned => resolved
2015-11-19 11:26 kgv Note Added: 0048367
2015-11-19 11:26 kgv Assigned To kgv => bugmaster
2015-11-19 11:26 kgv Status resolved => reviewed
2015-11-20 16:05 git Note Added: 0048429
2015-11-20 16:06 apv Note Added: 0048430
2015-11-20 16:06 apv Assigned To bugmaster => apv
2015-11-23 14:08 apv Note Added: 0048474
2015-11-23 14:08 apv Assigned To apv => bugmaster
2015-11-23 14:08 apv Status reviewed => tested
2015-11-27 12:21 bugmaster Changeset attached => occt master 97f937cc
2015-11-27 12:21 bugmaster Status tested => verified
2015-11-27 12:21 bugmaster Resolution open => fixed
2016-01-06 12:58 kgv Relationship added parent of 0027061
2016-04-17 14:14 git Note Added: 0053097
2016-04-17 14:14 git Note Added: 0053098
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker