MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026779Open CASCADE[OCCT] OCCT:DRAWpublic2015-10-15 12:262016-04-20 15:51
Reportervpa 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026779: Draw Harness, ViewerTest - vstate output is incorrect for sub-shapes selection without opening local context
DescriptionIf sub-shape selection without opening local context is activated, vstate does not print information about selected items.
Steps To Reproduce
pload MODELING VISUALIZATION
box b 1 2 3
vclear
vclose ALL
vinit View1
vaxo
vsetdispmode 1
vdisplay b
vfit
vselmode b 4 1
vselect 300 300
vstate


v6.9.0 output:
Neutral-point state:
  b Displayed Detected Type: AIS_Shape (AIS_Shape)
Locally selected sub-shapes within b:
       Face # 2

current master:
b Displayed Detected Type: AIS_Shape (AIS_Shape)
TagsNo tags attached.
Test case numberbugs vis bug26779
Attached Files

- Relationships

-  Notes
(0046806)
git (administrator)
2015-10-15 19:35

Branch CR26779 has been created by vpa.

SHA-1: 7f50666f2eaf36dd29c0489e734ec54456cf34a6


Detailed log of new commits:

Author: vpa
Date: Thu Oct 15 19:35:15 2015 +0300

    0026779: Draw Harness, ViewerTest - vstate output is incorrect for sub-shapes selection without opening local context
    
    - vstate output was corrected to handle parts selection without opened local context;
    - test case for issue 0026779
(0046807)
vpa (developer)
2015-10-15 19:36

Dear Kirill,

the patch in branch CR26779 is ready to be reviewed.
(0046809)
git (administrator)
2015-10-15 19:53

Branch CR26779 has been updated forcibly by vpa.

SHA-1: 695b1894a01fa63b2712c6d69bd7cb814670c6b3
(0046810)
kgv (developer)
2015-10-15 19:58

Please test the patch.
(0046939)
git (administrator)
2015-10-16 16:27

Branch CR26779 has been updated forcibly by mkv.

SHA-1: 837497dd14a4846d09befa76928d588d5499b2a2
(0047195)
mkv (tester)
2015-10-19 16:27

Dear BugMaster,
Branch CR26779 was rebased on current master of occt git-repository.
SHA-1: 837497dd14a4846d09befa76928d588d5499b2a2
(0047196)
mkv (tester)
2015-10-19 16:28

Dear BugMaster,
Branch CR26779 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 837497dd14a4846d09befa76928d588d5499b2a2

Number of compiler warnings:

occt component :
Linux: 8 (8 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
http://occt-tests/CR26779-master-occt-64/Debian70-64/bugs/vis/bug25230.html [^]
http://occt-tests/CR26779-master-occt-64/Windows-64-VC10/bugs/vis/bug25230.html [^]
bugs vis bug25230: FAILED
http://occt-tests/CR26779-master-occt-64/Debian70-64/bugs/vis/bug25265.html [^]
http://occt-tests/CR26779-master-occt-64/Windows-64-VC10/bugs/vis/bug25265.html [^]
bugs vis bug25265: FAILED

Testing cases:
http://occt-tests/CR26779-master-occt-64/Debian70-64/bugs/vis/bug26779.html [^]
http://occt-tests/CR26779-master-occt-64/Windows-64-VC10/bugs/vis/bug26779.html [^]
bugs vis bug26779: OK

Testing on Linux:
occt component :
Total MEMORY difference: 92387959 / 92246321 [+0.15%]
Total CPU difference: 19714.359999999764 / 19656.68999999973 [+0.29%]
products component :
Total MEMORY difference: 26217710 / 26295062 [-0.29%]
Total CPU difference: 7530.299999999989 / 7414.720000000001 [+1.56%]

Testing on Windows:
occt component :
Total MEMORY difference: 58029043 / 58035013 [-0.01%]
Total CPU difference: 18365.233325099336 / 17971.174799098968 [+2.19%]
products component :
Total MEMORY difference: 17155820 / 17161066 [-0.03%]
Total CPU difference: 5681.275618199991 / 5653.991043299955 [+0.48%]

There are no differences in images found by testdiff.
(0047197)
mkv (tester)
2015-10-19 16:28

Dear vpa,
Branch CR26779 has been rejected due to:
- regressions/differences/improvements
(0047199)
git (administrator)
2015-10-19 17:34

Branch CR26779 has been updated forcibly by vpa.

SHA-1: 01986926404cb329befe7a4954c36feb741113b3
(0047200)
vpa (developer)
2015-10-19 17:35

Dear Bugmaster,

regressions were fixed. Please, test the updated patch in branch CR26779.
(0047224)
mkv (tester)
2015-10-20 15:13

Dear BugMaster,
Branch CR26779 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 01986926404cb329befe7a4954c36feb741113b3

Number of compiler warnings:

occt component :
Linux: 8 (8 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR26779-master-occt-64/Debian70-64/bugs/vis/bug26779.html [^]
http://occt-tests/CR26779-master-occt-64/Windows-64-VC10/bugs/vis/bug26779.html [^]
bugs vis bug26779: OK

Testing on Linux:
occt component :
Total MEMORY difference: 92471015 / 92267597 [+0.22%]
Total CPU difference: 19706.229999999683 / 19657.53999999973 [+0.25%]
products component :
Total MEMORY difference: 26253877 / 26295062 [-0.16%]
Total CPU difference: 7381.480000000001 / 7414.720000000001 [-0.45%]

Testing on Windows:
occt component :
Total MEMORY difference: 58036631 / 58042636 [-0.01%]
Total CPU difference: 17981.00286209883 / 17972.641208498968 [+0.05%]
products component :
Total MEMORY difference: 17162295 / 17167618 [-0.03%]
Total CPU difference: 5538.784304799964 / 5655.301451699955 [-2.06%]

There are no differences in images found by testdiff.
(0047225)
mkv (tester)
2015-10-20 15:14

Dear BugMaster,
Branch CR26779 is TESTED.
(0053223)
git (administrator)
2016-04-17 14:42

Branch CR26779 has been deleted by kgv.

SHA-1: 01986926404cb329befe7a4954c36feb741113b3

- Related Changesets
occt: master 23963a92
Timestamp: 2015-10-19 14:28:06
Author: vpa
Committer: bugmaster
Details ] Diff ]
0026779: Draw Harness, ViewerTest - vstate output is incorrect for sub-shapes selection without opening local context

- vstate output was corrected to handle parts selection without opened local context;
- test case for issue 0026779
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
add - tests/bugs/vis/bug26779 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-10-15 12:26 vpa New Issue
2015-10-15 12:26 vpa Assigned To => vpa
2015-10-15 12:26 vpa Steps to Reproduce Updated View Revisions
2015-10-15 12:26 vpa Status new => assigned
2015-10-15 12:27 vpa Relationship added child of 0026272
2015-10-15 19:35 git Note Added: 0046806
2015-10-15 19:36 vpa Note Added: 0046807
2015-10-15 19:36 vpa Assigned To vpa => kgv
2015-10-15 19:36 vpa Status assigned => resolved
2015-10-15 19:53 git Note Added: 0046809
2015-10-15 19:58 kgv Note Added: 0046810
2015-10-15 19:58 kgv Assigned To kgv => bugmaster
2015-10-15 19:58 kgv Status resolved => reviewed
2015-10-15 19:58 kgv Steps to Reproduce Updated View Revisions
2015-10-15 19:58 kgv Product Version 6.9.1 =>
2015-10-16 12:47 mkv Assigned To bugmaster => mkv
2015-10-16 16:27 git Note Added: 0046939
2015-10-19 16:27 mkv Note Added: 0047195
2015-10-19 16:28 mkv Note Added: 0047196
2015-10-19 16:28 mkv Note Added: 0047197
2015-10-19 16:28 mkv Assigned To mkv => vpa
2015-10-19 16:28 mkv Status reviewed => assigned
2015-10-19 16:29 mkv Test case number => bugs vis bug26779
2015-10-19 17:34 git Note Added: 0047199
2015-10-19 17:34 vpa Status assigned => resolved
2015-10-19 17:35 vpa Note Added: 0047200
2015-10-19 17:35 vpa Assigned To vpa => bugmaster
2015-10-19 17:35 vpa Status resolved => reviewed
2015-10-19 17:44 mkv Assigned To bugmaster => mkv
2015-10-20 15:13 mkv Note Added: 0047224
2015-10-20 15:14 mkv Note Added: 0047225
2015-10-20 15:14 mkv Assigned To mkv => bugmaster
2015-10-20 15:14 mkv Status reviewed => tested
2015-10-23 12:30 bugmaster Changeset attached => occt master 23963a92
2015-10-23 12:30 bugmaster Status tested => verified
2015-10-23 12:30 bugmaster Resolution open => fixed
2016-04-17 14:42 git Note Added: 0053223
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:51 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker