MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026771Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2015-10-13 18:522016-12-09 16:41
Reportermsv 
Assigned Tobugmaster 
PrioritylowSeverityminor 
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0026771: Boolean intersection gives too large reached tolerance
DescriptionThe internal intersection algorithm (bopcurves command) computes intersection curve for attached faces, but the reached tolerance is too large unjustified.
Steps To ReproduceTest case is not required.

restore faces.brep f
explode f
set out [bopcurves f_1 f_2 -2d]
regexp {Reached=([0-9.\-+eE]*)} $out dummy tolr
if {$tolr > 0.01} {
  puts "Error: reached tolerance $tolr is too large"
}
TagsNo tags attached.
Test case number
Attached Files? file icon faces.brep (3,171 bytes) 2015-10-13 18:52

- Relationships
has duplicate 0027310closedbugmaster Huge tolerance obtained in the result of intersection of two cylindrical faces 

-  Notes
(0046712)
msv (developer)
2015-10-13 18:59

Dear Nikolay, please process it with low priority.
(0052561)
nbv (developer)
2016-04-11 09:23

This bug is duplicate of issue 0027310. Fix and test case has been created in frame of CR27310 issue.
(0054121)
msv (developer)
2016-05-19 10:05

Dear bugmaster, please verify and close this bug.

- Issue History
Date Modified Username Field Change
2015-10-13 18:52 msv New Issue
2015-10-13 18:52 msv Assigned To => msv
2015-10-13 18:52 msv File Added: faces.brep
2015-10-13 18:59 msv Note Added: 0046712
2015-10-13 18:59 msv Assigned To msv => nbv
2015-10-13 18:59 msv Priority normal => low
2015-10-13 18:59 msv Status new => assigned
2015-10-28 10:49 msv Target Version 7.0.0 => 7.1.0
2016-04-08 14:34 nbv Relationship added has duplicate 0027310
2016-04-11 09:23 nbv Note Added: 0052561
2016-04-11 09:23 nbv Assigned To nbv => msv
2016-04-11 09:23 nbv Status assigned => resolved
2016-04-11 09:23 nbv Steps to Reproduce Updated View Revisions
2016-05-19 10:05 msv Note Added: 0054121
2016-05-19 10:05 msv Assigned To msv => bugmaster
2016-05-19 10:05 msv Status resolved => feedback
2016-05-20 10:31 bugmaster Status feedback => closed
2016-05-20 10:31 bugmaster Resolution open => duplicate
2016-12-09 16:41 aiv Fixed in Version => 7.1.0


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker