MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026726Open CASCADE[OCCT] OCCT:DRAWpublic2015-09-25 17:242016-04-20 15:50
Reporterisk 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026726: Draw Harness, ViewerTest - AIS_InteractiveContext::EraseSelected() lacks test case
DescriptionAIS_InteractiveContext::EraseSelected() lacks test case
Steps To Reproducebugs vis bug26726
TagsNo tags attached.
Test case numberbugs vis bug26726
Attached Files

- Relationships
related to 0026628closedbugmaster Button Erase (Delete where erase algorythm is used) works incorrect 

-  Notes
(0046153)
git (administrator)
2015-09-25 17:43

Branch CR26726 has been created by isk.

SHA-1: d284151bae6ff31138681228c3e987a8b645a585


Detailed log of new commits:

Author: isk
Date: Fri Sep 25 17:38:15 2015 +0300

    0026726: Visualization: AIS_InteractiveContext::EraseSelected() lacks test case.
    Update draw command ViewerTest::Erase().
(0046169)
vpa (developer)
2015-09-25 20:00

Dear Ilya,

I have one small remark: please, consider using EraseSelected (Standard_False) to avoid excessive viewer update.
(0046180)
git (administrator)
2015-09-28 08:03

Branch CR26726 has been updated forcibly by isk.

SHA-1: ee298d134c5bbb90bb31137f07cbf1393b499265
(0046194)
vpa (developer)
2015-09-28 11:50

Dear bugmaster,

please test patch in branch CR26726.
(0046218)
git (administrator)
2015-09-28 14:49

Branch CR26726 has been updated forcibly by apv.

SHA-1: c6879b84f0da2aac533d4f2a37ade658cb4737de
(0046219)
apv (tester)
2015-09-28 14:49

Branch CR26726 has been rebased on the current master
(0046257)
apv (tester)
2015-09-29 14:25

Dear BugMaster,

Branch CR26726 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: c6879b84f0da2aac533d4f2a37ade658cb4737de

Number of compiler warnings:
occt component:
   Linux: 13 (13 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR26726-master-occt-64/Debian70-64/summary.html [^]
http://occt-tests/CR26726-master-occt-64/Windows-64-VC10/summary.html [^]
bugs vis bug24966

Testing cases:
bugs vis bug26726 - OK
http://occt-tests/CR26726-master-occt-64/Debian70-64/bugs/vis/bug26726.html [^]
http://occt-tests/CR26726-master-occt-64/Windows-64-VC10/bugs/vis/bug26726.html [^]

Testing on Linux:
Total MEMORY difference: 92512284 / 93306890 [-0.85%]
Total CPU difference: 19717.509999999453 / 19848.729999999236 [-0.66%]

Testing on Windows:
Total MEMORY difference: 57919761 / 57928042 [-0.01%]
Total CPU difference: 17715.114757698993 / 17726.846032899077 [-0.07%]
(0046258)
apv (tester)
2015-09-29 14:25

Dear isk,

Branch CR26726 has been rejected due to:
- regressions/differences/improvements
(0050211)
git (administrator)
2016-01-28 16:47

Branch CR26726 has been updated forcibly by isk.

SHA-1: 7ddaa3e0d6eccd867a88e53b5718dc55f89d36db
(0050213)
isk (developer)
2016-01-28 16:49

Branch CR26726 was rebased on current master.
(0050215)
isk (developer)
2016-01-28 16:52

Dear Varvara,
Please review the branch CR26726.
(0050220)
kgv (developer)
2016-01-29 08:50

+    const Standard_Boolean aHasOpenedContext = aCtx->HasOpenedContext();
     // Erase selected objects

the following comment is for entire "if" block - so it is better keeping it at the first line in the block.
(0050221)
git (administrator)
2016-01-29 09:20

Branch CR26726 has been updated forcibly by isk.

SHA-1: 4476e94621275efa48a5c888b7afaf1e88134101
(0050222)
isk (developer)
2016-01-29 09:21

Move the comment.
(0050223)
git (administrator)
2016-01-29 10:35

Branch CR26726 has been updated forcibly by isk.

SHA-1: a8110c379f184791b4f9722824172bd01c0b7f5c
(0050224)
isk (developer)
2016-01-29 10:36

Update test case. It checks colors now.
(0050261)
kgv (developer)
2016-01-30 16:19

Please test the patch.
(0050307)
git (administrator)
2016-02-01 15:30

Branch CR26726 has been updated forcibly by apv.

SHA-1: 3a41881c6f7ab6f6a679753c5c9a00cb5800e66d
(0050308)
apv (tester)
2016-02-01 15:31

Branch CR26726 has been rebased on the current master
(0050337)
apv (tester)
2016-02-02 13:52

Dear BugMaster,

Branch CR26726 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 3a41881c6f7ab6f6a679753c5c9a00cb5800e66d

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 1 (1 on master)
products component:
   Linux: 36 (36 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
bugs vis bug26726 - OK
http://occt-tests/CR26726-master-occt-64/Debian70-64/bugs/vis/bug26726.html [^]
http://occt-tests/CR26726-master-occt-64/Windows-64-VC10/bugs/vis/bug26726.html [^]

Testing on Linux:
Total MEMORY difference: 89640207 / 89398107 [+0.27%]
Total CPU difference: 19068.98000000005 / 19103.799999999923 [-0.18%]

Testing on Windows:
Total MEMORY difference: 57285159 / 57304383 [-0.03%]
Total CPU difference: 17942.111812799227 / 18573.837862298933 [-3.40%]
(0052836)
git (administrator)
2016-04-17 13:18

Branch CR26726 has been deleted by kgv.

SHA-1: 3a41881c6f7ab6f6a679753c5c9a00cb5800e66d

- Related Changesets
occt: master 671b6fe0
Timestamp: 2016-01-29 07:34:22
Author: isk
Committer: bugmaster
Details ] Diff ]
0026726: Draw Harness, ViewerTest - AIS_InteractiveContext::EraseSelected() lacks test case
Update draw command ViewerTest::Erase().
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
add - tests/bugs/vis/bug26726 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-09-25 17:24 isk New Issue
2015-09-25 17:24 isk Assigned To => kgv
2015-09-25 17:25 isk Assigned To kgv => isk
2015-09-25 17:43 git Note Added: 0046153
2015-09-25 17:44 isk Assigned To isk => abv
2015-09-25 17:44 isk Status new => resolved
2015-09-25 17:44 isk Steps to Reproduce Updated View Revisions
2015-09-25 19:08 abv Assigned To abv => vpa
2015-09-25 20:00 vpa Note Added: 0046169
2015-09-25 20:00 vpa Assigned To vpa => isk
2015-09-25 20:00 vpa Status resolved => assigned
2015-09-28 07:26 isk Steps to Reproduce Updated View Revisions
2015-09-28 08:03 git Note Added: 0046180
2015-09-28 08:03 isk Assigned To isk => vpa
2015-09-28 08:03 isk Status assigned => resolved
2015-09-28 11:50 vpa Note Added: 0046194
2015-09-28 11:50 vpa Assigned To vpa => bugmaster
2015-09-28 11:50 vpa Status resolved => reviewed
2015-09-28 12:45 vpa Relationship added related to 0026628
2015-09-28 14:23 apv Assigned To bugmaster => apv
2015-09-28 14:49 git Note Added: 0046218
2015-09-28 14:49 apv Note Added: 0046219
2015-09-29 14:21 apv Test case number => bugs vis bug25726
2015-09-29 14:25 apv Note Added: 0046257
2015-09-29 14:25 apv Assigned To apv => isk
2015-09-29 14:25 apv Status reviewed => assigned
2015-09-29 14:25 apv Note Added: 0046258
2015-12-28 10:59 kgv Category OCCT:Visualization => OCCT:DRAW
2015-12-28 10:59 kgv Target Version 7.0.0 => 7.1.0
2015-12-28 10:59 kgv Summary Visualization: AIS_InteractiveContext::EraseSelected() lacks test case => Draw Harness, ViewerTest - AIS_InteractiveContext::EraseSelected() lacks test case
2016-01-28 16:47 git Note Added: 0050211
2016-01-28 16:49 isk Note Added: 0050213
2016-01-28 16:52 isk Note Added: 0050215
2016-01-28 16:52 isk Assigned To isk => vpa
2016-01-28 16:52 isk Status assigned => resolved
2016-01-29 08:50 kgv Note Added: 0050220
2016-01-29 09:20 git Note Added: 0050221
2016-01-29 09:21 isk Note Added: 0050222
2016-01-29 10:35 git Note Added: 0050223
2016-01-29 10:36 isk Note Added: 0050224
2016-01-30 16:19 kgv Note Added: 0050261
2016-01-30 16:19 kgv Assigned To vpa => bugmaster
2016-01-30 16:19 kgv Status resolved => reviewed
2016-01-30 16:19 kgv Target Version 7.1.0 => 7.0.0
2016-02-01 12:27 apv Assigned To bugmaster => apv
2016-02-01 15:30 git Note Added: 0050307
2016-02-01 15:31 apv Note Added: 0050308
2016-02-02 11:43 apv Test case number bugs vis bug25726 => bugs vis bug26726
2016-02-02 13:52 apv Note Added: 0050337
2016-02-02 13:52 apv Assigned To apv => bugmaster
2016-02-02 13:52 apv Status reviewed => tested
2016-02-05 12:49 bugmaster Changeset attached => occt master 671b6fe0
2016-02-05 12:49 bugmaster Status tested => verified
2016-02-05 12:49 bugmaster Resolution open => fixed
2016-04-17 13:18 git Note Added: 0052836
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker