MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026632Open CASCADE[OCCT] OCCT:Samplespublic2015-09-02 15:572015-10-23 20:49
Reporterapn 
Assigned Tokgv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 6.9.1Fixed in Version[OCCT] 6.9.1 
Summary0026632: HLR sample doesn't work with Algo mode
DescriptionHLR Process works incorrect using Algo mode in "Choose Shapes and Projector" menu. Problem is in out of range array in function Update in HLRBRep_Data.cxx.
Problem is reproduced on 6.9.1 beta (works correctly on 6.9.0)
Steps To ReproduceRun mfc HLR sample, import shape, run Process HLR, push Get Shapes and choose Algo mode.

--------------------------------------------------
Test script (it is OK on both MASTER and FIX. I cannot reproduce the problem with using DRAW-commands):

Draw[]> restore samples\\mfc\\standard\\Data\\bottle.brep bb
Draw[]> vinit
Draw[]> vdisplay bb
Draw[]> vfit
Draw[]> vhlr on
Draw[]> vhlrtype algo
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0045695)
bugmaster (administrator)
2015-09-16 10:55

Dear APN,

Please try to analyze reason of problem i.e. problem algorithm or sample.
If problem please ask JGV for help
(0045760)
apn (administrator)
2015-09-17 12:23

It's a problem in HLR algorithm (in HLRBRep_InternalAlgo.cxx)
(0045936)
nbv (developer)
2015-09-21 09:35

Dear Andrei (apn),

The main reason of the problem is incorrect curve resolution computation (with BSplCLib class). It returns resolution value ~ 1.0e307. Finally, it leads to Floating Overflow exception.
(0046000)
git (administrator)
2015-09-22 13:37

Branch CR26632 has been created by nbv.

SHA-1: 2063a4aaa76c9815937b3ff33f9aecea9c0a5050


Detailed log of new commits:

Author: nbv
Date: Tue Sep 22 13:35:13 2015 +0300

    0026632: HLR sample doesn't work with Algo mode
    
    The main reason of the problem is Walking-line contains two equal Walking-points (the segment has null-length both in 3D and 2D).
(0046001)
nbv (developer)
2015-09-22 13:51

Dear Mikhail,

Please review CR26632 branch.
(0046003)
git (administrator)
2015-09-22 14:21

Branch CR26632 has been updated forcibly by nbv.

SHA-1: 29dd3d1bd704a4157b77f5b45293f3cd3767d5e4
(0046005)
msv (developer)
2015-09-22 14:52

Reviewed.
Concerning the test case, it would be good to make a test command in QABugs.
(0046006)
nbv (developer)
2015-09-22 15:21

Issue #0026714 has been created according to previous recommendation.
(0046056)
apv (tester)
2015-09-23 16:18

Dear BugMaster,

Branch CR26632 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 29dd3d1bd704a4157b77f5b45293f3cd3767d5e4

Number of compiler warnings:
occt component:
   Linux: 15 (15 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing on Linux:
Total MEMORY difference: 92254523 / 92156584 [+0.11%]
Total CPU difference: 19069.22999999906 / 18924.599999998987 [+0.76%]

Testing on Windows:
Total MEMORY difference: 56863979 / 56867352 [-0.01%]
Total CPU difference: 16962.581533799137 / 17116.72612189913 [-0.90%]
(0046057)
apv (tester)
2015-09-23 16:18

Dear apn,

Please, verify HLR sample. Thank you in advance.
(0046078)
apn (administrator)
2015-09-24 11:47

HLR sample works correctly with Algo mode.
(0047009)
git (administrator)
2015-10-16 16:37

Branch CR26632 has been deleted by kgv.

SHA-1: 29dd3d1bd704a4157b77f5b45293f3cd3767d5e4

- Related Changesets
occt: master 657ccd95
Timestamp: 2015-09-22 10:35:13
Author: nbv
Committer: kgv
Details ] Diff ]
0026632: HLR sample doesn't work with Algo mode

The main reason of the problem is Walking-line contains two equal Walking-points (the segment has null-length both in 3D and 2D).
mod - src/IntWalk/IntWalk_IWalking_5.gxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-09-02 15:57 apn New Issue
2015-09-02 15:57 apn Assigned To => abv
2015-09-02 15:57 apn Status new => assigned
2015-09-16 10:53 bugmaster Assigned To abv => apn
2015-09-16 10:55 bugmaster Note Added: 0045695
2015-09-16 10:57 bugmaster Target Version => 6.9.1
2015-09-17 12:23 apn Note Added: 0045760
2015-09-17 12:23 apn Assigned To apn => jgv
2015-09-17 13:16 apn Description Updated View Revisions
2015-09-21 09:21 nbv Assigned To jgv => nbv
2015-09-21 09:35 nbv Note Added: 0045936
2015-09-22 13:37 git Note Added: 0046000
2015-09-22 13:51 nbv Note Added: 0046001
2015-09-22 13:51 nbv Assigned To nbv => msv
2015-09-22 13:51 nbv Status assigned => resolved
2015-09-22 13:51 nbv Steps to Reproduce Updated View Revisions
2015-09-22 14:21 git Note Added: 0046003
2015-09-22 14:52 msv Note Added: 0046005
2015-09-22 14:52 msv Assigned To msv => bugmaster
2015-09-22 14:52 msv Status resolved => reviewed
2015-09-22 15:14 nbv Steps to Reproduce Updated View Revisions
2015-09-22 15:19 nbv Relationship added related to 0026714
2015-09-22 15:21 nbv Note Added: 0046006
2015-09-22 18:31 apv Assigned To bugmaster => apv
2015-09-23 16:18 apv Note Added: 0046056
2015-09-23 16:18 apv Note Added: 0046057
2015-09-23 16:19 apv Assigned To apv => apn
2015-09-24 11:47 apn Note Added: 0046078
2015-09-24 11:48 apn Assigned To apn => bugmaster
2015-09-24 11:48 apn Status reviewed => tested
2015-09-28 12:58 kgv Changeset attached => occt master 657ccd95
2015-09-28 12:58 kgv Assigned To bugmaster => kgv
2015-09-28 12:58 kgv Status tested => verified
2015-09-28 12:58 kgv Resolution open => fixed
2015-10-16 14:55 aiv Status verified => closed
2015-10-16 16:37 git Note Added: 0047009
2015-10-23 20:49 aiv Fixed in Version => 6.9.1


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker