MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026617Open CASCADE[OCCT] OCCT:Visualizationpublic2015-08-28 17:462020-07-01 23:52
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026617: Visualization, Ray Tracing - adopt progressive rendering Path Tracing for rendering stereoscopic pair
DescriptionProgressive rendering does not work within stereoscopic output since only one FBO is checked by state variables OpenGl_View::myAccumFrames and OpenGl_View::myPreviousOrigins (see OpenGl_View::runRaytraceShaders()).
Steps To Reproducev3d/raytrace/bug26617
TagsNo tags attached.
Test case numberv3d raytrace bug26617
Attached Filespng file icon pathtracing_OK.png (250,081 bytes) 2015-09-01 14:57
png file icon pathtracing_stereo_KO.png (395,881 bytes) 2015-09-01 14:57

- Relationships
parent of 0031643closedbugmaster Open CASCADE Visualization - Graphic3d_Camera::Copy() raises exception on copying ZNear < 0.0 
related to 0026676closedkgv Open CASCADE Visualization, Ray Tracing - correct rendering if stereo pair 

-  Notes
(0045842)
git (administrator)
2015-09-17 20:42

Branch CR26617 has been created by apl.

SHA-1: 82ffd05a24d8bce77290254b682a76102641562d


Detailed log of new commits:

Author: apl
Date: Thu Sep 17 20:40:19 2015 +0300

    0026617: Visualization, Ray Tracing - adopt progressive rendering Path Tracing for rendering stereoscopic pair
    
    - Use two different FBOs for accumulating frames for left/right eye projection.
    - Added equality checks to camera modification methods to avoid camera updates when performing identity operations.
(0045859)
git (administrator)
2015-09-18 11:05

Branch CR26617 has been updated forcibly by apl.

SHA-1: 9babceb526bf9cc1d7c946d8fda5660d93ee030d
(0045864)
apl (developer)
2015-09-18 11:33
edited on: 2015-09-18 11:35

The patch is based on CR24776_4.

Dear Kirill,

Could you please review branch CR26617?

(0045925)
git (administrator)
2015-09-18 20:19

Branch CR26617 has been updated forcibly by apl.

SHA-1: 11387cec19941bdc4ca0578547acafc42689b0fb
(0045982)
git (administrator)
2015-09-22 11:57

Branch CR26617 has been updated forcibly by kgv.

SHA-1: 1aa61d9d5ad99a7802fe1571e7d66c3830d79604
(0045983)
kgv (developer)
2015-09-22 11:58

Patch is ready for testing.
Please note that branch CR26617 is based on patch CR24776_5 for 0024776 (which has additional branch in Products).
(0046036)
apv (tester)
2015-09-23 13:20

Dear BugMaster,

Branch CR26617 from occt git-repository (and CR24776 from products git-repository) was compiled on Linux and Windows platforms and tested.
SHA-1: 1aa61d9d5ad99a7802fe1571e7d66c3830d79604

Number of compiler warnings:
occt component:
   Linux: 15 (15 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR26617-CR24776-occt-64/Debian70-64/summary.html [^]
http://occt-tests/CR26617-CR24776-occt-64/Windows-64-VC10/summary.html [^]
v3d ivtk bgcolor, detect, display_mode, erase, select, selection_mode

Testing cases:
v3d raytrace bug26617 - OK
http://occt-tests/CR26617-CR24776-occt-64/Debian70-64/v3d/raytrace/bug26617.html [^]
http://occt-tests/CR26617-CR24776-occt-64/Windows-64-VC10/v3d/raytrace/bug26617.html [^]

Testing on Linux:
Total MEMORY difference: 92555279 / 92119688 [+0.47%]
Total CPU difference: 18937.959999998886 / 18923.689999998984 [+0.08%]

Testing on Windows:
Total MEMORY difference: 56790822 / 56820909 [-0.05%]
Total CPU difference: 17270.51190769897 / 16809.435352099128 [+2.74%]
(0046037)
apv (tester)
2015-09-23 13:28
edited on: 2015-09-23 13:33

Dear apl,

Branch CR26617 has been rejected due to:
- regressions/differences/improovements

(0047211)
git (administrator)
2015-10-20 12:59

Branch CR26617 has been updated forcibly by apl.

SHA-1: b1e6832cfa5bb34c92793c1a1f82cac344558397
(0047212)
git (administrator)
2015-10-20 13:00

Branch CR26617_1 has been created by apl.

SHA-1: f53c981e2b611954933142cc58d24164950bb13d


Detailed log of new commits:

Author: apl
Date: Tue Oct 20 12:59:56 2015 +0300

    0026617: Visualization, Ray Tracing - adopt progressive rendering Path Tracing for rendering stereoscopic pair
    
    - Use two different FBOs for accumulating frames for left/right eye projection.
    - Added equality checks to camera modification methods to avoid camera updates when performing identity operations.
(0047216)
apl (developer)
2015-10-20 13:15

Test cases (ivtk regressions) were corrected and changes pushed to CR26617.

The patch was rebased on current master and pushed to CR26617_1.

Dear Kirill,

Please review the patch.
(0047218)
kgv (developer)
2015-10-20 13:52

Please test updated patch.
(0047261)
apv (tester)
2015-10-21 12:10

Dear BugMaster,

Branch CR26617_1 from occt git-repository (and master from products git-repository) was compiled on Linux, Windows and MacOS platforms and tested.
SHA-1: f53c981e2b611954933142cc58d24164950bb13d

Number of compiler warnings:
occt component:
   Linux: 8 (8 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detetced

Testing cases:
v3d raytrace bug26617 - OK
http://occt-tests/CR26617-1-master-occt-64/Debian70-64/v3d/raytrace/bug26617.html [^]
http://occt-tests/CR26617-1-master-occt-64/Windows-64-VC10/v3d/raytrace/bug26617.html [^]

Testing on Linux:
Total MEMORY difference: 92112309 / 92269179 [-0.17%]
Total CPU difference: 19678.009999999897 / 19657.609999999728 [+0.10%]

Testing on Windows:
Total MEMORY difference: 58077272 / 58086183 [-0.02%]
Total CPU difference: 18525.617953198747 / 18302.583323498948 [+1.22%]
(0053207)
git (administrator)
2016-04-17 14:38

Branch CR26617 has been deleted by kgv.

SHA-1: b1e6832cfa5bb34c92793c1a1f82cac344558397
(0053208)
git (administrator)
2016-04-17 14:38

Branch CR26617_1 has been deleted by kgv.

SHA-1: f53c981e2b611954933142cc58d24164950bb13d

- Related Changesets
occt: master bf02aa7d
Timestamp: 2015-10-20 09:59:56
Author: apl
Committer: bugmaster
Details ] Diff ]
0026617: Visualization, Ray Tracing - adopt progressive rendering Path Tracing for rendering stereoscopic pair

- Use two different FBOs for accumulating frames for left/right eye projection.
- Added equality checks to camera modification methods to avoid camera updates when performing identity operations.
mod - src/Graphic3d/Graphic3d_Camera.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_FrameBuffer.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Raytrace.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Redraw.cxx Diff ] File ]
mod - src/V3d/V3d_View.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]
mod - tests/v3d/end Diff ] File ]
mod - tests/v3d/raytrace/begin Diff ] File ]
add - tests/v3d/raytrace/bug26617 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-08-28 17:46 kgv New Issue
2015-08-28 17:46 kgv Assigned To => dbp
2015-08-28 17:46 kgv Assigned To dbp => kgv
2015-09-01 14:57 kgv File Added: pathtracing_OK.png
2015-09-01 14:57 kgv File Added: pathtracing_stereo_KO.png
2015-09-10 16:53 kgv Relationship added related to 0026676
2015-09-10 16:54 kgv Relationship added child of 0025556
2015-09-14 11:44 apl Assigned To kgv => apl
2015-09-14 11:44 apl Status new => assigned
2015-09-17 20:42 git Note Added: 0045842
2015-09-18 11:05 git Note Added: 0045859
2015-09-18 11:33 apl Note Added: 0045864
2015-09-18 11:33 apl Assigned To apl => kgv
2015-09-18 11:33 apl Status assigned => resolved
2015-09-18 11:33 apl Steps to Reproduce Updated View Revisions
2015-09-18 11:35 apl Note Edited: 0045864 View Revisions
2015-09-18 20:19 git Note Added: 0045925
2015-09-22 11:57 git Note Added: 0045982
2015-09-22 11:58 kgv Note Added: 0045983
2015-09-22 11:58 kgv Assigned To kgv => bugmaster
2015-09-22 11:58 kgv Status resolved => reviewed
2015-09-22 16:22 apv Assigned To bugmaster => apv
2015-09-23 11:55 apv Test case number => v3d raytrace bug26617
2015-09-23 13:20 apv Note Added: 0046036
2015-09-23 13:20 apv Assigned To apv => apl
2015-09-23 13:20 apv Status reviewed => assigned
2015-09-23 13:28 apv Note Added: 0046037
2015-09-23 13:33 apv Note Edited: 0046037 View Revisions
2015-10-20 12:59 git Note Added: 0047211
2015-10-20 13:00 git Note Added: 0047212
2015-10-20 13:15 apl Note Added: 0047216
2015-10-20 13:15 apl Assigned To apl => kgv
2015-10-20 13:15 apl Status assigned => resolved
2015-10-20 13:52 kgv Note Added: 0047218
2015-10-20 13:52 kgv Assigned To kgv => bugmaster
2015-10-20 13:52 kgv Status resolved => reviewed
2015-10-20 14:53 apv Assigned To bugmaster => apv
2015-10-21 12:10 apv Note Added: 0047261
2015-10-21 12:10 apv Assigned To apv => bugmaster
2015-10-21 12:10 apv Status reviewed => tested
2015-10-23 12:30 bugmaster Changeset attached => occt master bf02aa7d
2015-10-23 12:30 bugmaster Status tested => verified
2015-10-23 12:30 bugmaster Resolution open => fixed
2016-04-17 14:38 git Note Added: 0053207
2016-04-17 14:38 git Note Added: 0053208
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:51 aiv Status verified => closed
2020-07-01 23:52 kgv Relationship added parent of 0031643


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker