MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026609Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2015-08-27 09:552016-04-20 15:49
Reporterpkv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026609: Wrong result obtained by solid classifier algorithm.
DescriptionWrong result obtained by solid classifier algorithm.

The problem was noticed by the customer:
http://asml.redmine.opencascade.com/issues/30 [^]
Steps To Reproducerestore z
restore p
bclassify z p

#Result: The point is OUT of shape
# but it should be IN.
Additional information
and documentation updates
The treatment of "inverted" shapes by solid classifier algorithm is improved.
"Inverted" shape is one that represent cavity in material.
TagsNo tags attached.
Test case numberbugs modalg_6 bug26609
Attached Fileszip file icon 0000030.zip (1,660 bytes) 2015-08-27 09:55

- Relationships
related to 0026590assignedmsv Inconsistent results obtained by checkshape 

-  Notes
(0045941)
git (administrator)
2015-09-21 12:54

Branch CR26609 has been created by ifv.

SHA-1: 3e5e27749b9557144e48960aeb73be3c0e7a666e


Detailed log of new commits:

Author: ifv
Date: Mon Sep 21 12:20:07 2015 +0300

    0026609: Wrong result obtained by solid classifier algorithm.
(0045942)
ifv (developer)
2015-09-21 12:56

Branch CR26609 is ready for review and tests
(0045945)
msv (developer)
2015-09-21 14:27

Reviewed.
(0046010)
apv (tester)
2015-09-22 16:36

Dear BugMaster,

Branch CR26609 from occt git-repository (and master from products git-repository) was compiled on Linux and Windows platforms and tested.
SHA-1: 3e5e27749b9557144e48960aeb73be3c0e7a666e

Number of compiler warnings:
occt component:
   Linux: 15 (15 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR26609-master-occt-64/Debian70-64/summary.html [^]
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/summary.html [^]
Boolean volumemaker B9 (Windows only), D4 (Windows only), D6

Testing on Linux:
Total MEMORY difference: 92027358 / 92153107 [-0.14%]
Total CPU difference: 19262.43999999915 / 18923.859999998986 [+1.79%]

Testing on Windows:
Total MEMORY difference: 56816161 / 56825005 [-0.02%]
Total CPU difference: 17322.865843299038 / 16809.482152399127 [+3.05%]

There are differences in images found by testdiff:
http://occt-tests/CR26609-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]
Boolean volumemaker A8, D7
(0046204)
git (administrator)
2015-09-28 13:33

Branch CR26609 has been updated forcibly by ifv.

SHA-1: a2151cd1fbd0accb8eb85bb5af1d3c957994147b
(0046230)
ifv (developer)
2015-09-28 18:24

Branch CR26609 is updated and can be tested
(0046288)
mkv (tester)
2015-09-29 18:42

Dear BugMaster,
Branch CR26609 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: a2151cd1fbd0accb8eb85bb5af1d3c957994147b

Number of compiler warnings:

occt component :
Linux: 13 (13 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/boolean/volumemaker/D6.html [^]
boolean volumemaker D6: FAILED

Testing cases:
http://occt-tests/CR26609-master-occt-64/Debian70-64/bugs/modalg_6/bug26609.html [^]
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug26609.html [^]
bugs modalg_6 bug26609: OK

Testing on Linux:
occt component :
Total MEMORY difference: 93607314 / 93277685 [+0.35%]
Total CPU difference: 19499.029999999515 / 19595.019999999236 [-0.49%]
products component :
Total MEMORY difference: 26254341 / 26289080 [-0.13%]
Total CPU difference: 7160.950000000005 / 7198.059999999998 [-0.52%]

Testing on Windows:
occt component :
Total MEMORY difference: 57904311 / 57932432 [-0.05%]
Total CPU difference: 17968.241980299106 / 17726.565231099077 [+1.36%]
products component :
Total MEMORY difference: 17122159 / 17129161 [-0.04%]
Total CPU difference: 5626.160464899974 / 5621.652035999961 [+0.08%]

There are no differences in images found by testdiff.
(0046289)
mkv (tester)
2015-09-29 18:43

Dear ifv,
Branch has been rejected due to:
- regressions/differences/improvements
(0046290)
git (administrator)
2015-09-29 18:44

Branch CR26609 has been updated by mkv.

SHA-1: 2df26d9c28af837fbadb787aa7a37c97a512ee7e


Detailed log of new commits:

Author: mkv
Date: Tue Sep 29 18:44:30 2015 +0300

    Test case for issue CR26609

(0046291)
mkv (tester)
2015-09-29 18:45

Dear ifv,
could you please review following test case
bugs modalg_6 bug26609
(0046501)
git (administrator)
2015-10-06 13:02

Branch CR26609 has been updated forcibly by ifv.

SHA-1: 7dbb329bfccddc5d9f11d78a43cc520422168d4e
(0046502)
ifv (developer)
2015-10-06 13:08

Ok for test case.
Branch CR26609 is updated, please test
(0046556)
mkv (tester)
2015-10-07 13:33

Dear BugMaster,
Branch CR26609 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 7dbb329bfccddc5d9f11d78a43cc520422168d4e

Number of compiler warnings:

occt component :
Linux: 13 (13 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:

Improvements:
http://occt-tests/CR26609-master-occt-64/Debian70-64/boolean/gdml_private/G7.html [^]
  boolean gdml_private G7
http://occt-tests/CR26609-master-occt-64/Debian70-64/boolean/gdml_private/T2.html [^]
  boolean gdml_private T2
http://occt-tests/CR26609-master-occt-64/Debian70-64/boolean/gdml_private/ZJ3.html [^]
  boolean gdml_private ZJ3
http://occt-tests/CR26609-master-occt-64/Debian70-64/boolean/gdml_private/ZJ4.html [^]
  boolean gdml_private ZJ4

Testing cases:
http://occt-tests/CR26609-master-occt-64/Debian70-64/bugs/modalg_6/bug26609.html [^]
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug26609.html [^]
bugs modalg_6 bug26609: OK

Testing on Linux:
occt component :
Total MEMORY difference: 93118233 / 92262834 [+0.93%]
Total CPU difference: 19681.359999999753 / 19770.619999999843 [-0.45%]
products component :
Total MEMORY difference: 26344181 / 26369733 [-0.10%]
Total CPU difference: 7340.2199999999975 / 7378.749999999995 [-0.52%]

Testing on Windows:
occt component :
Total MEMORY difference: 58070841 / 58089039 [-0.03%]
Total CPU difference: 18225.456429099137 / 18228.68564979895 [-0.02%]
products component :
Total MEMORY difference: 17178489 / 17183716 [-0.03%]
Total CPU difference: 5607.42474479997 / 5689.09126829997 [-1.44%]

There are following differences in images found by testdiff.
http://occt-tests/CR26609-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR26609-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]
IMAGE boolean gdml_private S9: S9.png differs
IMAGE boolean gdml_private J6: J6.png differs
IMAGE boolean gdml_private P2: P2.png differs
IMAGE boolean gdml_private N8: N8.png differs
IMAGE boolean gdml_private O3: O3.png differs
IMAGE boolean gdml_private W1: W1.png differs
IMAGE boolean gdml_private O9: O9.png differs
IMAGE boolean gdml_private H9: H9.png differs
IMAGE boolean gdml_private V2: V2.png differs
IMAGE boolean volumemaker B4: B4.png differs
IMAGE boolean volumemaker A5: A5.png differs
IMAGE boolean volumemaker D7: D7.png differs
IMAGE boolean volumemaker D4: D4.png differs
IMAGE boolean volumemaker A8: A8.png differs
(0046559)
mkv (tester)
2015-10-07 13:41

Dear ifv,
Branch CR26609 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0046560)
git (administrator)
2015-10-07 13:44

Branch CR26609 has been updated by mkv.

SHA-1: d4622a93d004da0f77e0f42788785009ce7bed4c


Detailed log of new commits:

Author: mkv
Date: Wed Oct 7 13:44:08 2015 +0300

    Test case for issue CR26609

(0046566)
ifv (developer)
2015-10-07 15:34

Difference of images correspond to current state of algorithms. New images can be considered as correct.
(0046588)
git (administrator)
2015-10-08 12:34

Branch CR26609 has been updated by mkv.

SHA-1: 2115be2e834f33eb48c8742af2c16c698d436ade


Detailed log of new commits:

Author: mkv
Date: Thu Oct 8 12:34:48 2015 +0300

    Correction of test cases for issue CR26609

(0046589)
mkv (tester)
2015-10-08 12:38

Dear BugMaster,
following test cases are corrected and pushed to branch CR of occt git-repository
  boolean gdml_private T2, ZJ3, ZJ4
Now its are OK.
(0046590)
mkv (tester)
2015-10-08 12:38

Dear BugMaster,
Branch CR26609 is TESTED.
(0047082)
git (administrator)
2015-10-16 16:58

Branch CR26609 has been deleted by kgv.

SHA-1: 2115be2e834f33eb48c8742af2c16c698d436ade

- Related Changesets
occt: master a0258acd
Timestamp: 2015-10-08 10:26:15
Author: ifv
Committer: bugmaster
Details ] Diff ]
0026609: Wrong result obtained by solid classifier algorithm.

Test case for issue CR26609

Correction of test cases for issue CR26609
mod - src/BRepClass3d/BRepClass3d_SolidExplorer.cxx Diff ] File ]
mod - src/IntCurvesFace/IntCurvesFace_Intersector.cxx Diff ] File ]
mod - src/IntCurvesFace/IntCurvesFace_Intersector.hxx Diff ] File ]
mod - tests/boolean/gdml_private/T2 Diff ] File ]
mod - tests/boolean/gdml_private/ZJ3 Diff ] File ]
mod - tests/boolean/gdml_private/ZJ4 Diff ] File ]
mod - tests/boolean/volumemaker/D4 Diff ] File ]
add - tests/bugs/modalg_6/bug26609 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-08-27 09:55 pkv New Issue
2015-08-27 09:55 pkv Assigned To => msv
2015-08-27 09:55 pkv File Added: 0000030.zip
2015-08-27 09:56 pkv Status new => assigned
2015-08-27 09:57 pkv Relationship added related to 0026590
2015-08-27 14:28 msv Assigned To msv => ifv
2015-09-21 12:54 git Note Added: 0045941
2015-09-21 12:56 ifv Note Added: 0045942
2015-09-21 12:56 ifv Assigned To ifv => msv
2015-09-21 12:56 ifv Status assigned => resolved
2015-09-21 14:27 msv Note Added: 0045945
2015-09-21 14:27 msv Assigned To msv => bugmaster
2015-09-21 14:27 msv Status resolved => reviewed
2015-09-21 17:17 apv Assigned To bugmaster => apv
2015-09-22 16:36 apv Note Added: 0046010
2015-09-22 16:36 apv Assigned To apv => ifv
2015-09-22 16:36 apv Status reviewed => assigned
2015-09-28 13:33 git Note Added: 0046204
2015-09-28 18:23 ifv Status assigned => resolved
2015-09-28 18:24 ifv Note Added: 0046230
2015-09-28 18:24 ifv Assigned To ifv => bugmaster
2015-09-28 18:24 ifv Status resolved => reviewed
2015-09-28 19:51 mkv Assigned To bugmaster => mkv
2015-09-29 18:42 mkv Note Added: 0046288
2015-09-29 18:43 mkv Note Added: 0046289
2015-09-29 18:43 mkv Assigned To mkv => ifv
2015-09-29 18:43 mkv Status reviewed => feedback
2015-09-29 18:44 git Note Added: 0046290
2015-09-29 18:45 mkv Note Added: 0046291
2015-09-29 18:45 mkv Test case number => bugs modalg_6 bug26609
2015-10-06 13:02 git Note Added: 0046501
2015-10-06 13:08 ifv Note Added: 0046502
2015-10-06 13:08 ifv Assigned To ifv => bugmaster
2015-10-06 13:08 ifv Status feedback => reviewed
2015-10-06 13:37 mkv Assigned To bugmaster => mkv
2015-10-07 13:33 mkv Note Added: 0046556
2015-10-07 13:41 mkv Note Added: 0046559
2015-10-07 13:41 mkv Assigned To mkv => ifv
2015-10-07 13:41 mkv Status reviewed => feedback
2015-10-07 13:44 git Note Added: 0046560
2015-10-07 15:34 ifv Note Added: 0046566
2015-10-07 15:34 ifv Assigned To ifv => bugmaster
2015-10-07 15:34 ifv Status feedback => reviewed
2015-10-07 15:45 mkv Assigned To bugmaster => mkv
2015-10-08 12:34 git Note Added: 0046588
2015-10-08 12:38 mkv Note Added: 0046589
2015-10-08 12:38 mkv Note Added: 0046590
2015-10-08 12:38 mkv Assigned To mkv => bugmaster
2015-10-08 12:38 mkv Status reviewed => tested
2015-10-09 15:22 bugmaster Changeset attached => occt master a0258acd
2015-10-09 15:22 bugmaster Status tested => verified
2015-10-09 15:22 bugmaster Resolution open => fixed
2015-10-16 16:58 git Note Added: 0047082
2015-11-19 18:44 ifv Additional Information Updated View Revisions
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:49 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker