MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026536Open CASCADE[OCCT] OCCT:Visualizationpublic2015-08-10 11:552016-04-20 15:48
Reporterdbp 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026536: Visualization, Ray-tracing engine - improve BVH traverse and fix texture support
DescriptionImproving BVH traverse and fixing texture support
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Filesjpg file icon turb.jpg (41,203 bytes) 2015-08-11 14:00

- Relationships

-  Notes
(0043933)
git (administrator)
2015-08-10 11:55

Branch CR26536 has been created by dbp.

SHA-1: 74de3dd2c1290b09ad4c10b5ebc4440228f4389c


Detailed log of new commits:

Author: dbp
Date: Mon Aug 10 11:42:05 2015 +0300

    Revising traverse of two-level BVH and fixing texture support
(0043936)
git (administrator)
2015-08-10 13:44

Branch CR26536_1 has been created by dbp.

SHA-1: 227e97385aa8b4c58b702c0d81af6c92e57ed72b


Detailed log of new commits:

Author: dbp
Date: Mon Aug 10 12:34:58 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
(0043949)
git (administrator)
2015-08-10 17:55

Branch CR26536_2 has been created by dbp.

SHA-1: 789c2093cb79c42fb93cc04de0ddc7604efce848


Detailed log of new commits:

Author: dbp
Date: Mon Aug 10 12:34:58 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
(0043961)
git (administrator)
2015-08-11 11:02

Branch CR26536_3 has been created by dbp.

SHA-1: 919a8ccc468df4b32ce2e9ff71a316272e72d2cf


Detailed log of new commits:

Author: dbp
Date: Mon Aug 10 12:34:58 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
(0043964)
git (administrator)
2015-08-11 12:02

Branch CR26536_3 has been updated forcibly by dbp.

SHA-1: 8a85bc458de9dea4f0ae619c4d9c18bc64e9fae9
(0043965)
git (administrator)
2015-08-11 12:10

Branch CR26536_4 has been created by duv.

SHA-1: 057a266518880e13ad173afb277c4c9833bd043a


Detailed log of new commits:

Author: dbp
Date: Mon Aug 10 12:34:58 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
(0044027)
dbp (developer)
2015-08-12 12:14

Dear kgv,

please review the patch in branch CR26536_4. Main improvements:

1) Textures are working on AMD! If you have time and possibility, could you please check it on your Radeon? We have tested on Radeon 7870.

2) Rendering of large-scale scenes containing many objects (> 100) was significantly improved. E.g. on the turbine model (sceenshot attached) path tracing performance increased on 40%. This is due to refactored traverse subroutine: now there is single traverse for two levels of BVH.
(0044071)
git (administrator)
2015-08-13 12:28

Branch CR26536_4 has been updated by kgv.

SHA-1: 21394f35e6988fe8df8e46d5127489c68035d098


Detailed log of new commits:

Author: kgv
Date: Thu Aug 13 09:27:41 2015 +0300

    OpenGl_View::initProgram() - fix NULL-dereference

(0044072)
git (administrator)
2015-08-13 12:49

Branch CR26536_4 has been updated by kgv.

SHA-1: 5f1c3c708c34d975a8abccdc89082a421c4a68df


Detailed log of new commits:

Author: kgv
Date: Thu Aug 13 09:49:20 2015 +0300

    OpenGl_RaytraceGeometry::ReleaseResources() - nullify resource

(0044085)
kgv (developer)
2015-08-13 14:38
edited on: 2015-08-13 14:38

I confirm that textures are now operable on Radeon R9 R290 (with Catalyst 15.4 beta).
Please proceed minor remarks.

(0044716)
git (administrator)
2015-08-27 12:09

Branch CR26536_5 has been created by dbp.

SHA-1: 19e8aba2a3703fdaf5c7cad31b1dbd2b07713f9e


Detailed log of new commits:

Author: dbp
Date: Thu Aug 27 10:27:41 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
    
    In order to provide compatibility with AMD GPUs, 64-bit texture handles were replaced by uvec2 type in GLSL code.
(0044717)
dbp (developer)
2015-08-27 12:09

Dear kgv,

please review the patch in branch CR26536_5.
(0044719)
git (administrator)
2015-08-27 12:16

Branch CR26536_5 has been updated forcibly by dbp.

SHA-1: 77efc3227c1112c3c8d1eb8110bce94120b4451b
(0044721)
git (administrator)
2015-08-27 12:34

Branch CR26536_4_new has been created by dbp.

SHA-1: 350f3d7350758227b565d0934a79591e9f641049


Detailed log of new commits:

Author: dbp
Date: Thu Aug 27 10:27:41 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
    
    In order to provide compatibility with AMD GPUs, 64-bit texture handles were replaced by uvec2 type in GLSL code.
(0044726)
git (administrator)
2015-08-27 12:43

Branch CR26536_4_new has been updated by kgv.

SHA-1: 8c5fe55264d7ba2531d219c6f2a34f990177489a


Detailed log of new commits:

Author: kgv
Date: Thu Aug 27 12:43:22 2015 +0300

    cosmetics

(0044727)
git (administrator)
2015-08-27 12:46

Branch CR26536_6 has been created by kgv.

SHA-1: 90481da9989b36b03c8c7b786d3fcf59d753871b


Detailed log of new commits:

Author: dbp
Date: Thu Aug 27 12:46:22 2015 +0300

    0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support
    
    Replace 64-bit handles of bindless textures by uvec2 type in GLSL code for compatibility with AMD drivers.
    OpenGl_View::initProgram() - fix NULL-dereference.
(0044728)
kgv (developer)
2015-08-27 12:47

Please test patch in branch CR26536_6.
(0044766)
git (administrator)
2015-08-27 18:53

Branch CR26536_6 has been updated forcibly by mkv.

SHA-1: 4b44d7222ba92a2c51b1436da4fc8df2170a060b
(0044803)
mkv (tester)
2015-08-28 15:11

Dear BugMaster,
Branch CR26536_6 was rebased on branch IR-2015-08-27 of occt git-repository.
SHA-1: 4b44d7222ba92a2c51b1436da4fc8df2170a060b
(0044804)
mkv (tester)
2015-08-28 15:11

Dear BugMaster,
Branch CR26536_6 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 4b44d7222ba92a2c51b1436da4fc8df2170a060b

Number of compiler warnings:

occt component :
Linux: 15 (15 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 91918242 / 91193918 [+0.79%]
Total CPU difference: 17887.33999999895 / 17162.149999999383 [+4.23%]
products component :
Total MEMORY difference: 25186122 / 25216901 [-0.12%]
Total CPU difference: 7113.120000000007 / 7037.939999999998 [+1.07%]

Testing on Windows:
occt component :
Total MEMORY difference: 57061389 / 57052452 [+0.02%]
Total CPU difference: 16078.882669099032 / 16097.197186498954 [-0.11%]
products component :
Total MEMORY difference: 16223163 / 16222282 [+0.01%]
Total CPU difference: 5385.263720699981 / 5332.831784599964 [+0.98%]

There are following differences in images found by testdiff.
http://occt-tests/CR26536-6-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
IMAGE bugs vis bug24288_2: bug24288_2_Driver1_Viewer1_View1.png differs
IMAGE bugs vis bug25732_1: bug25732_1_Driver1_Viewer1_View1.png differs
(0044813)
kgv (developer)
2015-08-28 15:31

Dear bugmaster,

> There are following differences in images found by testdiff.
> http://occt-tests/CR26536-6-master-occt-64/Debian70-64/diff-Debian70-64.html [^] [^]
> IMAGE bugs vis bug24288_2: bug24288_2_Driver1_Viewer1_View1.png differs
> IMAGE bugs vis bug25732_1: bug25732_1_Driver1_Viewer1_View1.png differs
these differences are caused by different versions of tests (with and without "vfont add") and unrelated to patch itself.
Please switch to tested.
(0046851)
git (administrator)
2015-10-16 16:08

Branch CR26536 has been deleted by kgv.

SHA-1: 74de3dd2c1290b09ad4c10b5ebc4440228f4389c
(0046852)
git (administrator)
2015-10-16 16:08

Branch CR26536_1 has been deleted by kgv.

SHA-1: 227e97385aa8b4c58b702c0d81af6c92e57ed72b
(0046853)
git (administrator)
2015-10-16 16:08

Branch CR26536_2 has been deleted by kgv.

SHA-1: 789c2093cb79c42fb93cc04de0ddc7604efce848
(0046854)
git (administrator)
2015-10-16 16:08

Branch CR26536_3 has been deleted by kgv.

SHA-1: 8a85bc458de9dea4f0ae619c4d9c18bc64e9fae9
(0046855)
git (administrator)
2015-10-16 16:08

Branch CR26536_4 has been deleted by kgv.

SHA-1: 5f1c3c708c34d975a8abccdc89082a421c4a68df
(0046856)
git (administrator)
2015-10-16 16:08

Branch CR26536_4_new has been deleted by kgv.

SHA-1: 8c5fe55264d7ba2531d219c6f2a34f990177489a
(0046857)
git (administrator)
2015-10-16 16:08

Branch CR26536_5 has been deleted by kgv.

SHA-1: 77efc3227c1112c3c8d1eb8110bce94120b4451b
(0046858)
git (administrator)
2015-10-16 16:08

Branch CR26536_6 has been deleted by kgv.

SHA-1: 4b44d7222ba92a2c51b1436da4fc8df2170a060b

- Related Changesets
occt: master 47e9c178
Timestamp: 2015-08-27 09:46:22
Author: dbp
Committer: bugmaster
Details ] Diff ]
0026536: Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support

Replace 64-bit handles of bindless textures by uvec2 type in GLSL code for compatibility with AMD drivers.
OpenGl_View::initProgram() - fix NULL-dereference.
mod - src/BVH/BVH_Tree.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_SceneGeometry.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_SceneGeometry.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderProgram.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderProgram.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_2.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Raytrace.cxx Diff ] File ]
mod - src/Shaders/PathtraceBase.fs Diff ] File ]
mod - src/Shaders/RaytraceBase.fs Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-08-10 11:55 dbp New Issue
2015-08-10 11:55 dbp Assigned To => kgv
2015-08-10 11:55 git Note Added: 0043933
2015-08-10 13:44 git Note Added: 0043936
2015-08-10 17:55 git Note Added: 0043949
2015-08-11 11:02 git Note Added: 0043961
2015-08-11 12:02 git Note Added: 0043964
2015-08-11 12:10 git Note Added: 0043965
2015-08-11 13:58 dbp Status new => resolved
2015-08-11 13:58 dbp Steps to Reproduce Updated View Revisions
2015-08-11 13:58 dbp File Added: turb.png
2015-08-11 13:58 dbp File Deleted: turb.png
2015-08-11 14:00 dbp File Added: turb.jpg
2015-08-12 12:14 dbp Assigned To kgv => dbp
2015-08-12 12:14 dbp Status resolved => assigned
2015-08-12 12:14 dbp Steps to Reproduce Updated View Revisions
2015-08-12 12:14 dbp Note Added: 0044027
2015-08-12 12:14 dbp Assigned To dbp => kgv
2015-08-12 12:14 dbp Status assigned => resolved
2015-08-12 12:14 dbp Steps to Reproduce Updated View Revisions
2015-08-13 12:28 git Note Added: 0044071
2015-08-13 12:49 git Note Added: 0044072
2015-08-13 14:38 kgv Note Added: 0044085
2015-08-13 14:38 kgv Note Edited: 0044085 View Revisions
2015-08-13 14:39 kgv Assigned To kgv => dbp
2015-08-13 14:39 kgv Status resolved => assigned
2015-08-13 14:39 kgv Product Version Unscheduled =>
2015-08-13 14:39 kgv Summary Visualization - Ray-tracing engine: improving BVH traverse and fixing texture support => Visualization, Ray-tracing engine - improve BVH traverse and fix texture support
2015-08-13 16:11 bugmaster Project Salome => Open CASCADE
2015-08-27 12:09 git Note Added: 0044716
2015-08-27 12:09 dbp Note Added: 0044717
2015-08-27 12:09 dbp Assigned To dbp => kgv
2015-08-27 12:09 dbp Status assigned => resolved
2015-08-27 12:16 git Note Added: 0044719
2015-08-27 12:34 git Note Added: 0044721
2015-08-27 12:43 git Note Added: 0044726
2015-08-27 12:46 git Note Added: 0044727
2015-08-27 12:47 kgv Note Added: 0044728
2015-08-27 12:47 kgv Assigned To kgv => bugmaster
2015-08-27 12:47 kgv Status resolved => reviewed
2015-08-27 18:53 git Note Added: 0044766
2015-08-27 19:00 mkv Assigned To bugmaster => mkv
2015-08-28 15:11 mkv Note Added: 0044803
2015-08-28 15:11 mkv Note Added: 0044804
2015-08-28 15:11 mkv Assigned To mkv => kgv
2015-08-28 15:11 mkv Status reviewed => feedback
2015-08-28 15:12 mkv Test case number => Not needed
2015-08-28 15:31 kgv Note Added: 0044813
2015-08-28 15:31 kgv Assigned To kgv => bugmaster
2015-09-01 14:18 bugmaster Status feedback => tested
2015-09-04 13:02 bugmaster Changeset attached => occt master 47e9c178
2015-09-04 13:02 bugmaster Status tested => verified
2015-09-04 13:02 bugmaster Resolution open => fixed
2015-10-16 16:08 git Note Added: 0046851
2015-10-16 16:08 git Note Added: 0046852
2015-10-16 16:08 git Note Added: 0046853
2015-10-16 16:08 git Note Added: 0046854
2015-10-16 16:08 git Note Added: 0046855
2015-10-16 16:08 git Note Added: 0046856
2015-10-16 16:08 git Note Added: 0046857
2015-10-16 16:08 git Note Added: 0046858
2016-04-20 15:44 aiv Fixed in Version => 7.0.0
2016-04-20 15:48 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker