MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026533Community[OCCT] OCCT:Visualizationpublic2015-08-07 12:562015-10-23 20:50
ReporterTimo 
Assigned Tobugmaster 
PrioritynormalSeveritytext 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 6.9.1Fixed in Version[OCCT] 6.9.1 
Summary0026533: Draw command vdisplay requires vclear to update the presentation since OCC 6.9.0
DescriptionThere is a difference between OCC 6.8.0 and 6.9.0:

After the meshing has been improved by incmesh, the visualization can be updated by vdisplay in OCC 6.8.0.
In 6.9.0 the visualization is only updated when vclear is performed before vdisplay.

Is this intended or a bug?
Steps To Reproduce
pload MODELING VISUALIZATION
vinit View1
vclear
vtop
restore Aal2.brep a
vdisplay a
vfit
incmesh a 0.3
vdisplay -redisplay a

=> black screen until rotate/vfit

restore Aal2.brep a
vdisplay a
incmesh a 0.3
vdisplay a
=> visualization is not changed

vclear
vdisplay a
=> visualization changed (now edge is smooth)
TagsNo tags attached.
Test case numberNot needed
Attached Files? file icon Aal2.brep (3,749 bytes) 2015-08-07 12:56
png file icon not smooth edge visualization.png (40,348 bytes) 2015-08-07 12:56
png file icon smooth edge visualization.png (24,575 bytes) 2015-08-07 12:56

- Relationships
related to 0026532closedbugmaster Community Meshing of edge with minSize parameter leads to incorrect result 
related to 0026238closedbugmaster Community Visualization - flicking when draw dynamic AIS object on Radeon 
related to 0025343closedbugmaster Open CASCADE Visualization - Update user's guide and DRAW commands description 
related to 0026688closedbugmaster Community Visualization, TKOpenGl - apply transparency within GLSL programs 

-  Notes
(0043906)
kgv (developer)
2015-08-07 13:13
edited on: 2015-08-07 13:25

The current behavior is expected.
The following syntax should work for you:
vdisplay -redisplay a

The flag "-redisplay" has been lost from help output for some reason... so this should be corrected.

(0043912)
Timo (developer)
2015-08-07 14:03
edited on: 2015-08-07 14:24

OK, with -redisplay the edge is smooth.

But I think, when using "vdisplay -redisplay a", an update of the view is missing, because the screen is black until I scale or click on the view or do a "vupdate a".
The -update and -noupdate parameters of vdisplay seem to have no effect. By the way, what is the default?

The Draw User's guide does not contain the new arguments that were introduced in OCC 6.9.0.

(0043913)
kgv (developer)
2015-08-07 14:27

> The -update and -noupdate parameters of vdisplay seem to have no effect. By the way, what is the default?
default value of this option is meant to be configurable.
But for now default is -update.
(0044595)
kgv (developer)
2015-08-25 12:06

Dear Timo,

> But I think, when using "vdisplay -redisplay a",
> an update of the view is missing,
> because the screen is black until I scale or click on the view or do a "vupdate a".
could you please provide OpenGL drivers info (vglinfo)?
It seems that the problem with black screen is caused by the same reason as in 0026238 (e.g. not reproducible on up-to-date drivers).
(0044600)
Timo (developer)
2015-08-25 13:00

OpenGL info:
  GLvendor = 'ATI Technologies Inc.'
  GLdevice = 'ATI FirePro V5800 (FireGL V)'
  GLversion = '4.3.12800 Compatibility Profile Context FireGL 13.350.1012.0'
  GLSLversion = '4.30'
(0044601)
kgv (developer)
2015-08-25 14:02

> GLversion = '4.3.12800 Compatibility Profile Context FireGL 13.350.1012.0'
OK, so this it seems to be the same AMD driver bug that has been fixed in Catalyst 15.7 release.
(0044602)
kgv (developer)
2015-08-25 14:04

Dear Ilya,

please update documentation related to vdisplay command (and similar).
(0044790)
git (administrator)
2015-08-28 12:22

Branch CR26533 has been created by isk.

SHA-1: 8824a529f13ae81df2e88297ce5c2692ddb77d1a


Detailed log of new commits:

Author: isk
Date: Fri Aug 28 12:21:01 2015 +0300

    0026533: Draw command vdisplay requires vclear to update the presentation since OCC 6.9.0.
    Update documentation related to vdisplay command.
(0045228)
Timo (developer)
2015-09-08 14:54

Driver update failed on my system. I reported it to AMD.
But when I use "vcaps -ffp 0" the problem of "vdisplay -redisplay a" is fixed.
(0045289)
git (administrator)
2015-09-09 11:05

Branch CR26533 has been updated forcibly by isk.

SHA-1: 7c8710e69139edb8d9e1b7605bfadabd63cc36a2
(0045299)
isk (developer)
2015-09-09 12:29

Dear Kirill,
Please review the branch CR26533.
(0045397)
kgv (developer)
2015-09-10 12:32

Please check compilation, regression testing is not needed.
(0045456)
git (administrator)
2015-09-10 19:17

Branch CR26533 has been updated forcibly by mkv.

SHA-1: 577e53891526ba93a3d6a43c0045d0dfce8e8d18
(0045534)
mkv (tester)
2015-09-11 18:31

Dear BugMaster,
Branch CR26533 was rebased on branch IR-2015-09-10 of occt git-repository.
SHA-1: 577e53891526ba93a3d6a43c0045d0dfce8e8d18
(0045535)
mkv (tester)
2015-09-11 18:31

Dear BugMaster,
Branch CR26533 from occt git-repository (and master from products git-repository) was compiled on Linux and Windows platforms and tested on Release mode.
SHA-1: 577e53891526ba93a3d6a43c0045d0dfce8e8d18

Number of compiler warnings:

occt component :
Linux: 16 (15 on master)
Windows: 2 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

There is new additional compilation warning on Linux platform:
http://jenkins-test-01.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_17008/job/CR26533-master_build_occt_linux/1/warnings17Result/package.2123673135/ [^]
ViewerTest_ObjectCommands.cxx:6252, GNU C Compiler 4 (gcc), Priority: Normal
unknown escape sequence: '\:' [enabled by default]

There is new additional compilation warning on Windows platform:
http://jenkins-test-01.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_17008/job/CR26533-master_build_occt_windows_64/1/warnings34Result/ [^]
ViewerTest_ObjectCommands.cxx:6252, MSBuild, Priority: Normal
':' : unrecognized character escape sequence

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR26533-master-occt-64/Debian70-64/bugs/demo/bug26533.html [^]
http://occt-tests/CR26533-master-occt-64/Windows-64-VC10/bugs/demo/bug26533.html [^]
bugs demo bug26533: OK

Testing on Linux:
occt component :
Total MEMORY difference: 91527310 / 91877805 [-0.38%]
Total CPU difference: 17760.10999999898 / 17784.189999999086 [-0.14%]
products component :
Total MEMORY difference: 25215618 / 25244094 [-0.11%]
Total CPU difference: 7092.329999999991 / 7047.8300000000045 [+0.63%]

Testing on Windows:
occt component :
Total MEMORY difference: 57170285 / 57163344 [+0.01%]
Total CPU difference: 16185.665353599072 / 16285.86479589925 [-0.62%]
products component :
Total MEMORY difference: 16215975 / 16215956 [+0.00%]
Total CPU difference: 5395.606586999971 / 5419.583940699973 [-0.44%]

There are no differences in images found by testdiff.
(0045536)
git (administrator)
2015-09-11 18:31

Branch CR26533 has been updated by mkv.

SHA-1: 6b3f8c79c834ffd548ad5d5cc7ee4c27a88d0274


Detailed log of new commits:

Author: mkv
Date: Fri Sep 11 18:31:47 2015 +0300

    Test case for issue CR26533

(0045537)
mkv (tester)
2015-09-11 18:32

Dear isk,
could you please review following test case
bugs demo bug26533
(0045541)
kgv (developer)
2015-09-11 19:38

Dear mkv,

> could you please review following test case
> bugs demo bug26533
please drop the test case. There no need to have such test for bug in driver which would be not reproduced within image dump anyway.
(0045555)
Timo (developer)
2015-09-14 11:50

Now the graphic driver update worked. And after it the problem is fixed independent of vcaps -ffp settings.

OpenGL info:
  GLvendor = 'ATI Technologies Inc.'
  GLdevice = 'ATI FirePro V5800 (FireGL) Graphics Adapter'
  GLversion = '4.4.13300 Compatibility Profile Context FireGL 14.502.1032.0'
  GLSLversion = '4.40'
(0045565)
kgv (developer)
2015-09-14 13:56

Dear Timo,

> Now the graphic driver update worked.
> And after it the problem is fixed independent of vcaps -ffp settings.
thank you for confirming.
(0045605)
git (administrator)
2015-09-15 09:29

Branch CR26533 has been updated by isk.

SHA-1: 6e8b3ecd79c0a83455acde5869e85678fd6a9a48


Detailed log of new commits:

Author: isk
Date: Tue Sep 15 09:29:15 2015 +0300

    Eliminate warning. Drop test case.

(0045613)
git (administrator)
2015-09-15 12:10

Branch CR26533_1 has been created by isk.

SHA-1: 5070159d8f262d1e9e5db40757021157283a328a


Detailed log of new commits:

Author: isk
Date: Tue Sep 15 12:06:43 2015 +0300

    0026533: Draw command vdisplay requires vclear to update the presentation since OCC 6.9.0.
    Update documentation related to vdisplay command and similar.
(0045622)
Timo (developer)
2015-09-15 12:45

Just to mention that with
vcaps -ffp 0
we experienced the following problems on OCC 6.9.0:
- transparency didn't work
- capping of clipping plane wasnt visible
                Graphic3d_ClipPlane.SetCapping(true);
                Graphic3d_ClipPlane.SetCappingHatchOn();

I guess it is already known to you.
(0045625)
kgv (developer)
2015-09-15 12:54

Dear Timo,

> capping of clipping plane wasnt visible
this is most likely a bug 0026122.

> transparency didn't work
I would appreciate if you register the bug with appropriate test case.

Thank you.
(0045630)
Timo (developer)
2015-09-15 13:32

OK, see 0026688.
(0045644)
kgv (developer)
2015-09-15 15:30

Please check compilation of updated patch in branch CR26533_1.
(0045718)
mkv (tester)
2015-09-16 15:12

Dear BugMaster,
Branch CR26533_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 5070159d8f262d1e9e5db40757021157283a328a

Number of compiler warnings:

occt component :
Linux: 15 (15 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 92426838 / 92770647 [-0.37%]
Total CPU difference: 17940.289999999008 / 17943.789999999088 [-0.02%]
products component :
Total MEMORY difference: 25933679 / 25884840 [+0.19%]
Total CPU difference: 7702.959999999991 / 7187.509999999996 [+7.17%]

Testing on Windows:
occt component :
Total MEMORY difference: 57717739 / 57708552 [+0.02%]
Total CPU difference: 16456.186687698955 / 16459.571909399227 [-0.02%]
products component :
Total MEMORY difference: 16789617 / 16788939 [+0.00%]
Total CPU difference: 5510.267321999974 / 5566.7084837999655 [-1.01%]

There are no differences in images found by testdiff.
(0046882)
git (administrator)
2015-10-16 16:14

Branch CR26533 has been deleted by kgv.

SHA-1: 6e8b3ecd79c0a83455acde5869e85678fd6a9a48
(0046883)
git (administrator)
2015-10-16 16:14

Branch CR26533_1 has been deleted by kgv.

SHA-1: 5070159d8f262d1e9e5db40757021157283a328a

- Related Changesets
occt: master faea8b40
Timestamp: 2015-09-15 09:06:43
Author: isk
Committer: bugmaster
Details ] Diff ]
0026533: Draw command vdisplay requires vclear to update the presentation since OCC 6.9.0.
Update documentation related to vdisplay command and similar.
mod - dox/user_guides/draw_test_harness/draw_test_harness.md Diff ] File ]
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_RelationCommands.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-08-07 12:56 Timo New Issue
2015-08-07 12:56 Timo Assigned To => kgv
2015-08-07 12:56 Timo File Added: Aal2.brep
2015-08-07 12:56 Timo File Added: not smooth edge visualization.png
2015-08-07 12:56 Timo File Added: smooth edge visualization.png
2015-08-07 12:57 Timo Relationship added related to 0026532
2015-08-07 12:57 Timo Summary Draw command vdisplay requires vclear to update the presentation => Draw command vdisplay requires vclear to update the presentation since OCC 6.9.0
2015-08-07 13:13 kgv Note Added: 0043906
2015-08-07 13:22 kgv Relationship added related to 0024394
2015-08-07 13:24 kgv Assigned To kgv => Timo
2015-08-07 13:24 kgv Status new => feedback
2015-08-07 13:25 kgv Note Edited: 0043906 View Revisions
2015-08-07 14:03 Timo Note Added: 0043912
2015-08-07 14:03 Timo Assigned To Timo => kgv
2015-08-07 14:21 Timo Status feedback => assigned
2015-08-07 14:24 Timo Note Edited: 0043912 View Revisions
2015-08-07 14:27 kgv Note Added: 0043913
2015-08-12 11:34 kgv Steps to Reproduce Updated View Revisions
2015-08-14 13:24 kgv Assigned To kgv => isk
2015-08-25 12:03 kgv Relationship added related to 0026238
2015-08-25 12:06 kgv Note Added: 0044595
2015-08-25 12:06 kgv Assigned To isk => Timo
2015-08-25 12:06 kgv Status assigned => feedback
2015-08-25 13:00 Timo Note Added: 0044600
2015-08-25 13:02 Timo Assigned To Timo => kgv
2015-08-25 13:02 Timo Status feedback => assigned
2015-08-25 14:02 kgv Note Added: 0044601
2015-08-25 14:04 kgv Note Added: 0044602
2015-08-25 14:04 kgv Assigned To kgv => isk
2015-08-25 14:04 kgv Severity minor => text
2015-08-25 14:04 kgv Relationship added related to 0025343
2015-08-28 12:22 git Note Added: 0044790
2015-09-08 14:54 Timo Note Added: 0045228
2015-09-09 11:05 git Note Added: 0045289
2015-09-09 12:29 isk Note Added: 0045299
2015-09-09 12:29 isk Assigned To isk => kgv
2015-09-09 12:29 isk Status assigned => resolved
2015-09-10 12:32 kgv Note Added: 0045397
2015-09-10 12:32 kgv Assigned To kgv => bugmaster
2015-09-10 12:32 kgv Status resolved => reviewed
2015-09-10 17:05 mkv Assigned To bugmaster => mkv
2015-09-10 19:17 git Note Added: 0045456
2015-09-11 18:31 mkv Note Added: 0045534
2015-09-11 18:31 mkv Note Added: 0045535
2015-09-11 18:31 git Note Added: 0045536
2015-09-11 18:32 mkv Note Added: 0045537
2015-09-11 18:32 mkv Assigned To mkv => isk
2015-09-11 18:32 mkv Status reviewed => assigned
2015-09-11 18:32 mkv Test case number => bugs demo bug26533
2015-09-11 19:38 kgv Note Added: 0045541
2015-09-11 19:38 kgv Assigned To isk => mkv
2015-09-11 19:38 kgv Status assigned => feedback
2015-09-11 19:39 kgv Assigned To mkv => isk
2015-09-11 19:39 kgv Status feedback => assigned
2015-09-14 11:50 Timo Note Added: 0045555
2015-09-14 13:56 kgv Note Added: 0045565
2015-09-15 09:29 git Note Added: 0045605
2015-09-15 12:10 git Note Added: 0045613
2015-09-15 12:45 Timo Note Added: 0045622
2015-09-15 12:54 kgv Note Added: 0045625
2015-09-15 13:32 Timo Note Added: 0045630
2015-09-15 13:32 Timo Relationship added related to 0026688
2015-09-15 15:30 kgv Note Added: 0045644
2015-09-15 15:30 kgv Assigned To isk => bugmaster
2015-09-15 15:30 kgv Status assigned => resolved
2015-09-15 15:30 kgv Status resolved => reviewed
2015-09-15 16:12 mkv Assigned To bugmaster => mkv
2015-09-16 15:12 mkv Note Added: 0045718
2015-09-16 15:12 mkv Assigned To mkv => bugmaster
2015-09-16 15:12 mkv Status reviewed => tested
2015-09-16 15:12 mkv Test case number bugs demo bug26533 => Not needed
2015-09-17 16:34 abv Target Version 7.0.0 => 6.9.1
2015-09-18 13:31 bugmaster Changeset attached => occt master faea8b40
2015-09-18 13:31 bugmaster Status tested => verified
2015-09-18 13:31 bugmaster Resolution open => fixed
2015-10-16 14:55 user533 Status verified => closed
2015-10-16 16:14 git Note Added: 0046882
2015-10-16 16:14 git Note Added: 0046883
2015-10-23 20:50 user533 Fixed in Version => 6.9.1


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker