MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026478Open CASCADE[OCCT] OCCT:Application Frameworkpublic2015-07-24 13:282016-04-20 15:48
Reportervro 
Assigned Tobugmaster 
PrioritynormalSeveritytext 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026478: There is a lack of documentation on OCAF / Topological naming
DescriptionTopological naming of OCAF has almost no description, it is not enough represented in the documentation and samples of Open CASCADE. A short article on topological naming illustrating a simple usage of this mechanism might be helpful.
A final version of the article is attached to this issue.
Steps To ReproduceNA
TagsNo tags attached.
Test case number
Attached Filespdf file icon TopNaming_final.pdf (140,381 bytes) 2015-07-24 13:28
docx file icon Topological Naming.docx (18,958 bytes) 2015-08-25 10:04

- Relationships

-  Notes
(0043882)
git (administrator)
2015-08-06 14:32

Branch CR26478_1 has been created by ysn.

SHA-1: c3f7b077809cd2e4e79d8b67c7c6d3afd4bc7985


Detailed log of new commits:

Author: ysn
Date: Thu Aug 6 14:31:22 2015 +0300

    Article content added in @subsection occt_ocaf_5_8 Example of topological naming usage
(0043883)
ysn (developer)
2015-08-06 14:35

Actually, topological naming is described in @section occt_ocaf_5_ OCAF Shape Attributes. I have added the article content as its last subsection.

It would be very nice if you could revise the whole section.
(0044541)
vro (developer)
2015-08-24 14:19

Everything looks fine, many thanks!
(0044566)
szy (manager)
2015-08-24 17:44

I have overlooked once again OCAF User's Guide and think that the guide should be extended by a separate chapter 'Topological Naming' (probably inside OCAF Shape Attributes we will see). Because the used rules should be explicitly declared. In opposite case it will stay 'black hole' in OCCT functionality. I plan to do it till end of the month (I hope).
Therefore - don't close the issue till my integration.
(0044584)
szy (manager)
2015-08-25 10:07

I have attached the Word document with promised chapter "Topological Naming".
It should replace the old chapter "5.2.4. Selection Mechanism".
So, make proofreading, please.
Thanks
szy
(0044729)
git (administrator)
2015-08-27 12:58

Branch CR26478_1 has been updated by ysn.

SHA-1: 5d9980ddd020f9fbf58c0c7f0364bc5d0a0b5faa


Detailed log of new commits:

Author: ysn
Date: Thu Aug 27 12:58:23 2015 +0300

    The description of topological naming mechanism has been added in sub-section 5_6.

(0044731)
ysn (developer)
2015-08-27 13:01
edited on: 2015-08-27 13:02

Provided document integrated with some rewriting aimed to facilitate the reading.
See branch CR26478_1.

(0045445)
szy (manager)
2015-09-10 17:35

Reviewed.
(0047071)
git (administrator)
2015-10-16 16:57

Branch CR26478_1 has been deleted by kgv.

SHA-1: 5d9980ddd020f9fbf58c0c7f0364bc5d0a0b5faa

- Related Changesets
occt: master a7372ed5
Timestamp: 2015-09-10 14:49:32
Author: ysn
Committer: bugmaster
Details ] Diff ]
0026478: There is a lack of documentation on OCAF / Topological naming

Article content added in @subsection occt_ocaf_5_8 Example of topological naming usage

The description of topological naming mechanism has been added in sub-section 5_6.
add - dox/user_guides/ocaf/images/ocaf_image020.png Diff ] File ]
add - dox/user_guides/ocaf/images/ocaf_image021.png Diff ] File ]
add - dox/user_guides/ocaf/images/ocaf_image022.png Diff ] File ]
mod - dox/user_guides/ocaf/ocaf.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-07-24 13:28 vro New Issue
2015-07-24 13:28 vro Assigned To => ysn
2015-07-24 13:28 vro File Added: TopNaming_final.pdf
2015-08-06 14:32 git Note Added: 0043882
2015-08-06 14:32 ysn Assigned To ysn => vro
2015-08-06 14:35 ysn Note Added: 0043883
2015-08-06 14:35 ysn Status new => resolved
2015-08-06 14:35 ysn Steps to Reproduce Updated View Revisions
2015-08-24 14:19 vro Assigned To vro => ysn
2015-08-24 14:19 vro Note Added: 0044541
2015-08-24 14:19 vro Status resolved => reviewed
2015-08-24 17:44 szy Note Added: 0044566
2015-08-24 17:44 szy Assigned To ysn => szy
2015-08-24 17:44 szy Status reviewed => assigned
2015-08-25 10:02 szy Assigned To szy => vro
2015-08-25 10:04 szy File Added: Topological Naming.docx
2015-08-25 10:04 szy Assigned To vro => ysn
2015-08-25 10:07 szy Note Added: 0044584
2015-08-27 12:58 git Note Added: 0044729
2015-08-27 13:01 ysn Note Added: 0044731
2015-08-27 13:01 ysn Assigned To ysn => szy
2015-08-27 13:01 ysn Status assigned => resolved
2015-08-27 13:02 ysn Note Edited: 0044731 View Revisions
2015-09-10 17:35 szy Note Added: 0045445
2015-09-10 17:35 szy Assigned To szy => bugmaster
2015-09-10 17:35 szy Status resolved => reviewed
2015-09-10 18:38 mkv Status reviewed => tested
2015-09-11 14:09 bugmaster Changeset attached => occt master a7372ed5
2015-09-11 14:09 bugmaster Status tested => verified
2015-09-11 14:09 bugmaster Resolution open => fixed
2015-10-16 16:57 git Note Added: 0047071
2016-04-20 15:44 aiv Fixed in Version => 7.0.0
2016-04-20 15:48 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker