MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026467Open CASCADE[OCCT] OCCT:Configurationpublic2015-07-22 10:102016-04-20 15:48
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026467: Configuration, genproj.tcl - restore generation of Code::Blocks and XCode project files
DescriptionCode::Blocks projects generator extracted from WOK is incomplete and should be fixed.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
parent of 0026559closedski Configuration, genproj.tcl - add mandatory c++11 compiler flag to generated Code::Blocks project files 
child of 0024786closedabv Move functionality of WOK command wgenproj to OCCT tool genproj 

-  Notes
(0043367)
git (administrator)
2015-07-23 18:55

Branch CR26467 has been created by kgv.

SHA-1: c045df27b54f35fa4f98f8c5ab9709dc957abc61


Detailed log of new commits:

Author: kgv
Date: Thu Jul 23 18:47:58 2015 +0300

    0026467: Configuration, genproj.tcl - restore generation of Code::Blocks and XCode project files
    
    Restore XCode generator.
    Add missing dependencies to EXTERNLIB.
    genproj.tcl - remove OS:mkdir() - duplicate of wokUtils:FILES:mkdir().
    genproj.tcl - use osutils:usedOsLibs() for Code::Blocks.
    src/OS - remove unused :LinksoWith() and :CompileWith().
    
    adm/CMPLRS - remove unused CSF_ entities.
    Remove config.h related code.
    Add executable flag to codeblocks.sh and draw.sh scripts.
    Setup ARCH variable using $tcl_platform(pointerSize).
    wokdep:SearchLib() - use $tcl_platform(os) instead of $tcl_platform(platform)
    for checking Linux-specific library paths.
    wokdep:SearchFreeType() - fix misprint in ft2build.h header file name.
    wokdep:SaveCustom() - export SHORTCUT_HEADERS to "custom.sh" as well, not only to "custom.bat".
(0043369)
git (administrator)
2015-07-23 18:59

Branch CR26467 has been updated forcibly by kgv.

SHA-1: 7704dcf18f1a3c738b8cc2cd0d79d5d333a63e17
(0043371)
kgv (developer)
2015-07-23 19:25

Please check building and integrate.
(0043589)
apn (administrator)
2015-07-27 15:29

Dear BugMaster,

Branch CR26467 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 7704dcf18f1a3c738b8cc2cd0d79d5d333a63e17

Number of compiler warnings:
occt component:
   Linux: 15 (15 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 100122638 / 99851059 [+0.27%]
Total CPU difference: 17366.669999999456 / 17369.89999999935 [-0.02%]

Testing on Windows:

Total MEMORY difference: 57594827 / 58583823 [-1.69%]
Total CPU difference: 16205.508680799028 / 16904.580361999288 [-4.14%]
(0044164)
git (administrator)
2015-08-14 10:54

Branch CR26467 has been deleted by inv.

SHA-1: 7704dcf18f1a3c738b8cc2cd0d79d5d333a63e17

- Related Changesets
occt: master c7d774c5
Timestamp: 2015-07-23 15:59:20
Author: kgv
Committer: bugmaster
Details ] Diff ]
0026467: Configuration, genproj.tcl - restore generation of Code::Blocks and XCode project files

Restore XCode generator.
Add missing dependencies to EXTERNLIB.
genproj.tcl - remove OS:mkdir() - duplicate of wokUtils:FILES:mkdir().
genproj.tcl - use osutils:usedOsLibs() for Code::Blocks.
src/OS - remove unused :LinksoWith() and :CompileWith().

adm/CMPLRS - remove unused CSF_ entities.
Remove config.h related code.
Add executable flag to codeblocks.sh and draw.sh scripts.
Setup ARCH variable using $tcl_platform(pointerSize).
wokdep:SearchLib() - use $tcl_platform(os) instead of $tcl_platform(platform)
for checking Linux-specific library paths.
wokdep:SearchFreeType() - fix misprint in ft2build.h header file name.
wokdep:SaveCustom() - export SHORTCUT_HEADERS to "custom.sh" as well, not only to "custom.bat".
mod - adm/CMPLRS Diff ] File ]
mod - adm/genconfdeps.tcl Diff ] File ]
mod - adm/genproj.tcl Diff ] File ]
mod - adm/templates/env.sh Diff ] File ]
add - adm/templates/xcode.sh Diff ] File ]
add - genproj.sh Diff ] File ]
mod - src/OS/ApplicationFramework.tcl Diff ] File ]
mod - src/OS/DataExchange.tcl Diff ] File ]
mod - src/OS/Draw.tcl Diff ] File ]
mod - src/OS/FoundationClasses.tcl Diff ] File ]
mod - src/OS/ModelingAlgorithms.tcl Diff ] File ]
mod - src/OS/ModelingData.tcl Diff ] File ]
mod - src/OS/Visualization.tcl Diff ] File ]
mod - src/TKQADraw/EXTERNLIB Diff ] File ]
mod - src/TKXDEIGES/EXTERNLIB Diff ] File ]
mod - src/TKXMesh/EXTERNLIB Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-07-22 10:10 kgv New Issue
2015-07-22 10:10 kgv Assigned To => kgv
2015-07-23 18:46 kgv Summary Configuration, genproj.tcl - fix generation of Code::Blocks files for Linux => Configuration, genproj.tcl - restore generation of Code::Blocks and XCode project files
2015-07-23 18:55 git Note Added: 0043367
2015-07-23 18:59 git Note Added: 0043369
2015-07-23 19:25 kgv Note Added: 0043371
2015-07-23 19:25 kgv Assigned To kgv => bugmaster
2015-07-23 19:25 kgv Status new => resolved
2015-07-23 19:25 kgv Status resolved => reviewed
2015-07-24 17:24 apv Assigned To bugmaster => apv
2015-07-27 11:27 apv Assigned To apv => apn
2015-07-27 14:43 kgv Relationship added child of 0024786
2015-07-27 15:29 apn Note Added: 0043589
2015-07-27 15:30 apn Test case number => Not needed
2015-07-27 15:30 apn Assigned To apn => bugmaster
2015-07-27 15:30 apn Status reviewed => tested
2015-07-31 12:31 bugmaster Changeset attached => occt master c7d774c5
2015-07-31 12:31 bugmaster Status tested => verified
2015-07-31 12:31 bugmaster Resolution open => fixed
2015-08-13 18:08 kgv Relationship added parent of 0026559
2015-08-14 10:54 git Note Added: 0044164
2016-04-20 15:44 aiv Fixed in Version => 7.0.0
2016-04-20 15:48 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker