MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026452Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2015-07-17 07:162020-09-05 12:35
Reporterpkv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0026452: Infinite loop in Edge/Edge intersection.
DescriptionEdge/Edge intersection is running endless for the two edges attached.
Steps To Reproduce#
restore qee q
explode q
copy q_1 b1
copy q_2 b2

bclearobjects; bcleartools
baddobjects b1 b2

bfillds
#
TagsNo tags attached.
Test case numberperf/modalg/bug26542
Attached Files? file icon qee (221,121 bytes) 2015-07-17 07:16

- Relationships
parent of 0026474closedbugmaster Open CASCADE Wrong computation of the resolution value 
child of 0026450closedapn Community Boolean operation is running endless 

-  Notes
(0059764)
msv (developer)
2016-11-02 12:39

The long loop is still reproduced.
(0093688)
emv (developer)
2020-08-28 13:04

Problem is not reproduced any more, test case is to be integrated.
(0093873)
git (administrator)
2020-09-02 14:28

Branch CR26452 has been created by emv.

SHA-1: 2ac5bffd66e5d8ee4e3bf2dd95db9d5dedcf340a


Detailed log of new commits:

Author: emv
Date: Wed Sep 2 14:29:50 2020 +0300

    0026452: Infinite loop in Edge/Edge intersection.
    
    Integrating test case only as the problem is not reproduced anymore.
(0093973)
emv (developer)
2020-09-03 13:29

Dear Mikhail, please review CR26452.
http://occt-tests/CR26452-master-emv-OCCT/ [^]
(0093977)
msv (developer)
2020-09-03 13:34

+tcopy e_1 e1
+tcopy e_2 e2

Why is it needed to check operation on copies?
(0093978)
emv (developer)
2020-09-03 14:03

The edges in compound have common vertex. tcopy allows breaking sharing.
(0093981)
msv (developer)
2020-09-03 14:20

For integration:
occt - CR26452
(0094062)
bugmaster (administrator)
2020-09-05 12:09

Combination -
OCCT branch : IR-2020-09-04
master SHA - a516227511f3452f9f55b79c961265b0bf210793
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-09-04 SHA - 134448d280fb82bfb14ffc6255ac1cb53f7fd1cf
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17319.18000000012 / 17284.370000000214 [+0.20%]
Products
Total CPU difference: 12059.670000000087 / 12007.590000000067 [+0.43%]
Windows-64-VC14:
OCCT
Total CPU difference: 18776.390625 / 18770.796875 [+0.03%]
Products
Total CPU difference: 13251.640625 / 13222.90625 [+0.22%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0094083)
git (administrator)
2020-09-05 12:35

Branch CR26452 has been deleted by inv.

SHA-1: 2ac5bffd66e5d8ee4e3bf2dd95db9d5dedcf340a

- Related Changesets
occt: master b3df3dcd
Timestamp: 2020-09-02 11:29:50
Author: emv
Committer: bugmaster
Details ] Diff ]
0026452: Infinite loop in Edge/Edge intersection.

Integrating test case only as the problem is not reproduced anymore.
add - tests/perf/modalg/bug26542 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-07-17 07:16 pkv New Issue
2015-07-17 07:16 pkv Assigned To => emv
2015-07-17 07:16 pkv File Added: qee
2015-07-17 07:16 pkv Relationship added child of 0026450
2015-07-17 07:17 pkv Status new => assigned
2015-07-23 14:41 emv Relationship added parent of 0026474
2016-10-26 09:18 emv Target Version 7.1.0 => 7.2.0
2016-11-02 12:39 msv Note Added: 0059764
2017-07-24 09:22 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0
2019-08-12 16:44 msv Target Version 7.4.0 => 7.5.0
2020-08-28 13:04 emv Note Added: 0093688
2020-09-02 14:28 git Note Added: 0093873
2020-09-03 13:29 emv Note Added: 0093973
2020-09-03 13:29 emv Assigned To emv => msv
2020-09-03 13:29 emv Status assigned => resolved
2020-09-03 13:34 msv Note Added: 0093977
2020-09-03 14:03 emv Note Added: 0093978
2020-09-03 14:20 msv Note Added: 0093981
2020-09-03 14:20 msv Assigned To msv => bugmaster
2020-09-03 14:20 msv Status resolved => reviewed
2020-09-05 12:09 bugmaster Status reviewed => tested
2020-09-05 12:09 bugmaster Note Added: 0094062
2020-09-05 12:21 bugmaster Test case number => perf/modalg/bug26542
2020-09-05 12:25 bugmaster Changeset attached => occt master b3df3dcd
2020-09-05 12:25 bugmaster Status tested => verified
2020-09-05 12:25 bugmaster Resolution open => fixed
2020-09-05 12:35 git Note Added: 0094083


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker