MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026450Community[OCCT] OCCT:Modeling Algorithmspublic2015-07-16 15:172016-12-09 16:39
ReporterTimo 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0026450: Boolean operation is running endless
DescriptionFor the appended shapes the bop command is running endless or extremely long.
The shapes are considered valid by checkshape, bopcheck and bopargcheck.
Steps To Reproducerestore a.brep a
restore b.brep b
bop a b
TagsNo tags attached.
Test case numberbugs modalg_6 bug26450
Attached Files? file icon a.brep (85,940 bytes) 2015-07-16 15:17
? file icon b.brep (603,080 bytes) 2015-07-16 15:17

- Relationships
parent of 0026452assignedemv Open CASCADE Infinite loop in Edge/Edge intersection. 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0043133)
msv (developer)
2015-07-16 15:29

Dear Peter, please analyze the reason of long run.
(0059390)
msv (developer)
2016-10-28 18:54

This test case finishes in about 6 seconds on my machine in the current version of master.
(0059752)
Timo (developer)
2016-11-02 11:44
edited on: 2016-11-02 11:48

Yes, the endless run doesn't occur anymore since OCCT 7.0.0. I've just tested it. So, the issue could be closed.

What is with the child case 0026452?

(0059766)
msv (developer)
2016-11-02 12:44

The bug 26452 is still reproduced. The edges that are objects of BO in that bug are section edges extracted from the operation in the time of bug creation. The actual for the moment version of BO produces more simple bspline curves for the same section edges, and therefore the overall operation runs faster.
So, this bug can be closed, while the child bug 26452 requires additional investigation for the subject of possible improvement of speed of edge-edge intersection.
(0059767)
msv (developer)
2016-11-02 12:45

Dear bugmaster, please create test case limiting CPU time by 1 min for this operation. Then close this bug.
(0059772)
msv (developer)
2016-11-02 12:55

1 min is not enough for debug build. Please use CPU limit 5 min for this test.
(0060745)
git (administrator)
2016-11-23 18:07

Branch CR26450 has been created by apn.

SHA-1: 34518ec40b48c3cf6d404321425ff8a5708e9569


Detailed log of new commits:

Author: apn
Date: Wed Nov 23 18:07:21 2016 +0300

    0026450: Boolean operation is running endless
    
    Added test case bugs/modalg_6/bug26450
(0061235)
git (administrator)
2016-12-07 11:30

Branch CR26450 has been deleted by kgv.

SHA-1: 34518ec40b48c3cf6d404321425ff8a5708e9569

- Related Changesets
occt: master 10f55672
Timestamp: 2016-11-23 15:07:21
Author: apn
Details ] Diff ]
0026450: Boolean operation is running endless

Added test case bugs/modalg_6/bug26450
add - tests/bugs/modalg_6/bug26450 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-07-16 15:17 Timo New Issue
2015-07-16 15:17 Timo Assigned To => msv
2015-07-16 15:17 Timo File Added: a.brep
2015-07-16 15:17 Timo File Added: b.brep
2015-07-16 15:29 msv Note Added: 0043133
2015-07-16 15:29 msv Assigned To msv => pkv
2015-07-16 15:29 msv Status new => assigned
2015-07-16 15:29 msv Target Version 7.0.0 => 7.1.0
2015-07-17 07:16 pkv Relationship added parent of 0026452
2016-10-28 18:54 msv Note Added: 0059390
2016-10-28 18:54 msv Assigned To pkv => Timo
2016-10-28 18:54 msv Status assigned => feedback
2016-10-28 18:54 msv Target Version 7.1.0 => Unscheduled
2016-11-02 11:44 Timo Note Added: 0059752
2016-11-02 11:44 Timo Assigned To Timo => msv
2016-11-02 11:48 Timo Note Edited: 0059752 View Revisions
2016-11-02 12:05 abv Target Version Unscheduled => 7.1.0
2016-11-02 12:44 msv Note Added: 0059766
2016-11-02 12:45 msv Note Added: 0059767
2016-11-02 12:45 msv Assigned To msv => bugmaster
2016-11-02 12:45 msv Resolution open => unable to reproduce
2016-11-02 12:55 msv Note Added: 0059772
2016-11-23 18:07 git Note Added: 0060745
2016-11-23 18:10 apn Test case number => bugs modalg_6 bug26450
2016-11-23 18:10 apn Status feedback => tested
2016-11-24 15:52 apn Changeset attached => occt master 10f55672
2016-11-24 15:52 apn Assigned To bugmaster => apn
2016-11-24 15:52 apn Status tested => verified
2016-11-24 15:52 apn Resolution unable to reproduce => fixed
2016-12-07 11:30 git Note Added: 0061235
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker