MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026334Community[OCCT] OCCT:Modeling Algorithmspublic2015-06-11 03:112016-04-20 15:50
ReporterHayashi 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026334: BRepOffsetAPI_MakePipeShell returns the wrong shape
DescriptionWhen a wire of attachment is used, the wrong shape is returned.
6.8.0 and 6.7.1 crashes.
Steps To ReproduceBRep_Builder builder;
TopoDS_Wire w1, w2, w3;
BRepTools::Read(w1,"pw1.brep",builder);
BRepTools::Read(w2,"pw2.brep",builder);
BRepTools::Read(w3,"pw3.brep",builder);
BRepOffsetAPI_MakePipeShell make(w1);
make.Add(w2);
make.Add(w3);
make.Build();
make.Shape();
TagsNo tags attached.
Test case numberbugs modalg_6 bug26334
Attached Fileszip file icon wires.zip (7,190 bytes) 2015-06-11 03:11
png file icon result.png (51,478 bytes) 2015-06-11 03:12
png file icon curv.PNG (50,841 bytes) 2015-06-26 11:20
png file icon sweep.PNG (88,153 bytes) 2015-06-26 11:20

- Relationships

-  Notes
(0042477)
ifv (developer)
2015-06-26 11:08

Some curves of w1 has very strong torsion (rotation of Frenet trihedron around tangent direction)and Corrected Frenet algorithm used by default for sweeping cannot compensate this.
For such sase it is better using Discrete trihedron algorithm, which can be set by method make.SetDiscreteMode()
(0042478)
ifv (developer)
2015-06-26 11:23

file curv.png is curvature plot of w1 to illustrate torsion.
file sweep.png is result using Discrete trihedron algorithm by commands:
Draw[6]> mksweep pw1
Draw[7]> addsweep pw2
Draw[8]> addsweep pw3
Draw[9]> setsweep -DT
Draw[10]> buildsweep sw
(0042489)
Hayashi (reporter)
2015-06-26 12:56

Thank you for your investigation.
I confirmed that the shape that it's expected using SetDiscreteMode() returns by 6.7.1 and 6.9.0.
Please close.
(0042671)
bugmaster (administrator)
2015-07-02 13:43

Andrey,

Please create testing case
(0048970)
git (administrator)
2015-12-10 15:53

Branch CR26334 has been created by mkv.

SHA-1: a6bda85813149fcb4395b22f04c6f78858c4ad27


Detailed log of new commits:

Author: mkv
Date: Thu Dec 10 15:53:28 2015 +0300

    0026334: BRepOffsetAPI_MakePipeShell returns the wrong shape
(0048971)
mkv (tester)
2015-12-10 15:55

Dear ifv,
could you please review following test case
bugs modalg_6 bug26334

It is OK:
http://occt-tests/CR26949-master-occt-64/Debian70-64/bugs/modalg_6/bug26334.html [^]
http://occt-tests/CR26949-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug26334.html [^]
bugs modalg_6 bug26334: OK
(0048973)
ifv (developer)
2015-12-10 16:09

Testseems to be OK
(0048995)
mkv (tester)
2015-12-10 17:19

Dear BugMaster,
Branch CR26334 is TESTED.
(0053022)
git (administrator)
2016-04-17 14:00

Branch CR26334 has been deleted by kgv.

SHA-1: a6bda85813149fcb4395b22f04c6f78858c4ad27

- Related Changesets
occt: master 3da62e0e
Timestamp: 2015-12-10 12:53:28
Author: mkv
Committer: bugmaster
Details ] Diff ]
0026334: BRepOffsetAPI_MakePipeShell returns the wrong shape
add - tests/bugs/modalg_6/bug26334 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-06-11 03:11 Hayashi New Issue
2015-06-11 03:11 Hayashi Assigned To => msv
2015-06-11 03:11 Hayashi File Added: wires.zip
2015-06-11 03:12 Hayashi File Added: result.png
2015-06-11 09:17 msv Assigned To msv => ifv
2015-06-11 09:17 msv Target Version => 7.1.0
2015-06-26 10:57 ifv Status new => assigned
2015-06-26 11:08 ifv Note Added: 0042477
2015-06-26 11:08 ifv Assigned To ifv => msv
2015-06-26 11:08 ifv Status assigned => resolved
2015-06-26 11:20 ifv File Added: curv.PNG
2015-06-26 11:20 ifv File Added: sweep.PNG
2015-06-26 11:23 ifv Note Added: 0042478
2015-06-26 12:56 Hayashi Note Added: 0042489
2015-06-26 15:43 msv Assigned To msv => bugmaster
2015-06-26 15:43 msv Status resolved => reviewed
2015-06-26 17:50 mkv Test case number => Not needed
2015-06-26 17:50 mkv Status reviewed => tested
2015-07-02 13:43 bugmaster Note Added: 0042671
2015-07-02 13:43 bugmaster Assigned To bugmaster => apn
2015-07-02 13:43 bugmaster Status tested => feedback
2015-12-08 10:32 bugmaster Assigned To apn => mkv
2015-12-10 15:53 git Note Added: 0048970
2015-12-10 15:55 mkv Note Added: 0048971
2015-12-10 15:56 mkv Test case number Not needed => bugs modalg_6 bug26334
2015-12-10 15:56 mkv Assigned To mkv => ifv
2015-12-10 16:09 ifv Note Added: 0048973
2015-12-10 16:09 ifv Assigned To ifv => bugmaster
2015-12-10 16:09 ifv Status feedback => reviewed
2015-12-10 17:19 mkv Note Added: 0048995
2015-12-10 17:19 mkv Status reviewed => tested
2015-12-18 15:25 bugmaster Changeset attached => occt master 3da62e0e
2015-12-18 15:25 bugmaster Status tested => verified
2015-12-18 15:25 bugmaster Resolution open => fixed
2015-12-21 12:53 bugmaster Target Version 7.1.0 => 7.0.0
2016-04-17 14:00 git Note Added: 0053022
2016-04-20 15:42 user533 Fixed in Version => 7.0.0
2016-04-20 15:50 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker