MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026327Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2015-06-09 19:132016-04-20 15:50
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026327: Performance degradation from version 6.8.0 on Boolean operations
DescriptionThe problem has been identified during analysis of the post on OCCT Forum:
http://www.opencascade.org/org/forum/thread_27182/?forum=3 [^]

The following results have been obtained on Intel i7-3450, Windows 7, 64-bit:

    OCCT 6.7.0 (32-bit vc9): 22 sec
    OCCT 6.7.1 (32-bit vc10): 22 sec
    OCCT 6.7.3 (64-bit vc12): 8.3 sec
    OCCT 6.8.0 (32-bit vc10): 10.3 sec
    OCCT 6.9.0 (64-bit vc10): 20.8 sec
    master (64-bit vc10): 18.6 sec

Degradation from OCC6.8.0 (10.3 sec) to OCCT6.9.0 (20.8) is more than 2 times.
Steps To Reproducepload ALL
stepread FUSE_INPUT.stp a *
chrono s reset; chrono s start; for {set i 2} {$i < 22} {incr i} {puts "a_$i"; bfuse a_1 a_1 a_$i}; chrono s stop; chrono s show
TagsNo tags attached.
Test case numberbugs modalg_6 bug26327
Attached Files? file icon FUSE_INPUT.stp (1,498,686 bytes) 2015-06-09 19:13

- Relationships

-  Notes
(0042072)
msv (developer)
2015-06-10 10:10

Nilolay, please analyze and find the cause.
(0042078)
msv (developer)
2015-06-10 12:55
edited on: 2015-06-10 12:59

Thanks to Nikolay, the cause of performance degradation was found. This problem already was raised in the bug #26193. Please, see the comment of Nikolay ~41593, point 3.

Briefly, in the process of fixing the bug #25597 it was decided to compute the tolerance of new edges more precisely. As a result, the algorithm of BOP takes more time to obtain a more reliable result.

(0042081)
bugmaster (administrator)
2015-06-10 13:16

Dear MSV,

And what's next after switching status to reviewed.
Should we create testing case and close this issue?
(0042089)
msv (developer)
2015-06-10 16:29

Please just close it, as it is not a bug.
(0042090)
abv (manager)
2015-06-10 16:38

No, please create a test case, and keep the issue opened -- performance is one of parameters we need to keep non-regressive
(0042093)
msv (developer)
2015-06-10 17:33

Sometimes we need to give performance as sacrifice to win quality.
(0046168)
abv (manager)
2015-09-25 19:45

The performance of OCCT 6.9.1 on this case is on the level of OCCT 6.8.0 (note that version 6.7.3 never existed), and current master is even better:

OCCT 6.8.0: 10.7 sec
OCCT 6.9.0: 21 sec
OCCT 6.9.1: 10.9 sec
master: 8.7 sec

(i5-3450 3.1 GHz, 64-bit vc10)

Thus I believe the problem is solved, and suggest to add a test case (in group perf bop) and close the issue
(0048966)
git (administrator)
2015-12-10 15:46

Branch CR26327 has been created by mkv.

SHA-1: d3b411238400e277d3634cc5158ffd2bb6372bd6


Detailed log of new commits:

Author: mkv
Date: Thu Dec 10 15:46:29 2015 +0300

    Test case for issue CR26327
(0048967)
mkv (tester)
2015-12-10 15:48

Dear msv,
could you please review following test case
bugs modalg_6 bug26327

It is OK:
http://occt-tests/CR26949-master-occt-64/Debian70-64/bugs/modalg_6/bug26327.html [^]
http://occt-tests/CR26949-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug26327.html [^]
bugs modalg_6 bug26327: OK
(0048978)
msv (developer)
2015-12-10 16:23

OK
(0048992)
mkv (tester)
2015-12-10 17:17

Dear BugMaster,
Branch CR26327 is TESTED.
(0053021)
git (administrator)
2016-04-17 14:00

Branch CR26327 has been deleted by kgv.

SHA-1: d3b411238400e277d3634cc5158ffd2bb6372bd6

- Related Changesets
occt: master 6b13d528
Timestamp: 2015-12-10 12:46:29
Author: mkv
Committer: bugmaster
Details ] Diff ]
0026327: Performance degradation from version 6.8.0 on Boolean operations
Test case for issue CR26327
add - tests/bugs/modalg_6/bug26327 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-06-09 19:13 szy New Issue
2015-06-09 19:13 szy Assigned To => msv
2015-06-09 19:13 szy File Added: FUSE_INPUT.stp
2015-06-09 19:23 abv Description Updated View Revisions
2015-06-09 20:45 abv Relationship added related to 0026329
2015-06-09 20:45 abv Relationship deleted related to 0026329
2015-06-10 10:10 msv Note Added: 0042072
2015-06-10 10:10 msv Assigned To msv => nbv
2015-06-10 10:10 msv Status new => assigned
2015-06-10 12:55 msv Note Added: 0042078
2015-06-10 12:56 msv Status assigned => resolved
2015-06-10 12:56 msv Resolution open => no change required
2015-06-10 12:56 msv Assigned To nbv => bugmaster
2015-06-10 12:56 msv Status resolved => reviewed
2015-06-10 12:57 msv Note Edited: 0042078 View Revisions
2015-06-10 12:58 msv Note Edited: 0042078 View Revisions
2015-06-10 12:59 msv Note Edited: 0042078 View Revisions
2015-06-10 12:59 msv Note Edited: 0042078 View Revisions
2015-06-10 13:00 msv Relationship added related to 0026193
2015-06-10 13:01 msv Relationship added child of 0025597
2015-06-10 13:16 bugmaster Note Added: 0042081
2015-06-10 16:29 msv Note Added: 0042089
2015-06-10 16:38 abv Note Added: 0042090
2015-06-10 17:33 msv Note Added: 0042093
2015-08-26 11:47 abv Status reviewed => feedback
2015-09-25 00:19 abv Assigned To bugmaster => abv
2015-09-25 00:19 abv Target Version 7.0.0 => 7.1.0
2015-09-25 19:45 abv Note Added: 0046168
2015-09-25 19:45 abv Assigned To abv => bugmaster
2015-09-25 19:45 abv Target Version 7.1.0 => 7.0.0
2015-10-01 10:14 bugmaster Assigned To bugmaster => apn
2015-12-08 10:32 bugmaster Assigned To apn => mkv
2015-12-10 15:46 git Note Added: 0048966
2015-12-10 15:48 mkv Note Added: 0048967
2015-12-10 15:49 mkv Assigned To mkv => msv
2015-12-10 15:49 mkv Test case number => bugs modalg_6 bug26327
2015-12-10 16:23 msv Note Added: 0048978
2015-12-10 16:23 msv Assigned To msv => bugmaster
2015-12-10 16:23 msv Status feedback => reviewed
2015-12-10 17:17 mkv Note Added: 0048992
2015-12-10 17:17 mkv Status reviewed => tested
2015-12-18 15:25 bugmaster Changeset attached => occt master 6b13d528
2015-12-18 15:25 bugmaster Status tested => verified
2015-12-18 15:25 bugmaster Resolution no change required => fixed
2016-04-17 14:00 git Note Added: 0053021
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker