MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026254Open CASCADE[OCCT] OCCT:Foundation Classespublic2015-05-22 10:552016-04-20 15:51
Reporterazv 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026254: Inject GeomAbs_OffsetCurve into GeomAbs_CurveType enumeration
DescriptionIt is proposed to implement additional enumeration value for offset curve in the GeomAbs_CurveType enumeration as it was made for offset surfaces.
Steps To ReproduceNot applicable
Additional information
and documentation updates
The change will help to simplify using of offset curves especially in adaptors (GeomAdaptor_Curve and Geom2dAdaptor_Curve) according to changes made as part of 0024682
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024682closedbugmaster Move out B-spline cache from curves and surfaces to dedicated classes BSplCLib_Cache and BSplSLib_Cache 

-  Notes
(0046538)
git (administrator)
2015-10-07 09:13

Branch CR26254 has been created by azv.

SHA-1: aa1eba3b4b1b431aeea28dd17497cfee40554f90


Detailed log of new commits:

Author: azv
Date: Wed Oct 7 09:13:19 2015 +0300

    0026254: Inject GeomAbs_OffsetCurve into GeomAbs_CurveType enumeration
(0046539)
azv (developer)
2015-10-07 09:14

Dear Mikhail,

Please, review branch CR26254.
(0046754)
msv (developer)
2015-10-14 19:05

reviewed.
(0046756)
git (administrator)
2015-10-14 19:40

Branch CR26254 has been updated forcibly by apv.

SHA-1: 141da539777398e9a5c1ae125e8b5e4736d3e578
(0046757)
apv (tester)
2015-10-14 19:41

Branch CR26254 has been rebased on the current master
(0046779)
apv (tester)
2015-10-15 11:57
edited on: 2015-10-15 15:21

Dear BugMaster,

Branch CR26254 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 141da539777398e9a5c1ae125e8b5e4736d3e578

Number of compiler warnings:
occt component:
   Linux: 14 (13 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)
There is new additional warning on Linux:
HLRBRep_Curve.cxx:77, GNU C Compiler 4 (gcc), Priority: Normal
enumeration value 'GeomAbs_OffsetCurve' not handled in switch [-Wswitch]

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92799704 / 92519431 [+0.30%]
Total CPU difference: 19423.339999999793 / 19402.790000000048 [+0.11%]

Testing on Windows:
Total MEMORY difference: 58144018 / 58146190 [-0.00%]
Total CPU difference: 18273.067934298844 / 18359.36768749885 [-0.47%]

(0046780)
apv (tester)
2015-10-15 11:58

Dear azv,

Branch CR26254 has been rejected due to:
- additional warnings
(0046794)
git (administrator)
2015-10-15 15:26

Branch CR26254 has been updated forcibly by azv.

SHA-1: 53d782b88cc7c07d86ab6c566c1eaebe77bcb969
(0046795)
azv (developer)
2015-10-15 15:28

Dear Alexey,

The warning has been eliminated. Please, rebuild branch CR26254.
(0047026)
git (administrator)
2015-10-16 16:40

Branch CR26254 has been updated forcibly by apv.

SHA-1: f6df80c6738be40da1fe2e405935ab04965be638
(0047027)
apv (tester)
2015-10-16 16:40

Branch CR26254 has been rebased on the current master
(0047213)
apv (tester)
2015-10-20 13:04
edited on: 2015-10-20 13:37

Dear BugMaster,

Branch CR26254 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: f6df80c6738be40da1fe2e405935ab04965be638

Number of compiler warnings:
occt component:
   Linux: 2 (8 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92038967 / 92270356 [-0.25%]
Total CPU difference: 19527.40999999991 / 19657.70999999973 [-0.66%]

Testing on Windows:
Total MEMORY difference: 58027827 / 58040579 [-0.02%]
Total CPU difference: 18078.347486098977 / 17972.422807098967 [+0.59%]

(0053218)
git (administrator)
2016-04-17 14:42

Branch CR26254 has been deleted by kgv.

SHA-1: f6df80c6738be40da1fe2e405935ab04965be638

- Related Changesets
occt: master 1aec3320
Timestamp: 2015-10-07 06:13:19
Author: azv
Committer: bugmaster
Details ] Diff ]
0026254: Inject GeomAbs_OffsetCurve into GeomAbs_CurveType enumeration
mod - src/BOPTools/BOPTools_AlgoTools_2.cxx Diff ] File ]
mod - src/BRepAlgo/BRepAlgo.cxx Diff ] File ]
mod - src/BRepFill/BRepFill_TrimSurfaceTool.cxx Diff ] File ]
mod - src/BRepMAT2d/BRepMAT2d_Explorer.cxx Diff ] File ]
mod - src/DBRep/DBRep_DrawableShape.cxx Diff ] File ]
mod - src/DrawTrSurf/DrawTrSurf_Drawable.cxx Diff ] File ]
mod - src/Extrema/Extrema_ExtCC2d.cxx Diff ] File ]
mod - src/Extrema/Extrema_FuncExtCC.gxx Diff ] File ]
mod - src/Extrema/Extrema_FuncExtPC.gxx Diff ] File ]
mod - src/Extrema/Extrema_GExtPC.gxx Diff ] File ]
mod - src/Extrema/Extrema_GLocateExtPC.gxx Diff ] File ]
mod - src/Geom2dAdaptor/Geom2dAdaptor.cxx Diff ] File ]
mod - src/Geom2dAdaptor/Geom2dAdaptor_Curve.cxx Diff ] File ]
mod - src/GeomAbs/GeomAbs_CurveType.hxx Diff ] File ]
mod - src/GeomAdaptor/GeomAdaptor.cxx Diff ] File ]
mod - src/GeomAdaptor/GeomAdaptor_Curve.cxx Diff ] File ]
mod - src/GeomAPI/GeomAPI.cxx Diff ] File ]
mod - src/HLRBRep/HLRBRep_Curve.cxx Diff ] File ]
mod - src/IntCurve/IntCurve_IntCurveCurveGen.gxx Diff ] File ]
mod - src/IntCurve/IntCurve_UserIntConicCurveGen.gxx Diff ] File ]
mod - src/IntTools/IntTools.cxx Diff ] File ]
mod - src/IntTools/IntTools_BeanFaceIntersector.cxx Diff ] File ]
mod - src/IntTools/IntTools_EdgeEdge.cxx Diff ] File ]
mod - src/ProjLib/ProjLib_ComputeApprox.cxx Diff ] File ]
mod - src/ProjLib/ProjLib_ProjectedCurve.cxx Diff ] File ]
mod - src/ShapeConstruct/ShapeConstruct_ProjectCurveOnSurface.cxx Diff ] File ]
mod - src/TestTopOpeDraw/TestTopOpeDraw_TTOT.cxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_Griddump.cxx Diff ] File ]
mod - src/TopOpeBRepTool/TopOpeBRepTool_CurveTool.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-05-22 10:55 azv New Issue
2015-05-22 10:55 azv Assigned To => abv
2015-05-22 10:55 azv Relationship added related to 0024682
2015-09-25 01:01 abv Assigned To abv => azv
2015-09-25 01:01 abv Status new => assigned
2015-10-07 09:13 git Note Added: 0046538
2015-10-07 09:14 azv Note Added: 0046539
2015-10-07 09:14 azv Assigned To azv => msv
2015-10-07 09:14 azv Status assigned => resolved
2015-10-07 09:14 azv Steps to Reproduce Updated View Revisions
2015-10-14 19:05 msv Note Added: 0046754
2015-10-14 19:05 msv Assigned To msv => bugmaster
2015-10-14 19:05 msv Status resolved => reviewed
2015-10-14 19:23 apv Assigned To bugmaster => apv
2015-10-14 19:40 git Note Added: 0046756
2015-10-14 19:41 apv Note Added: 0046757
2015-10-15 11:20 apv Test case number => Not needed
2015-10-15 11:57 apv Note Added: 0046779
2015-10-15 11:57 apv Assigned To apv => azv
2015-10-15 11:57 apv Status reviewed => assigned
2015-10-15 11:58 apv Note Added: 0046780
2015-10-15 15:21 apv Note Edited: 0046779 View Revisions
2015-10-15 15:26 git Note Added: 0046794
2015-10-15 15:27 azv Status assigned => resolved
2015-10-15 15:28 azv Note Added: 0046795
2015-10-15 15:28 azv Assigned To azv => apv
2015-10-15 15:28 azv Status resolved => reviewed
2015-10-16 16:40 git Note Added: 0047026
2015-10-16 16:40 apv Note Added: 0047027
2015-10-20 13:04 apv Note Added: 0047213
2015-10-20 13:04 apv Assigned To apv => bugmaster
2015-10-20 13:04 apv Status reviewed => tested
2015-10-20 13:37 apv Note Edited: 0047213 View Revisions
2015-10-23 12:30 bugmaster Changeset attached => occt master 1aec3320
2015-10-23 12:30 bugmaster Status tested => verified
2015-10-23 12:30 bugmaster Resolution open => fixed
2016-04-17 14:42 git Note Added: 0053218
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:51 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker