MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026232Community[OCCT] OCCT:Modeling Datapublic2015-05-19 00:372015-10-23 20:51
ReporterAaron Michalk 
Assigned Tobugmaster 
PrioritynormalSeveritycrash 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 6.9.1Fixed in Version[OCCT] 6.9.1 
Summary0026232: Multithreaded crash in IntAna_Int3Pln::Perform due to statics
DescriptionIntermittently a crash occurs in IntAna_Int3Pln::Perform when called simultaneously by multiple threads. Crash is due to initialization of local statics inside the function.
Steps To ReproduceN/A
Additional information
and documentation updates
Statics local to a function are not thread safe.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0041260)
Aaron Michalk (reporter)
2015-05-19 00:38

Statics were introduced in 6.8.0.
(0041261)
git (administrator)
2015-05-19 07:11

Branch CR26232 has been created by abv.

SHA-1: 3d632a6e008be4c9ce59a6fd37163d6ddad8e4a6


Detailed log of new commits:

Author: abv
Date: Tue May 19 07:10:35 2015 +0300

    0026232: Multithreaded crash in IntAna_Int3Pln::Perform due to statics
    
    "Static" keyword removed from local variable declarations in IntAna_Int3Pln::Perform()
(0041262)
abv (manager)
2015-05-19 07:14

Fix pushed to CR26232, please review.

Note that this statement:

> Statics were introduced in 6.8.0.

is false: they were present since at least beginning of OCCT Git history (6.5.0)
(0041264)
msv (developer)
2015-05-19 10:52

Reviewed.
(0041270)
git (administrator)
2015-05-19 12:21

Branch CR26232 has been updated forcibly by mkv.

SHA-1: 96e5214d92191d0da1c9cf4d6332db61567907f4
(0041312)
mkv (tester)
2015-05-20 14:30

Dear BugMaster,
Branch CR26232 was rebased on current master of occt git-repository.
SHA-1: 96e5214d92191d0da1c9cf4d6332db61567907f4
(0041313)
mkv (tester)
2015-05-20 14:30

Dear BugMaster,
Branch CR26232 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 96e5214d92191d0da1c9cf4d6332db61567907f4

Number of compiler warnings:

occt component :
Linux: 25
Windows: 0 (0 on master)

products component :
Linux: 37
Windows: 0 (0 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 99781591 / 100379567 [-0.60%]
Total CPU difference: 19002.0800000001 / 19460.760000000177 [-2.36%]
products component :
Total MEMORY difference: 24182906 / 24391409 [-0.85%]
Total CPU difference: 7877.820000000015 / 7582.950000000026 [+3.89%]

Testing on Windows:
occt component :
Total MEMORY difference: 59014740 / 59221168 [-0.35%]
Total CPU difference: 17156.24117519893 / 16976.543623298945 [+1.06%]
products component :
Total MEMORY difference: 15655131 / 15659790 [-0.03%]
Total CPU difference: 6639.730162100001 / 6569.170909799987 [+1.07%]

There are no differences in images found by testdiff.
(0044273)
git (administrator)
2015-08-14 11:01

Branch CR26232 has been deleted by inv.

SHA-1: 96e5214d92191d0da1c9cf4d6332db61567907f4

- Related Changesets
occt: master 7e59624d
Timestamp: 2015-05-19 04:10:35
Author: abv
Committer: bugmaster
Details ] Diff ]
0026232: Multithreaded crash in IntAna_Int3Pln::Perform due to statics

"Static" keyword removed from local variable declarations in IntAna_Int3Pln::Perform()
mod - src/IntAna/IntAna_Int3Pln.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-05-19 00:37 Aaron Michalk New Issue
2015-05-19 00:37 Aaron Michalk Assigned To => msv
2015-05-19 00:38 Aaron Michalk Note Added: 0041260
2015-05-19 07:11 git Note Added: 0041261
2015-05-19 07:14 abv Note Added: 0041262
2015-05-19 07:14 abv Status new => resolved
2015-05-19 07:14 abv Target Version => 7.0.0
2015-05-19 07:14 abv Steps to Reproduce Updated View Revisions
2015-05-19 10:52 msv Note Added: 0041264
2015-05-19 10:52 msv Assigned To msv => bugmaster
2015-05-19 10:52 msv Status resolved => reviewed
2015-05-19 12:18 mkv Assigned To bugmaster => mkv
2015-05-19 12:21 git Note Added: 0041270
2015-05-20 14:30 mkv Note Added: 0041312
2015-05-20 14:30 mkv Note Added: 0041313
2015-05-20 14:30 mkv Assigned To mkv => bugmaster
2015-05-20 14:30 mkv Status reviewed => tested
2015-05-20 14:30 mkv Test case number => Not needed
2015-05-22 12:19 bugmaster Changeset attached => occt master 7e59624d
2015-05-22 12:19 bugmaster Status tested => verified
2015-05-22 12:19 bugmaster Resolution open => fixed
2015-08-14 11:01 git Note Added: 0044273
2015-08-26 11:11 abv Target Version 7.0.0 => 6.9.1
2015-10-16 14:56 user533 Status verified => closed
2015-10-23 20:51 user533 Fixed in Version => 6.9.1


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker