MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026207Open CASCADE[OCCT] OCCT:Visualizationpublic2015-05-11 09:092016-04-20 15:49
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026207: VIS - compiler warnings on 64-bit build
DescriptionThe following warnings are reported by VC10 in 64-bit mode:

40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(80): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(82): warning C4267: 'initializing' : conversion from 'size_t' to 'const vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(97): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(97): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(99): warning C4267: 'initializing' : conversion from 'size_t' to 'const vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(122): warning C4267: 'argument' : conversion from 'size_t' to 'const vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(126): warning C4267: 'initializing' : conversion from 'size_t' to 'const vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(144): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(144): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(144): warning C4267: 'initializing' : conversion from 'size_t' to 'vtkIdType', possible loss of data
40>..\..\..\src\IVtkVTK\IVtkVTK_ShapeData.cxx(146): warning C4267: 'initializing' : conversion from 'size_t' to 'const vtkIdType', possible loss of data

The problem is that

typedef Standard_Size IVtk_IdType;

in IVtk_Types.hxx does not correspond to corresponding VTK type defined in vtkType.h:

typedef int vtkIdType;

It looks like we should have VTK built with 64-bit mode Ids if we use 64-bit Ids on OCCT side (I am using VTK 6.1.0 binaries downloaded from http://www.opencascade.org/getocc/download/3rdparty/ [^]).

In VTK, this is manipulated by macro VTK_USE_64BIT_IDS, however I did not understood how it should be configured properly.
Steps To ReproduceBuild OCCT for VC10 64-bit mode with 32-bit VTK package - compiler error message should appear: "32-bit VTK library can not be linked for 64-bit target platform"
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0026668closedbugmaster Eliminate compile warnings obtained by building occt with vc14: conversion requires a narrowing conversion 

-  Notes
(0040817)
bugmaster (administrator)
2015-05-12 12:11

The problem is reproduced if include defined to 32 bit package of VTK.
(0046115)
abv (manager)
2015-09-25 01:05

Roman, please check if this issue is actually relevant, also in relation with 0026668
(0046384)
rkv (developer)
2015-10-01 17:28

Please consider CR26668 for this fix.
(0047931)
abv (manager)
2015-11-08 22:14

Dear bugmaster, the issue should have been fixed by 0026668; please check and if confirmed, switch it to verified

- Issue History
Date Modified Username Field Change
2015-05-11 09:09 abv New Issue
2015-05-11 09:09 abv Assigned To => kgv
2015-05-12 12:11 bugmaster Note Added: 0040817
2015-09-25 01:04 abv Relationship added related to 0026668
2015-09-25 01:05 abv Note Added: 0046115
2015-09-25 01:05 abv Assigned To kgv => rkv
2015-09-25 01:05 abv Status new => assigned
2015-10-01 17:28 rkv Assigned To rkv => kgv
2015-10-01 17:28 rkv Status assigned => resolved
2015-10-01 17:28 rkv Steps to Reproduce Updated View Revisions
2015-10-01 17:28 rkv Note Added: 0046384
2015-11-08 22:14 abv Note Added: 0047931
2015-11-08 22:14 abv Assigned To kgv => bugmaster
2015-11-08 22:14 abv Status resolved => feedback
2015-11-10 10:47 bugmaster Status feedback => tested
2015-11-10 10:47 bugmaster Status tested => verified
2015-11-10 10:47 bugmaster Resolution open => fixed
2016-04-20 15:44 aiv Fixed in Version => 7.0.0
2016-04-20 15:49 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker