View Issue Details

IDProjectCategoryView StatusLast Update
0026174Open CASCADEOCCT:Data Exchangepublic2021-12-19 11:17
ReporterinkAssigned Tossafarov  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version6.8.0 
Target Version7.7.0 
Summary0026174: Data Exchange, IGES - Loss of color after the second write of file
DescriptionIf write the document twice, in the second file will be missing color.
This bug is reproduced, if the document will be the first time writen with the param write.iges.brep.mode Faces (default)
Steps To Reproduce
pload MODELING XDE OCAF VISUALIZATION
box b 0 0 0 10 10 10
compound  b c

NewDoc D
XAddShape D c 1
XSetColor D 0:1:1:1:1 1 0 0

WriteIges D d:/t1.igs
newmodel
WriteIges D d:/t2.igs

ReadIges D1 d:/t1.igs
ReadIges D2 d:/t2.igs

vinit View1
vclear
XDisplay D1 -dispMode 1
vfit

vclear
XDisplay D2 -dispMode 1
vfit
TagsNo tags attached.
Test case numberbugs iges bug26174

Relationships

related to 0029435 verifiedatychini Community Data Exchange - Exporting wires consisting of more than one edge results in loss of color data in IGES 

Activities

apv

2017-08-10 15:02

tester   ~0069279

Problem described in issue is reproduced on current state of OCCT.

ssafarov

2021-10-29 17:02

developer   ~0104967

Analysis and Solution Elaboration

ssafarov

2021-11-12 15:22

developer   ~0105155

Solution Elaboration: Found the reason and one of the possible solutions to the issue.

dpasukhi

2021-11-14 22:41

developer   ~0105184

Analysis

git

2021-11-15 18:22

administrator   ~0105200

Branch CR26174 has been created by ssafarov.

SHA-1: 1b848524400d9409ae55c44e0ea0246344b99f8a


Detailed log of new commits:

Author: ssafarov
Date: Mon Nov 15 18:15:33 2021 +0300

    0026174: Data Exchange, IGES - Loss of color after the second write of file
    
    Fixed export problem with reversed faces

dpasukhi

2021-11-19 16:45

developer   ~0105274

Analysis [15.11]

Support with finding a problem with Iges transfer process (input document is changed via import process)
Support with develop a solution to fix incorrect Iges entities binding and updating an input shapes

ssafarov

2021-11-19 18:04

developer   ~0105275

Analysis and Solution Elaboration: Search for a possible solution.

ika

2021-11-26 13:24

developer   ~0105448

Analysis

ssafarov

2021-11-26 15:11

developer   ~0105450

Analysis and Solution Elaboration

git

2021-11-29 17:48

administrator   ~0105520

Branch CR26174 has been updated by ssafarov.

SHA-1: 80f0a4a484fe636e5a7f7086dc5078709093643b


Detailed log of new commits:

Author: ssafarov
Date: Mon Nov 29 17:05:49 2021 +0300

    0026174: Data Exchange, IGES - Loss of color after the second write of file
    
    Transferring Edge transformations from TransferFace() method to TransferEdge()

git

2021-11-30 11:09

administrator   ~0105531

Branch CR26174 has been updated by ssafarov.

SHA-1: 060ec68f150931a8abb103a228cfb2747efeaa8e


Detailed log of new commits:

Author: ssafarov
Date: Tue Nov 30 11:06:32 2021 +0300

    0026174: Data Exchange, IGES - Loss of color after the second write of file
    
    Fixed variable names and added one more test check

git

2021-11-30 12:29

administrator   ~0105535

Branch CR26174_1 has been created by ssafarov.

SHA-1: 4379df6bc1f9bbd43a5f8078bb4ee556c8f49e11


Detailed log of new commits:

Author: ssafarov
Date: Mon Nov 15 18:15:33 2021 +0300

    0026174: Data Exchange, IGES - Loss of color after the second write of file
    
    Removed unnecessary code
    Fixed variable names and added one more test check
    Moved Edge's Curve transformations from TransferFace() method to TransferEdge()
    Fixed export problem with reversed faces

git

2021-12-03 14:45

administrator   ~0105632

Branch CR26174_2 has been created by ssafarov.

SHA-1: c8f28b2d7695e9250a343b212f98b10bc9e74179


Detailed log of new commits:

Author: ssafarov
Date: Mon Nov 15 18:15:33 2021 +0300

    0026174: Data Exchange, IGES - Loss of color after the second write of file
    
    A copy of myface is made, where further on the copy the geometry changes. We connect the face, wire, edge of the original shape with the one whose geometry was changed. This is done in order to get the original shape in the TransferWire() and TransferEdge() methods.

ssafarov

2021-12-03 20:05

developer   ~0105637

Solution Elaboration

git

2021-12-07 12:14

administrator   ~0105716

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: bd170518a86463342337155385c23d0b57b8c70f

git

2021-12-07 14:52

administrator   ~0105723

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: fe2ff6b279173722745a5a54464e7e075090491f

git

2021-12-08 11:09

administrator   ~0105740

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 4cfcb0165ab7822058f1a09cb604e33af9778d42

git

2021-12-08 19:19

administrator   ~0105751

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: cd604d96a4a4fc00c12c0d9a80519aa3aac3231d

git

2021-12-08 21:39

administrator   ~0105758

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: d59e2dcab2f6950f15333a18e017ec5cc7445f51

ssafarov

2021-12-09 10:55

developer   ~0105764

dpasukhi please review CR26174_2

Issue: The original shape is overwritten and linked to the transformed (Iges entity), so when we want to assign a color to the Iges entity in the MakeColors() method, we cannot do this, because we are trying to get the Iges entity from the original shape (before we overwrote it)

Solution: A copy of myface is made in the TransferFace() method, where further on the copy the geometry changes. We connect the face, wire, edge of the original shape with the one whose geometry was changed. This is done in order to get the original shape in the TransferWire() and TransferEdge() methods and connect the original shape to the Iges entity

Link compare:
http://occt-tests/CR26174-master-ssafarov-OCCT/Debian80-64/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-OCCT/Windows-64-VC14/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-Products/Debian80-64/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-Products/Windows-64-VC14/diff_summary.html

git

2021-12-09 13:52

administrator   ~0105767

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 4183ce9e5f01f0078bcaaac95af7ff317d595e0e

git

2021-12-09 16:30

administrator   ~0105772

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 3f72e47e6561a29ed6af404ec248b09a3d1446e4

git

2021-12-09 17:06

administrator   ~0105773

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 4bc2bd8e1bdb74db48ff610ff281126a7f034864

dpasukhi

2021-12-09 17:43

developer   ~0105774

Last edited: 2021-12-12 23:52

No remarks.

Dear bugmaster,
please integrate branch CR26174_2

All tests are OK. Retested:
http://jenkins-test-08.nnov.opencascade.com/view/CR26174-master-ssafarov/view/TESTING/job/CR26174-master-ssafarov-OCCT-Debian80-64-opt-test-restart/3/
http://jenkins-test-08.nnov.opencascade.com/view/CR26174-master-ssafarov/view/TESTING/job/CR26174-master-ssafarov-OCCT-Windows-64-VC14-opt-test-restart/3/

dpasukhi

2021-12-09 23:18

developer   ~0105777

There are some problem:

The written file has not correct parameterization of 2d curves (for example lines) for the reverted face

git

2021-12-10 19:04

administrator   ~0105794

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 287e8dd7515e025ba5a06f8d957e675c75081616

ssafarov

2021-12-10 21:32

developer   ~0105798

Solution Elaboration

git

2021-12-13 09:36

administrator   ~0105836

Branch CR26174_2 has been updated forcibly by ssafarov.

SHA-1: 6ba81a695f5e233b1da71e5242b1f32bf1debae0

ssafarov

2021-12-13 12:17

developer   ~0105843

dpasukhi please review CR26174_2

Link compare:
http://occt-tests/CR26174-master-ssafarov-Products/Windows-64-VC14/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-Products/Debian80-64/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-OCCT/Windows-64-VC14/diff_summary.html
http://occt-tests/CR26174-master-ssafarov-OCCT/Debian80-64/diff_summary.html

dpasukhi

2021-12-14 00:43

developer   ~0105964

No remarks.

Dear bugmaster,
please integrate branch CR26174_2

The solution does not distort the result iges file. All entities in the file are equal to the master. The issue's bug is fixed, the input document's shapes are not changed now.

smoskvin

2021-12-18 15:23

administrator   ~0106058

Combination -
OCCT branch : IR-2021-12-17
master SHA - 302ad26bffd1ef35a61b8b25b79b9376d9a3e906
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2021-12-17 SHA - 98edda224f5e3516cba5be029bc70c3df45ca649
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18206.60000000041 / 18222.99000000043 [-0.09%]
Products
Total CPU difference: 11646.460000000101 / 11645.100000000084 [+0.01%]
Windows-64-VC14:
OCCT
Total CPU difference: 20012.890625 / 20000.0 [+0.06%]
Products
Total CPU difference: 13093.890625 / 13044.453125 [+0.38%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2021-12-19 11:17

administrator   ~0106077

Branch CR26174 has been deleted by mnt.

SHA-1: 060ec68f150931a8abb103a228cfb2747efeaa8e

git

2021-12-19 11:17

administrator   ~0106078

Branch CR26174_1 has been deleted by mnt.

SHA-1: 4379df6bc1f9bbd43a5f8078bb4ee556c8f49e11

git

2021-12-19 11:17

administrator   ~0106079

Branch CR26174_2 has been deleted by mnt.

SHA-1: 6ba81a695f5e233b1da71e5242b1f32bf1debae0

Related Changesets

occt: master 6ba81a69

2021-11-15 18:15:33

ssafarov

Details Diff
0026174: Data Exchange, IGES - Loss of color after the second write of file

A copy of myface is made, where further on the copy the geometry changes. We connect the face, wire, edge of the original shape with the one whose geometry was changed. This is done in order to get the original shape in the TransferWire() and TransferEdge() methods.
Affected Issues
0026174
mod - src/BRepToIGES/BRepToIGES_BREntity.cxx Diff File
mod - src/BRepToIGES/BRepToIGES_BRShell.cxx Diff File
mod - src/BRepToIGES/BRepToIGES_BRSolid.cxx Diff File
mod - src/BRepToIGES/BRepToIGES_BRWire.cxx Diff File
mod - src/BRepToIGES/BRepToIGES_BRWire.hxx Diff File
mod - src/BRepToIGESBRep/BRepToIGESBRep_Entity.cxx Diff File
add - tests/bugs/iges/bug26174 Diff File
rm - tests/bugs/xde/bug26174 Diff File

Issue History

Date Modified Username Field Change
2015-04-30 15:09 ink New Issue
2015-04-30 15:09 ink Assigned To => gka
2015-05-06 06:49 abv Target Version 6.9.0 => 7.1.0
2016-10-26 12:07 gka Target Version 7.1.0 => 7.2.0
2017-07-27 09:33 abv Target Version 7.2.0 => 7.4.0
2017-08-10 15:02 apv Test case number => bugs xde bug26174
2017-08-10 15:02 apv Note Added: 0069279
2019-09-04 12:58 abv Target Version 7.4.0 => 7.5.0
2020-09-17 19:57 gka Target Version 7.5.0 => 7.6.0
2021-10-07 12:35 szy Target Version 7.6.0 => 7.7.0
2021-10-27 13:05 dpasukhi Assigned To gka => ssafarov
2021-10-27 20:28 kgv Summary Loss of color after the second write of file (iges). => Data Exchange, IGES - Loss of color after the second write of file
2021-10-27 20:28 kgv Steps to Reproduce Updated
2021-10-27 20:28 kgv Product Version => 6.8.0
2021-10-29 17:02 ssafarov Note Added: 0104967
2021-11-12 15:22 ssafarov Note Added: 0105155
2021-11-14 22:41 dpasukhi Note Added: 0105184
2021-11-15 18:22 git Note Added: 0105200
2021-11-15 18:58 kgv Steps to Reproduce Updated
2021-11-19 16:45 dpasukhi Note Added: 0105274
2021-11-19 18:04 ssafarov Note Added: 0105275
2021-11-26 13:24 ika Note Added: 0105448
2021-11-26 15:11 ssafarov Note Added: 0105450
2021-11-29 17:48 git Note Added: 0105520
2021-11-30 11:09 git Note Added: 0105531
2021-11-30 12:29 git Note Added: 0105535
2021-12-03 14:45 git Note Added: 0105632
2021-12-03 20:05 ssafarov Note Added: 0105637
2021-12-06 17:10 dpasukhi Relationship added related to 0029435
2021-12-07 12:14 git Note Added: 0105716
2021-12-07 14:52 git Note Added: 0105723
2021-12-08 11:09 git Note Added: 0105740
2021-12-08 19:19 git Note Added: 0105751
2021-12-08 21:39 git Note Added: 0105758
2021-12-09 10:55 ssafarov Note Added: 0105764
2021-12-09 10:55 ssafarov Assigned To ssafarov => dpasukhi
2021-12-09 10:55 ssafarov Status new => resolved
2021-12-09 13:52 git Note Added: 0105767
2021-12-09 16:30 git Note Added: 0105772
2021-12-09 17:06 git Note Added: 0105773
2021-12-09 17:43 dpasukhi Note Added: 0105774
2021-12-09 17:43 dpasukhi Assigned To dpasukhi => bugmaster
2021-12-09 17:43 dpasukhi Status resolved => reviewed
2021-12-09 23:14 dpasukhi Assigned To bugmaster => ssafarov
2021-12-09 23:14 dpasukhi Status reviewed => assigned
2021-12-09 23:18 dpasukhi Note Added: 0105777
2021-12-10 19:04 git Note Added: 0105794
2021-12-10 21:32 ssafarov Note Added: 0105798
2021-12-12 23:52 dpasukhi Note Edited: 0105774
2021-12-13 09:36 git Note Added: 0105836
2021-12-13 12:17 ssafarov Note Added: 0105843
2021-12-13 12:17 ssafarov Assigned To ssafarov => dpasukhi
2021-12-13 12:17 ssafarov Status assigned => resolved
2021-12-14 00:43 dpasukhi Note Added: 0105964
2021-12-14 00:43 dpasukhi Assigned To dpasukhi => bugmaster
2021-12-14 00:43 dpasukhi Status resolved => reviewed
2021-12-14 00:47 dpasukhi Test case number bugs xde bug26174 => bugs iges bug26174
2021-12-18 15:23 smoskvin Status reviewed => tested
2021-12-18 15:23 smoskvin Note Added: 0106058
2021-12-18 20:24 ssafarov Changeset attached => occt master 6ba81a69
2021-12-18 20:24 ssafarov Assigned To bugmaster => ssafarov
2021-12-18 20:24 ssafarov Status tested => verified
2021-12-18 20:24 ssafarov Resolution open => fixed
2021-12-19 11:17 git Note Added: 0106077
2021-12-19 11:17 git Note Added: 0106078
2021-12-19 11:17 git Note Added: 0106079