MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026047Open CASCADE[OCCT] OCCT:Data Exchangepublic2015-04-10 12:172017-08-15 14:41
Reporterado 
Assigned Togka 
PrioritynormalSeveritymajor 
StatusassignedResolutionopen 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0026047: Lost colors for IGES export
DescriptionThe problem extracted from the 25688.
It's reproduced on android and win64
Steps To Reproduce1. Open pencil.igs from Samples
2. Set Faces in the Options - Export IGES options
4. Save it as IGES
3. Open saved file
=> colors of conical and cylindrical parts are lost (compare pencil_initial.jpg and pencil_exportIGES-Faces.jpg)
TagsNo tags attached.
Test case number
Attached Filesjpg file icon pencil_initial.jpg (51,872 bytes) 2015-04-10 12:17
jpg file icon pencil_exportIGES-Faces.jpg (50,681 bytes) 2015-04-10 12:18

- Relationships
child of 0026168assignedgka Lost colors for IGES import 

-  Notes
(0040197)
git (administrator)
2015-04-24 11:06

Branch CR26047 has been created by ink.

SHA-1: 232bd4bb65d13d2872f0203d474f2e72cf22f9de


Detailed log of new commits:

Author: ink
Date: Fri Apr 24 11:04:32 2015 +0300

    0026047: Lost colors for IGES export
(0041567)
gka (developer)
2015-05-26 15:11

Branch CR26047 is ready to test
(0044966)
git (administrator)
2015-09-02 15:21

Branch CR26047 has been updated forcibly by mkv.

SHA-1: 6a2e8db6f7ed29b0da296cc30184b03e2296cf6d
(0045004)
mkv (tester)
2015-09-03 14:41

Dear BugMaster,
Branch CR26047 was rebased on current master of occt git-repository.
SHA-1: 6a2e8db6f7ed29b0da296cc30184b03e2296cf6d
(0045005)
mkv (tester)
2015-09-03 14:41

Dear BugMaster,
Branch CR26047 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 6a2e8db6f7ed29b0da296cc30184b03e2296cf6d

Number of compiler warnings:

occt component :
Linux: 15 (15 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
http://occt-tests/CR26047-master-products-64/Debian70-64/summary.html [^]
http://occt-tests/CR26047-master-products-64/Windows-64-VC10/summary.html [^]
sat doc_1 E9
sat doc_4 E7
sat doc_6 D3, H5

Testing cases:


Testing on Linux:
occt component :
Total MEMORY difference: 92039529 / 91192751 [+0.93%]
Total CPU difference: 17622.739999998987 / 17162.109999999382 [+2.68%]
products component :
Total MEMORY difference: 25141649 / 25144817 [-0.01%]
Total CPU difference: 7069.739999999988 / 7020.5499999999965 [+0.70%]

Testing on Windows:
occt component :
Total MEMORY difference: 57097354 / 57089920 [+0.01%]
Total CPU difference: 16345.098375598987 / 16439.931383498915 [-0.58%]
products component :
Total MEMORY difference: 16167781 / 16167831 [-0.00%]
Total CPU difference: 5356.341135299979 / 5316.560880299963 [+0.75%]

There are no differences in images found by testdiff.
(0045006)
mkv (tester)
2015-09-03 14:42

Dear ink,
could you please write tcl-script for reproduce this bug.
(0047282)
git (administrator)
2015-10-21 15:15

Branch CR26047_1 has been created by kgv.

SHA-1: f4f3314674a63995ba84037df43aca9115317354


Detailed log of new commits:

Author: kgv
Date: Wed Oct 21 15:15:36 2015 +0300

    Add test case bugs/xde/bug26047

Author: ink
Date: Fri Apr 24 11:04:32 2015 +0300

    0026047: Lost colors for IGES export
(0047283)
kgv (developer)
2015-10-21 15:16

Test case has been added to the patch in branch CR26047_1.
(0047284)
kgv (developer)
2015-10-21 15:17

Dear gka,

could you please review test case and confirm tests reported as regression due to deviation from reference data?
(0047308)
git (administrator)
2015-10-22 09:15

Branch CR26047 has been deleted by kgv.

SHA-1: 6a2e8db6f7ed29b0da296cc30184b03e2296cf6d
(0069380)
git (administrator)
2017-08-15 12:30

Branch CR26047_2 has been created by abv.

SHA-1: 820980cccf4ca87161456f35d881a60a885635cc


Detailed log of new commits:

Author: ink
Date: Fri Apr 24 11:04:32 2015 +0300

    0026047: Lost colors for IGES export
    
    Method XSAlgo_AlgoContainer::MergeTransferInfo() is corrected to keep locations of sub-shapes when recording transfer results in the map.
    
    Add test case bugs/xde/bug26047
(0069393)
abv (manager)
2017-08-15 14:40

The fix leads to loss of some colors in ACIS tests:
sat doc_1 E9
sat doc_4 E7
sat doc_6 D3 H5

- Issue History
Date Modified Username Field Change
2015-04-10 12:17 ado New Issue
2015-04-10 12:17 ado Assigned To => abv
2015-04-10 12:17 ado File Added: pencil_initial.jpg
2015-04-10 12:18 ado File Added: pencil_exportIGES-Faces.jpg
2015-04-15 19:35 abv Assigned To abv => ink
2015-04-15 19:35 abv Status new => assigned
2015-04-24 11:06 git Note Added: 0040197
2015-04-24 11:39 ink Assigned To ink => oan
2015-04-24 11:39 ink Status assigned => resolved
2015-04-27 14:48 oan Assigned To oan => gka
2015-04-30 12:13 ink Relationship added child of 0026168
2015-05-26 15:11 gka Note Added: 0041567
2015-05-26 15:11 gka Assigned To gka => bugmaster
2015-05-26 15:11 gka Status resolved => reviewed
2015-09-02 12:12 user533 Project Internal => CAD Assistant
2015-09-02 12:12 user533 Category PRODUCTS:CAD Assistant => OCCT:Application Framework
2015-09-02 13:32 user533 Project CAD Assistant => Open CASCADE
2015-09-02 13:40 kgv Category OCCT:Application Framework => OCCT:Data Exchange
2015-09-02 13:40 kgv Product Version => 6.9.0
2015-09-02 13:40 kgv Target Version => 7.0.0
2015-09-02 14:48 mkv Assigned To bugmaster => mkv
2015-09-02 15:03 kgv OS => L
2015-09-02 15:03 kgv OS Version => L
2015-09-02 15:03 kgv Platform Android, win64 => A
2015-09-02 15:21 git Note Added: 0044966
2015-09-03 14:41 mkv Note Added: 0045004
2015-09-03 14:41 mkv Note Added: 0045005
2015-09-03 14:41 mkv Assigned To mkv => ink
2015-09-03 14:41 mkv Status reviewed => assigned
2015-09-03 14:42 mkv Note Added: 0045006
2015-09-08 15:40 ink Note Added: 0045236
2015-09-08 15:41 ink Note Deleted: 0045236
2015-10-21 15:15 git Note Added: 0047282
2015-10-21 15:16 kgv Note Added: 0047283
2015-10-21 15:17 kgv Note Added: 0047284
2015-10-21 15:17 kgv Assigned To ink => gka
2015-10-21 15:17 kgv Status assigned => feedback
2015-10-22 09:15 git Note Added: 0047308
2015-11-23 10:25 gka Assigned To gka => ink
2015-11-23 10:25 gka Status feedback => assigned
2015-12-18 14:39 abv Assigned To ink => gka
2015-12-30 14:12 ink Status assigned => resolved
2016-02-08 18:07 abv Target Version 7.0.0 => 7.1.0
2016-10-26 11:42 gka Target Version 7.1.0 => 7.2.0
2017-08-15 12:30 git Note Added: 0069380
2017-08-15 14:40 abv Note Added: 0069393
2017-08-15 14:41 abv Target Version 7.2.0 => 7.4.0*
2017-08-15 14:41 abv Status resolved => assigned


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker