MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026034Community[OCCT] OCCT:Modeling Algorithmspublic2015-04-09 11:322019-01-21 14:37
Reportershoogen 
Assigned Tomsv 
PrioritynormalSeverityminor 
StatusassignedResolutionreopened 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version[OCCT] 6.8.0 
Target VersionFixed in Version 
Summary0026034: Result of revolution aborts the bopcheck if translated
DescriptionThe original shape is valid. After translation it raises a Standard_NumericError in the BOPCheck.

Might be related to 0024691.
Steps To Reproducetest bugs modalg_7 bug26034 1

pload MODELING
restore revolve-seg1-tcl-Revolve002.brep Revolve002
puts [bopcheck Revolve002]
ttranslate Revolve002 0 0 -0.5
puts [bopcheck Revolve002]
TagsBOPAlgo_OperationAborted
Test case numberbugs modalg_7 bug26034
Attached Files? file icon revolve1-draw-Revolve.brep (76,038 bytes) 2015-04-09 11:32
? file icon revolve-seg1-tcl-Revolve002.brep (3,621 bytes) 2015-04-09 11:33

- Relationships
related to 0029181assignedapn Open CASCADE Jenkins Certification Tool - testing with enabled exceptions (undefined No_Exception) 

-  Notes
(0039472)
shoogen (reporter)
2015-04-09 11:34

The shape revolve1-draw-Revolve.brep was uploaded accidentally and is not related to this issue.
(0069217)
apv (tester)
2017-08-08 16:47

Dear BugMaster,

Problem described in issue is not reproduced on current state of OCCT.
Problem is not reproduced on OCCT6.8.0.
(0080785)
kgv (developer)
2018-11-06 17:53

The problem is still here in OCCT.

Of course, since Standard_NumericError checks are disabled in RELEASE builds, the problem should be checked within DEBUG build or with No_Exception undefined.
(0081844)
kgv (developer)
2019-01-21 14:37

See failing test case bugs/modalg_7/bug26034

- Issue History
Date Modified Username Field Change
2015-04-09 11:32 shoogen New Issue
2015-04-09 11:32 shoogen Assigned To => msv
2015-04-09 11:32 shoogen File Added: revolve1-draw-Revolve.brep
2015-04-09 11:33 shoogen File Added: revolve-seg1-tcl-Revolve002.brep
2015-04-09 11:34 shoogen Note Added: 0039472
2015-04-09 11:34 shoogen Tag Attached: BOPAlgo_OperationAborted
2017-08-08 16:46 apv Assigned To msv => apv
2017-08-08 16:46 apv Status new => feedback
2017-08-08 16:47 apv Test case number => bugs modalg_7 bug26034
2017-08-08 16:47 apv Note Added: 0069217
2017-08-08 16:47 apv Status feedback => closed
2017-08-08 16:47 apv Resolution open => no change required
2017-08-08 16:47 apv Fixed in Version => 6.8.0
2018-11-06 17:53 kgv Assigned To apv => msv
2018-11-06 17:53 kgv Note Added: 0080785
2018-11-06 17:53 kgv Status closed => feedback
2018-11-06 17:53 kgv Resolution no change required => reopened
2018-11-06 17:53 kgv Relationship added related to 0029181
2018-11-06 17:54 kgv Status feedback => assigned
2018-11-06 17:54 kgv Fixed in Version 6.8.0 =>
2019-01-21 14:36 kgv Steps to Reproduce Updated View Revisions
2019-01-21 14:37 kgv Note Added: 0081844


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker