MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025941Community[OCCT] OCCT:Modeling Algorithmspublic2015-03-15 09:532015-05-14 15:30
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0025941: Wrong boolean common result of Edge/Face between HalfSpace.
DescriptionCommon result of Edge/Face between HalfSpace are wrong.
 code snippet:
         gp_Pln aPlane(aSplitPlane);
         BRepBuilderAPI_MakeFace aMakeFace(aPlane);
         const TopoDS_Face& aFade = aMakeFace.Face();
         BRepPrimAPI_MakeHalfSpace aMakeHalfSpace(aFade, aFencePoint);
         const TopoDS_Solid& aSolid = aMakeHalfSpace.Solid();
         TopoDS_Shape aFaceOrEdgeShape = ...;
         BRepAlgoAPI_Common aMakeCut(aFaceOrEdgeShape, aSolid);
Steps To ReproduceNot needed.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
duplicate of 0025937closedbugmaster Failed Cut Edge or Face by HalfSpace. 

-  Notes
(0038377)
Vico Liang (developer)
2015-03-16 05:26

This issue is similar to 0025937 and both of them have relation with halfspace.
(0040342)
pkv (developer)
2015-04-28 13:20

The issue is resolved by the fix done for the issue:
http://tracker.dev.opencascade.org/view.php?id=25937 [^]
(0040352)
msv (developer)
2015-04-28 15:10

Can be closed along with 0025937.

- Issue History
Date Modified Username Field Change
2015-03-15 09:53 Vico Liang New Issue
2015-03-15 09:53 Vico Liang Assigned To => msv
2015-03-16 05:24 Vico Liang Relationship added related to 0025937
2015-03-16 05:26 Vico Liang Note Added: 0038377
2015-03-17 13:55 abv Target Version 6.8.0 => 6.9.0
2015-03-17 15:05 msv Assigned To msv => pkv
2015-03-17 15:05 msv Status new => assigned
2015-04-17 00:02 abv Target Version 6.9.0 => 7.1.0
2015-04-28 13:04 msv Target Version 7.1.0 => 6.9.0
2015-04-28 13:20 pkv Note Added: 0040342
2015-04-28 13:20 pkv Assigned To pkv => msv
2015-04-28 15:09 msv Status assigned => resolved
2015-04-28 15:09 msv Steps to Reproduce Updated View Revisions
2015-04-28 15:10 msv Note Added: 0040352
2015-04-28 15:10 msv Assigned To msv => bugmaster
2015-04-28 15:10 msv Status resolved => reviewed
2015-04-28 15:10 msv Relationship deleted related to 0025937
2015-04-28 15:10 msv Relationship added duplicate of 0025937
2015-04-28 16:27 mkv Status reviewed => tested
2015-04-30 13:53 bugmaster Status tested => verified
2015-04-30 13:53 bugmaster Resolution open => fixed
2015-04-30 13:54 bugmaster Status verified => feedback
2015-04-30 13:54 bugmaster Resolution fixed => reopened
2015-04-30 13:54 bugmaster Status feedback => tested
2015-05-05 16:48 apv Test case number => Not needed
2015-05-07 12:04 bugmaster Status tested => verified
2015-05-07 12:04 bugmaster Resolution reopened => fixed
2015-05-14 15:28 user533 Status verified => closed
2015-05-14 15:30 user533 Fixed in Version => 6.9.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker