MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025906Open CASCADE[OCCT] OCCT:Visualizationpublic2015-03-06 18:512015-05-14 15:31
Reporteribs 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.3.1 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0025906: Visualization, V3d_View::Rotation() - eliminate erroneous viewer redraw within disabled immediate update
DescriptionRotation method of V3d_View class has the superfluous view update due to incorrect condition
Steps To Reproducenot required
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0038203)
git (administrator)
2015-03-06 18:54

Branch CR25906 has been created by ibs.

SHA-1: 951ecc422d5189b67db76325770aa0e363bc680e


Detailed log of new commits:

Author: ibs
Date: Fri Mar 6 18:52:30 2015 +0300

    0025906: The condition of immediate update is incorrect in the method of the view rotation
    
    incorrect condition fixed
(0038205)
ibs (developer)
2015-03-06 18:54

dear kgv, please review CR25906 branch in OCCT git
(0038219)
git (administrator)
2015-03-10 10:37

Branch CR25906 has been updated by ibs.

SHA-1: b22197324c7294da5fa76f161ff3e1805a414813


Detailed log of new commits:

Author: ibs
Date: Tue Mar 10 10:35:43 2015 +0300

    redundant update removed (Rotate method already does update)

(0038221)
git (administrator)
2015-03-10 11:36

Branch CR25906 has been updated forcibly by ibs.

SHA-1: 97c8b3aef705db25b2f10eb0f23d5c0dd7c8a041
(0038222)
kgv (developer)
2015-03-10 12:00

Please test the patch.
(0038291)
apv (tester)
2015-03-12 12:37

Dear BugMaster,

Branch CR25906 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 97c8b3aef705db25b2f10eb0f23d5c0dd7c8a041

Number of compiler warnings:
occt component:
   Linux: 18 (18 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 11 (11 on master)
   Windows: 4 (4 on master)

Regressions/Differences:
http://occt-tests/CR25906-master-occt-64/Windows-64-VC10/summary.html [^]
bugs modalg_1(006) bug19793_2
bugs mesh(016) bug25464
Both test-cases are unstable.

Testing on Linux:
Total MEMORY difference: 91671784 / 92036000
Total CPU difference: 57574.29000000006 / 58057.23999999997

Testing on Windows:
Total MEMORY difference: 57952346 / 57952469
Total CPU difference: 56798.984375 / 31110.625
(0038628)
git (administrator)
2015-03-18 13:39

Branch CR25906 has been deleted by inv.

SHA-1: 97c8b3aef705db25b2f10eb0f23d5c0dd7c8a041

- Related Changesets
occt: master b12a3e54
Timestamp: 2015-03-06 15:52:30
Author: ibs
Committer: bugmaster
Details ] Diff ]
0025906: Visualization, V3d_View::Rotation() - eliminate erroneous viewer redraw within disabled immediate update

the superfluous view update of Rotation method removed because of used before Rotate method already does immediate update
mod - src/V3d/V3d_View.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-03-06 18:51 ibs New Issue
2015-03-06 18:51 ibs Assigned To => ibs
2015-03-06 18:54 git Note Added: 0038203
2015-03-06 18:54 ibs Note Added: 0038205
2015-03-06 18:54 ibs Assigned To ibs => kgv
2015-03-06 18:54 ibs Status new => resolved
2015-03-06 18:54 ibs Steps to Reproduce Updated View Revisions
2015-03-06 21:41 kgv Summary The condition of immediate update is incorrect in the method of the view rotation => Visualization, V3d_View::Rotation() - eliminate erroneous viewer redraw within disabled immediate update
2015-03-10 10:37 git Note Added: 0038219
2015-03-10 11:36 git Note Added: 0038221
2015-03-10 12:00 kgv Note Added: 0038222
2015-03-10 12:00 kgv Assigned To kgv => bugmaster
2015-03-10 12:00 kgv Status resolved => reviewed
2015-03-10 12:01 kgv Product Version 6.8.0 => 6.3.1
2015-03-10 18:25 apv Assigned To bugmaster => apv
2015-03-12 12:37 apv Note Added: 0038291
2015-03-12 12:37 apv Assigned To apv => bugmaster
2015-03-12 12:37 apv Status reviewed => tested
2015-03-12 12:37 apv Test case number => Not needed
2015-03-13 16:52 bugmaster Changeset attached => occt master b12a3e54
2015-03-13 16:52 bugmaster Status tested => verified
2015-03-13 16:52 bugmaster Resolution open => fixed
2015-03-18 13:39 git Note Added: 0038628
2015-05-14 15:28 aiv Status verified => closed
2015-05-14 15:31 aiv Fixed in Version => 6.9.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker