View Issue Details

IDProjectCategoryView StatusLast Update
0025884Open CASCADEOCCT:Visualizationpublic2016-10-25 20:30
Reportersan Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionduplicate 
Summary0025884: Visualization - Override environment texture by object-level texture
DescriptionCurrently, environment mapping is enabled/disabled globally using V3d_View::SetSurfaceDetail() method. However, sometimes it is necessary to override for some object the scene-level environment texture with a texture defined at this object level, and apply it using manually supplied texture coordinates (rather then auto-generated ones).

This could be done e.g. in V3d_TEX_ALL mode which unfortunately suppresses the environment texture now. Instead, environment texture could be used for scene objects having no individual texture, the object-level texture being used if specified.

A more advanced solution would be to combine environment and object textures using the value of EnvReflexion property of Graphic3d_MaterialAspect, however this functionality is less critical.
TagsNo tags attached.
Test case numberNot needed

Relationships

duplicate of 0026434 closedbugmaster Visualization - Textured objects should have priority over the environment mapping 
related to 0025783 closedbugmaster Visualization - allow Z-layer to draw 2D objects and to make it alternative to Overlay and Underlay 

Activities

kgv

2016-10-13 12:48

developer   ~0058654

Dear bugmaster,

please close the issue as duplicate of 0026434.

Issue History

Date Modified Username Field Change
2015-03-02 23:50 san New Issue
2015-03-02 23:50 san Assigned To => kgv
2015-03-03 00:06 san Relationship added related to 0025783
2015-03-05 19:12 san Assigned To kgv => dbp
2015-03-05 19:12 san Status new => assigned
2015-04-27 19:24 kgv Target Version 6.9.0 => 7.1.0
2016-10-13 12:46 kgv Relationship added related to 0026434
2016-10-13 12:48 kgv Relationship replaced duplicate of 0026434
2016-10-13 12:48 kgv Note Added: 0058654
2016-10-13 12:48 kgv Assigned To dbp => bugmaster
2016-10-13 12:48 kgv Status assigned => feedback
2016-10-13 12:48 kgv Resolution open => duplicate
2016-10-25 20:30 apn Test case number => Not needed
2016-10-25 20:30 apn Status feedback => closed
2016-10-25 20:30 apn Target Version 7.1.0 =>