MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025853Community[OCCT] OCCT:Visualizationpublic2015-02-23 16:562015-05-14 15:31
Reporterspamkiller 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0025853: Edges disappear or reappear when displaying new edges
DescriptionEdges disappear or reappear when displaying a large number of new edges. Reproduced with Draw Test Harness and the script below.

For screenshots and details:
http://www.opencascade.org/org/forum/thread_26797/?forum=3 [^]

Also testes with the Draw Test Harness tool of the binary download version of OpenCASCADE6.8.0 (opencascade-6.8.0.exe from http://www.opencascade.org/getocc/download/loadocc/ [^])
Steps To Reproduce# Display a large number of lines

#Category: Visualization BUG "invisible lines"
#Title: Display a large number of lines

pload ALL

vinit View1 w=1024 h=1024
vsetdispmode View1 1
vtrihedron trihedron1
vsize trihedron1 400
vclear

#vtop
set scale 0.1
set vpprojx 0.0
set vpprojy 0.0
set vpprojz 1.0
set vpupx 0.0
set vpupy 1.0
set vpupz 0.0
set vpatx 4995
set vpaty 500
set vpatz 0
set vpeyex 4995
set vpeyey 500
set vpeyez 0.0001
vviewparams -scale $scale -eye $vpeyex $vpeyey $vpeyez -at $vpatx $vpaty $vpatz -up $vpupx $vpupy $vpupz -proj $vpprojx $vpprojy $vpprojz

set NB 1000

proc draw_lines {{distance 10.0}} {
  # set colors to corner spheres
  for {set i 0} {$i < $::NB} {incr i} {
    set x [expr $i * $distance]
    set ya 0.0
    set yb 1000.0
    set z 0.0
    vertex v1 $x $ya $z
    vertex v2 $x $yb $z
    edge e$i v1 v2
    vdisplay -update e$i
    puts "$i: $x $ya $yb $z"
  }
}

puts "Start test lines"
draw_lines 10.0
vfit
TagsNo tags attached.
Test case numberbugs vis bug25853
Attached Filespng file icon Screenshot - 2015-02-23.png (29,709 bytes) 2015-02-23 16:56

- Relationships
related to 0025675closedbugmaster Open CASCADE Visualization - Fix problems and inefficiencies with frustum culling 

-  Notes
(0037790)
kgv (developer)
2015-02-24 09:01

Please check the case on current master - the issue should be fixed by patch for #0025679.
(0038040)
git (administrator)
2015-03-03 13:36

Branch CR25853 has been created by apn.

SHA-1: b228704946c5f7d6a545a55be1abd523768fef8f


Detailed log of new commits:

Author: apn
Date: Tue Mar 3 13:35:57 2015 +0300

    0025853: Edges disappear or reappear when displaying new edges
    
    Added test case bugs/vis/bug25853
(0038041)
apn (administrator)
2015-03-03 13:36

Problem is not reproduced on current state of master.
Test case:
bugs vis bug25853 - OK.
(0038616)
git (administrator)
2015-03-18 13:39

Branch CR25853 has been deleted by inv.

SHA-1: b228704946c5f7d6a545a55be1abd523768fef8f

- Related Changesets
occt: master 44b47a9a
Timestamp: 2015-03-03 10:35:57
Author: apn
Committer: bugmaster
Details ] Diff ]
0025853: Edges disappear or reappear when displaying new edges

Added test case bugs/vis/bug25853
add - tests/bugs/vis/bug25853 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-02-23 16:56 spamkiller New Issue
2015-02-23 16:56 spamkiller Assigned To => kgv
2015-02-23 16:56 spamkiller File Added: Screenshot - 2015-02-23.png
2015-02-24 08:59 kgv Relationship added related to 0025675
2015-02-24 09:00 kgv Relationship added duplicate of 0025679
2015-02-24 09:01 kgv Note Added: 0037790
2015-02-24 09:01 kgv Assigned To kgv => bugmaster
2015-02-24 09:01 kgv Status new => feedback
2015-02-24 09:01 kgv Resolution open => duplicate
2015-02-24 09:01 kgv Target Version => 6.9.0
2015-02-27 10:09 bugmaster Assigned To bugmaster => apn
2015-03-03 13:36 git Note Added: 0038040
2015-03-03 13:36 apn Note Added: 0038041
2015-03-03 13:37 apn Test case number => bugs vis bug25853
2015-03-03 13:37 apn Assigned To apn => bugmaster
2015-03-03 13:37 apn Status feedback => tested
2015-03-06 15:13 bugmaster Changeset attached => occt master 44b47a9a
2015-03-06 15:13 bugmaster Status tested => verified
2015-03-06 15:13 bugmaster Resolution duplicate => fixed
2015-03-18 13:39 git Note Added: 0038616
2015-05-14 15:28 user533 Status verified => closed
2015-05-14 15:31 user533 Fixed in Version => 6.9.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker