MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025813Community[OCCT] OCCT:Modeling Algorithmspublic2015-02-10 15:512016-04-20 15:50
Reportershoogen 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0025813: regression in Hidden Line Removal
DescriptionSome of the problems seem in HLR seem to be regressions, as OCE 0.9.1 (based on OCCT 6.5.2) gives better results then OCCT 6.8.1-dev, 6.7.0 and OCE 0.16
Steps To Reproducebug25813_1, bug25813_2, bug25813_3, bug25813_4, bug25813_5
TagsNo tags attached.
Test case numberbugs modalg_6 bug25813_1, bug25813_2, bug25813_3, bug25813_4, bug25813_5
Attached Filespng file icon hlr-bus1.png (19,199 bytes) 2015-02-10 15:51
png file icon hlr-bus1-oce0_9_1.png (15,111 bytes) 2015-02-10 15:52
zip file icon hlr-bus1.zip (22,698 bytes) 2015-02-12 02:00
png file icon hlr-torus1.png (4,858 bytes) 2015-02-12 22:05
png file icon hlr-test_normandc1m1a.png (14,276 bytes) 2015-02-14 22:13
? file icon hlr-test_normandc1m1-draw-Cut001.brep (30,096 bytes) 2015-02-14 22:14
txt file icon hlr-test_normandc1m1.txt (875 bytes) 2015-02-14 22:15
png file icon hlr-fillet1.png (2,023 bytes) 2015-02-20 13:57
txt file icon hlr-fillet1.txt (468 bytes) 2015-02-20 13:59
png file icon hlr-fillet2.png (5,736 bytes) 2015-04-08 17:33
? file icon hlr-fillet2-tcl-f.brep (108,539 bytes) 2015-04-08 17:37
? file icon hlr-fillet2.tcl (424 bytes) 2015-04-08 17:38
? file icon CR25813.gitbundle (2,820 bytes) 2015-04-09 20:21

- Relationships
related to 0023709closedaba Open CASCADE Redesign of hlrtest command 

-  Notes
(0037468)
shoogen (reporter)
2015-02-12 22:07

I found a simpler example (without external shapes)

pload MODELING
ptorus Torus 10 2 -180 180 360
hprj Shape2DView_proj 0 0 0 0 1 0 0 0 1
houtl Shape2DView_outl Torus
hfill Shape2DView_outl Shape2DView_proj 0
hload Shape2DView_outl
hsetprj Shape2DView_proj
hupdate
hhide
hres2d
#compound vl v1l vnl vol vil hl h1l hnl hol hil Shape2DView
#donly Shape2DView
(0039475)
shoogen (reporter)
2015-04-09 11:47
edited on: 2015-04-09 18:11

One of the problems was introduced in OCE between versions 0.12 (6.5.4) and 0.13 (6.6.0).
reverting http://git.dev.opencascade.org/gitweb/?p=occt.git;a=commitdiff;h=0a768f56848d12b18c41422554f35a40c72b6d02#patch13 [^]
solves the problem shown by "hlr-fillet2" and improves the output for "hlr-bus1".
The problem with "hlr-fillet1" was introduced between OCE versions 0.14 (6.6.0) and 0.15 (6.7.0).

(0039482)
shoogen (reporter)
2015-04-09 12:23

please add a relation to 0023709
(0039530)
shoogen (reporter)
2015-04-09 19:02

please add a relation to #0023625.
(0039536)
shoogen (reporter)
2015-04-09 20:30

CR25813 does not contain a bugfix. It just proofs that the problems are regressions introduced by 0a768f5 and bda8360.
(0051483)
git (administrator)
2016-03-09 17:47

Branch CR25813 has been created by jgv.

SHA-1: 0ac1eec4403274c51db6f932119e657aefe96abc


Detailed log of new commits:

Author: jgv
Date: Wed Mar 9 17:46:55 2016 +0300

    0025813: regression in Hidden Line Removal
    Regressions that appeared in OCCT 6.6.0 are fixed.
(0051484)
jgv (developer)
2016-03-09 17:49

Please review the branch CR25813.
(0051486)
msv (developer)
2016-03-09 17:58

Reviewed.
(0051529)
git (administrator)
2016-03-10 17:32

Branch CR25813 has been updated by apv.

SHA-1: 099656a3e92d9a6b34591c828dee9bb4d8c2b097


Detailed log of new commits:

Author: apv
Date: Thu Mar 10 17:31:51 2016 +0300

    Correction of test cases for issue 0025813

(0051532)
apv (tester)
2016-03-10 18:07

Dear BugMaster,

Branch CR25813 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 0ac1eec4403274c51db6f932119e657aefe96abc

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 0 (0 on master)
products component:
   Linux: 41 (41 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR25813-master-occt-64/Debian70-64/summary.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/summary.html [^]
bugs modalg_6 bug25908

Testing cases:
bugs modalg_6 bug25813_1 - OK
http://occt-tests/CR25813-master-occt-64/Debian70-64/bugs/modalg_6/bug25813_1.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25813_1.html [^]
bugs modalg_6 bug25813_2 - OK
http://occt-tests/CR25813-master-occt-64/Debian70-64/bugs/modalg_6/bug25813_2.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25813_2.html [^]
bugs modalg_6 bug25813_3 - OK
http://occt-tests/CR25813-master-occt-64/Debian70-64/bugs/modalg_6/bug25813_3.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25813_3.html [^]
bugs modalg_6 bug25813_4 - OK
http://occt-tests/CR25813-master-occt-64/Debian70-64/bugs/modalg_6/bug25813_4.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25813_4.html [^]
bugs modalg_6 bug25813_5 - OK
http://occt-tests/CR25813-master-occt-64/Debian70-64/bugs/modalg_6/bug25813_5.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25813_5.html [^]

Testing on Linux:
Total MEMORY difference: 89763398 / 89810039 [-0.05%]
Total CPU difference: 19179.149999999943 / 19348.249999999996 [-0.87%]

Testing on Windows:
Total MEMORY difference: 57953193 / 58015407 [-0.11%]
Total CPU difference: 18027.007556998902 / 18102.59004149884 [-0.42%]

There is difference in images found by testdiff:
http://occt-tests/CR25813-master-occt-64/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR25813-master-occt-64/Windows-64-VC10/diff-Windows-64-VC10.html [^]
bugs modalg_5 bug24842_front
(0051533)
apv (tester)
2016-03-10 18:11

Dear jgv,

Branch CR25813 has been rejected due to:
- regressions/differences/improvements
- differences in images

Moreover, please validate modifications and images for test cases:
bugs modalg_6 bug25813_1, bug25813_2, bug25813_3, bug25813_4, bug25813_5
(0051553)
jgv (developer)
2016-03-11 13:37

Dear Alexey,

bugs modalg_6 bug25908
is not regression, please update reference data to new state;

difference "bugs modalg_5 bug24842_front" is improvement;

test cases are OK.
(0051594)
git (administrator)
2016-03-14 14:59

Branch CR25813 has been updated by apv.

SHA-1: e5aaf5a4e517f23ede70a5258ca6a9d174db69be


Detailed log of new commits:

Author: apv
Date: Mon Mar 14 14:58:22 2016 +0300

    Reference data update for test case bugs/mnodalg_6 /bug25908

(0051597)
apv (tester)
2016-03-14 15:01

Dear Andrey,

Please validate reference data update for test case bugs/modalg_6/bug25908 in branch CR25813 from occt git-repository.
(0051665)
abv (manager)
2016-03-15 17:31

I have no objections
(0052888)
git (administrator)
2016-04-17 13:40

Branch CR25813 has been deleted by kgv.

SHA-1: e5aaf5a4e517f23ede70a5258ca6a9d174db69be

- Related Changesets
occt: master f6fd8f0b
Timestamp: 2016-03-09 14:46:55
Author: jgv
Committer: bugmaster
Details ] Diff ]
0025813: regression in Hidden Line Removal
Regressions that appeared in OCCT 6.6.0 are fixed.

Correction of test cases for issue 0025813

Reference data update for test case bugs/mnodalg_6 /bug25908
mod - src/HLRBRep/HLRBRep_Data.cxx Diff ] File ]
add - tests/bugs/modalg_6/bug25813_1 Diff ] File ]
add - tests/bugs/modalg_6/bug25813_2 Diff ] File ]
add - tests/bugs/modalg_6/bug25813_3 Diff ] File ]
add - tests/bugs/modalg_6/bug25813_4 Diff ] File ]
add - tests/bugs/modalg_6/bug25813_5 Diff ] File ]
mod - tests/bugs/modalg_6/bug25908 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-02-10 15:51 shoogen New Issue
2015-02-10 15:51 shoogen Assigned To => msv
2015-02-10 15:51 shoogen File Added: hlr-bus1.png
2015-02-10 15:52 shoogen File Added: hlr-bus1-oce0_9_1.png
2015-02-12 02:00 shoogen File Added: hlr-bus1.zip
2015-02-12 22:05 shoogen File Added: hlr-torus1.png
2015-02-12 22:07 shoogen Note Added: 0037468
2015-02-14 22:13 shoogen File Added: hlr-test_normandc1m1a.png
2015-02-14 22:14 shoogen File Added: hlr-test_normandc1m1-draw-Cut001.brep
2015-02-14 22:15 shoogen File Added: hlr-test_normandc1m1.txt
2015-02-20 13:57 shoogen File Added: hlr-fillet1.png
2015-02-20 13:59 shoogen File Added: hlr-fillet1.txt
2015-04-08 17:33 shoogen File Added: hlr-fillet2.png
2015-04-08 17:37 shoogen File Added: hlr-fillet2-tcl-f.brep
2015-04-08 17:38 shoogen File Added: hlr-fillet2.tcl
2015-04-09 11:47 shoogen Note Added: 0039475
2015-04-09 12:23 shoogen Note Added: 0039482
2015-04-09 12:51 msv Relationship added related to 0023709
2015-04-09 16:12 shoogen Note Edited: 0039475 View Revisions
2015-04-09 16:14 shoogen Note Edited: 0039475 View Revisions
2015-04-09 18:11 shoogen Note Edited: 0039475 View Revisions
2015-04-09 19:02 shoogen Note Added: 0039530
2015-04-09 20:21 shoogen File Added: CR25813.gitbundle
2015-04-09 20:30 shoogen Note Added: 0039536
2015-04-09 23:50 msv Relationship added related to 0023625
2015-04-10 10:00 abv Target Version => 6.9.0
2015-04-20 15:19 msv Assigned To msv => jgv
2015-04-20 15:19 msv Status new => assigned
2015-04-30 16:43 msv Target Version 6.9.0 => 7.1.0
2016-03-09 17:47 git Note Added: 0051483
2016-03-09 17:49 jgv Note Added: 0051484
2016-03-09 17:49 jgv Assigned To jgv => msv
2016-03-09 17:49 jgv Status assigned => resolved
2016-03-09 17:49 jgv Steps to Reproduce Updated View Revisions
2016-03-09 17:58 msv Note Added: 0051486
2016-03-09 17:58 msv Assigned To msv => bugmaster
2016-03-09 17:58 msv Status resolved => reviewed
2016-03-09 18:10 apv Assigned To bugmaster => apv
2016-03-10 14:03 apv Test case number => bugs modalg_6 bug25813_1, bug25813_2, bug25813_3, bug25813_4, bug25813_5
2016-03-10 17:32 git Note Added: 0051529
2016-03-10 18:07 apv Note Added: 0051532
2016-03-10 18:07 apv Assigned To apv => jgv
2016-03-10 18:07 apv Status reviewed => assigned
2016-03-10 18:11 apv Note Added: 0051533
2016-03-11 13:37 jgv Note Added: 0051553
2016-03-11 13:37 jgv Assigned To jgv => apv
2016-03-11 13:37 jgv Status assigned => feedback
2016-03-14 14:59 git Note Added: 0051594
2016-03-14 14:59 apv Assigned To apv => abv
2016-03-14 15:01 apv Note Added: 0051597
2016-03-15 17:31 abv Note Added: 0051665
2016-03-15 17:31 abv Assigned To abv => apv
2016-03-15 19:36 apv Assigned To apv => bugmaster
2016-03-15 19:36 apv Status feedback => tested
2016-03-25 10:49 bugmaster Target Version 7.1.0 => 7.0.0
2016-03-29 15:55 bugmaster Changeset attached => occt master f6fd8f0b
2016-03-29 15:55 bugmaster Status tested => verified
2016-03-29 15:55 bugmaster Resolution open => fixed
2016-04-17 13:40 git Note Added: 0052888
2016-04-20 15:43 user533 Fixed in Version => 7.0.0
2016-04-20 15:50 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker