MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025802Open CASCADE[OCCT] OCCT:Testspublic2015-02-06 18:112015-05-14 15:32
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0025802: Adapt test cases bugs vis bug10781 and bug23227 for Intel graphics driver
DescriptionThe following tests cases do not pass on Intel graphics:
bugs vis bug23227
bugs vis bug10781 
Steps To Reproduce
bugs vis bug23227
bugs vis bug10781 
TagsNo tags attached.
Test case numberbugs vis(004) bug10781, bug23227
Attached Filespng file icon diff_bugs_vis_bug9517.png (364,858 bytes) 2015-02-09 06:37
png file icon diff_bugs_vis_bug1188.png (129,872 bytes) 2015-02-09 06:37

- Relationships

-  Notes
(0037195)
git (administrator)
2015-02-06 18:15

Branch CR25802 has been created by kgv.

SHA-1: 5618bb5477c5710503dfea5974d5cb77b35b3a89


Detailed log of new commits:

Author: kgv
Date: Fri Feb 6 18:15:48 2015 +0300

    0025802: Adopt test cases bugs vis bug10781 and bug23227 for Intel graphics driver
    
    Test case bugs/vis/bug10781 - use smaller line width in test case
    (some Intel OpenGL drivers support only 7 pixels-width lines).
    Test case bugs/vis/bug23227 - just check triangles count in feedback buffer is not 0.
(0037196)
kgv (developer)
2015-02-06 18:17

Please check updated test cases.
(0037204)
abv (manager)
2015-02-08 23:58

Interesting notice: if I switch to another user on my computer while running tests, test bugs vis bug10781 passes fine (it draws wide lines successfully), even on current master.

Also differences are reported in this case for almost all shading images (not appreciable by eye, and colors are the same as shown in Paint, while pixels reported as different).

Another interesting cases are:

- bugs vis bug1188: when another user is active, image is greater in vertical direction.

- bugs vis bug9517: images have diffenent level of blurring

See attached images of testdiff output (case A is when another user is active).

Note that my computer has Intel HD 4600 integrated graphics, settings of both users are default
(0037205)
abv (manager)
2015-02-09 06:37

Addition: test bugs vis bug23227 also passes on master if another user is active. At the same time, additional test bugs vis bug25363 fails, as it seems, due to slightly shifted location of the marker. This shift seems to be systematic, as similar diffs are shown on all snapshots containing texts and markers.
(0037206)
abv (manager)
2015-02-09 06:43

I confirm that tests bugs vis bug23227 and bugs vis bug10781 are OK on CR25802
(0037207)
abv (manager)
2015-02-09 06:44

For testers: please test only specified test cases, no recompiling or overall testing is necessary
(0037297)
mkv (tester)
2015-02-10 16:28

Dear BugMaster,
Branch CR25802 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 5618bb5477c5710503dfea5974d5cb77b35b3a89

Number of compiler warnings:

occt component :
Linux: 18 (18 on master)
Windows: 0 (0 on master)

products component :
Linux: 11 (11 on master)
Windows: 1 (1 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR25802-master-occt/Debian60-64/bugs/vis/bug10781.html [^]
http://occt-tests/CR25802-master-occt/Windows-32-VC10/bugs/vis/bug10781.html [^]
bugs vis(004) bug10781: OK

http://occt-tests/CR25802-master-occt/Debian60-64/bugs/vis/bug23227.html [^]
http://occt-tests/CR25802-master-occt/Windows-32-VC10/bugs/vis/bug23227.html [^]
bugs vis(004) bug23227: OK

Testing on Linux:
occt component :
Total MEMORY difference: 84599250 / 86235915
Total CPU difference: 49889.06999999998 / 47876.709999999846
products component :
Total MEMORY difference: 23436833 / 23349226
Total CPU difference: 15319.989999999976 / 14717.069999999967

Testing on Windows:
occt component :
Total MEMORY difference: 40649406 / 40658496
Total CPU difference: 34215.4375 / 32754.0
products component :
Total MEMORY difference: 11034006 / 11081969
Total CPU difference: 10508.75 / 10978.125

There are no differences in images found by testdiff.
(0038596)
git (administrator)
2015-03-18 13:38

Branch CR25802 has been deleted by inv.

SHA-1: 5618bb5477c5710503dfea5974d5cb77b35b3a89

- Related Changesets
occt: master eea55df5
Timestamp: 2015-02-06 15:15:48
Author: kgv
Committer: bugmaster
Details ] Diff ]
0025802: Adopt test cases bugs vis bug10781 and bug23227 for Intel graphics driver

Test case bugs/vis/bug10781 - use smaller line width in test case
(some Intel OpenGL drivers support only 7 pixels-width lines).
Test case bugs/vis/bug23227 - just check triangles count in feedback buffer is not 0.
mod - tests/bugs/vis/bug10781 Diff ] File ]
mod - tests/bugs/vis/bug23227 Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-02-06 18:11 kgv New Issue
2015-02-06 18:11 kgv Assigned To => mkv
2015-02-06 18:15 git Note Added: 0037195
2015-02-06 18:17 kgv Note Added: 0037196
2015-02-06 18:17 kgv Assigned To mkv => bugmaster
2015-02-06 18:17 kgv Severity minor => integration request
2015-02-06 18:17 kgv Status new => resolved
2015-02-06 18:18 kgv Status resolved => reviewed
2015-02-06 19:46 mkv Assigned To bugmaster => mkv
2015-02-08 23:58 abv Note Added: 0037204
2015-02-09 06:37 abv Note Added: 0037205
2015-02-09 06:37 abv File Added: diff_bugs_vis_bug9517.png
2015-02-09 06:37 abv File Added: diff_bugs_vis_bug1188.png
2015-02-09 06:43 abv Note Added: 0037206
2015-02-09 06:44 abv Note Added: 0037207
2015-02-10 16:28 mkv Note Added: 0037297
2015-02-10 16:30 mkv Test case number => bugs vis(004) bug10781, bug23227
2015-02-10 16:30 mkv Assigned To mkv => bugmaster
2015-02-10 16:30 mkv Status reviewed => tested
2015-02-10 16:31 abv Summary Adopt test cases bugs vis bug10781 and bug23227 for Intel graphics driver => Adapt test cases bugs vis bug10781 and bug23227 for Intel graphics driver
2015-02-13 17:55 bugmaster Changeset attached => occt master eea55df5
2015-02-13 17:55 bugmaster Status tested => verified
2015-02-13 17:55 bugmaster Resolution open => fixed
2015-03-18 13:38 git Note Added: 0038596
2015-05-14 15:29 aiv Status verified => closed
2015-05-14 15:32 aiv Fixed in Version => 6.9.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker