MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025698Community[OCCT] OCCT:Modeling Algorithmspublic2015-01-12 18:432017-12-05 17:09
ReporterIstvan Csanady 
Assigned Tomsv 
PrioritynormalSeverityminor 
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0025698: Implementation of progress feedback in pave filler
DescriptionProgress indication is not implemented in BOPAlgo_PaveFiller. I created an implementation. See the attached patch.
Steps To ReproduceNot needed.
TagsNo tags attached.
Test case number
Attached Filesdiff file icon patch.diff (3,522 bytes) 2015-01-12 18:43
diff file icon patch2.diff (843 bytes) 2015-01-12 18:57

- Relationships

-  Notes
(0035978)
Istvan Csanady (developer)
2015-01-12 18:57

Both patches needed.
(0039501)
git (administrator)
2015-04-09 15:32

Branch CR25698 has been created by msv.

SHA-1: b0e6fe32e260d7115f60f70cf7d95e7df6102989


Detailed log of new commits:

Author: Istvan Csanady
Date: Mon Jan 12 16:40:00 2015 +0100

    0025698: Implementation of progress feedback in pave filler
(0039502)
msv (developer)
2015-04-09 15:34

Dear pkv, please review the branch CR25698.
(0039665)
pkv (developer)
2015-04-14 09:02
edited on: 2015-04-17 10:02

1. Replace the pieces of code
...
 if (!myProgressIndicator.IsNull()) {
    myProgressIndicator->NewScope(100.0);
    myProgressIndicator->SetStep(100.0 / 16.0);
  }
,,,
if (!myProgressIndicator.IsNull()) {
    myProgressIndicator->Increment();
  }
...
 if (!myProgressIndicator.IsNull()) {
    myProgressIndicator->Increment();
    myProgressIndicator->EndScope();
  }
 ...
by methods that control the indicator. Say,

BOPAlgo_PaveFiller::IndicatorStart ()
BOPAlgo_PaveFiller::IndicatorIncrement ()
BOPAlgo_PaveFiller::IndicatorStop ().

Place the methods in a separate file [say BOPAlgo_PaveFiller_11.cxx]
The reasons:
- keep the one functionality in one place is easy to maintain and modify
- keep the control program out of details

2. Why the steps
 myDS->UpdatePaveBlocks(); RefineFaceInfoOn();
are out of IndicatorIncrement ()

3. Why the all steps have equal complexity?
The complexity of a step depends on data.
It would be nice to have the analysis of data inside the code.
The analysis will allow to distribute the complexity of steps more correctly

4. It will be good to have a test command and several test cases
to see how it works. These tools are absolutely necessary to identify
the problems associated with Progress Indicator in context of
BOPAlgo_PaveFiller:
- The Draw command is needed.
- Steps To Reproduce is needed.
- Test cases are needed.

(0039762)
msv (developer)
2015-04-15 12:09

Dear pkv, I see that this task is not so simple as seemed. So, please, put it in your list of tasks.

- Issue History
Date Modified Username Field Change
2015-01-12 18:43 Istvan Csanady New Issue
2015-01-12 18:43 Istvan Csanady Assigned To => msv
2015-01-12 18:43 Istvan Csanady File Added: patch.diff
2015-01-12 18:57 Istvan Csanady File Added: patch2.diff
2015-01-12 18:57 Istvan Csanady Note Added: 0035978
2015-04-09 15:32 git Note Added: 0039501
2015-04-09 15:32 msv Status new => assigned
2015-04-09 15:34 msv Note Added: 0039502
2015-04-09 15:34 msv Assigned To msv => pkv
2015-04-09 15:34 msv Status assigned => resolved
2015-04-09 15:34 msv Steps to Reproduce Updated View Revisions
2015-04-14 09:02 pkv Note Added: 0039665
2015-04-14 09:03 pkv Assigned To pkv => msv
2015-04-14 09:03 pkv Status resolved => assigned
2015-04-15 12:07 msv Assigned To msv => pkv
2015-04-15 12:09 msv Note Added: 0039762
2015-04-15 12:09 msv Target Version 6.9.0 => 7.1.0
2015-04-17 10:02 pkv Note Edited: 0039665 View Revisions
2016-10-28 18:56 msv Assigned To pkv => msv
2016-10-28 18:56 msv Target Version 7.1.0 => 7.2.0
2017-07-21 11:22 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0*


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker