MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025693Community[OCCT] OCCT:Modeling Datapublic2015-01-08 20:552018-06-29 21:19
Reportershoogen 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0025693: Wire of BSplines fails bopcheck
DescriptionThe attached wire was created from SVG data. Bezier segments of SVG paths were converted to BezierCurves. Duplicate poles (at the knots) were copied form the SVG as they were.
AFAIK, bezier curves have no multiplicities (in OCCT).
Afterwards a wire was created from the separated edges. Then the result was scaled using a transformation. (which should convert the segments to BSplines)

The individual edges pass the bopcheck whereas the bopcheck generates an error when testing the whole wire.
The user wanted to extrude the wire and later apply a fillet (parallel to the wire). This operation fails, as well.
Steps To Reproduce> restore path3035.brp
> bopcheck path3035
There were errors during the operation, so the list may be incomplete.
 This shape seems to be OK.
TagsBOPAlgo_OperationAborted
Test case numberbugs moddata_3 bug25693_1, bug25693_2
Attached Files? file icon path3035.brp (26,761 bytes) 2015-01-08 20:55
? file icon path3039.brp (3,101 bytes) 2015-01-09 00:07
? file icon edges.brep (6,431 bytes) 2017-09-26 08:36
? file icon edge_face_1.brep (2,808 bytes) 2017-09-26 08:36
? file icon edge_face_2.brep (2,808 bytes) 2017-09-26 08:36

- Relationships
related to 0025104closedbugmaster Prism from BSpline curve can not be chamfered 
related to 0025879closedbugmaster result of blend fails the bopcheck 

-  Notes
(0035933)
shoogen (reporter)
2015-01-08 23:37

Another path passes the bopcheck, but resulting extrusion fails.

> pload MODELING
> restore path3039.brp path3039
> prism Extrude_path3039 path3039 0 0 50
> bopcheck path3039
# This shape seems to be OK.
> bopcheck Extrude_path3039
#There were errors during the operation, so the list may be incomplete.
# This shape seems to be OK.
(0036308)
shoogen (reporter)
2015-01-21 12:29

path3035:
#4 0x00007ffff574d3fc in gp_VectorWithNullMagnitude::Raise ( AString=0x7ffff75b49e1 " ") at occt/drv/gp/gp_VectorWithNullMagnitude_0.cxx:10
#5 0x00007ffff74e4716 in gp_Vec::Angle (this=0x7fffffffc0e0, Other=...) at occt/inc/gp_Vec.lxx:124
#6 0x00007fffed703b83 in IntTools_EdgeEdge::IsIntersection (this=0xd6eba0, aT11=0, aT12=4.4222129615312391e-05, aT21=0.99994021005999179, aT22=1) at occt/src/IntTools/IntTools_EdgeEdge.cxx:914
0000007 0x00007fffed701202 in IntTools_EdgeEdge::FindSolutions (this=0xd6eba0, theR1=..., theR2=..., theBox2=..., theRanges1=..., theRanges2=...) at occt/src/IntTools/IntTools_EdgeEdge.cxx:425
0000008 0x00007fffed70037a in IntTools_EdgeEdge::FindSolutions (this=0xd6eba0, theRanges1=..., theRanges2=..., bSplit2=@0x7fffffffc8cc: 0) at occt/src/IntTools/IntTools_EdgeEdge.cxx:255
0000009 0x00007fffed70009a in IntTools_EdgeEdge::Perform (this=0xd6eba0) at occt/src/IntTools/IntTools_EdgeEdge.cxx:221
#10 0x00007fffed79528c in BOPAlgo_EdgeEdge::Perform (this=0xd6eb78) at occt/src/BOPAlgo/BOPAlgo_PaveFiller_3.cxx:107
0000011 0x00007fffed797461 in BOPCol_TBBFunctor<BOPAlgo_EdgeEdge, BOPCol_NCVector<BOPAlgo_EdgeEdge> >::operator() (this=0x7fffffffc970, aBR=...) at occt/inc/BOPCol_TBB.hxx:107
#12 0x00007fffed795bad in BOPCol_TBBCnt<BOPCol_TBBFunctor<BOPAlgo_EdgeEdge, BOPCol_NCVector<BOPAlgo_EdgeEdge> >, BOPCol_NCVector<BOPAlgo_EdgeEdge> >::Perform ( bRunParallel=0, aV=...) at occt/inc/BOPCol_TBB.hxx:147
0000013 0x00007fffed7919e2 in BOPAlgo_PaveFiller::PerformEE (this=0x7fffffffd2a0) at occt/src/BOPAlgo/BOPAlgo_PaveFiller_3.cxx:367
(0036310)
shoogen (reporter)
2015-01-21 13:03

Extrude_path3039:
#4 0x00007ffff4e1afb0 in Standard_ConstructionError::Raise ( AString=0x7ffff75b4860 "") at occt/drv/Standard/Standard_ConstructionError_0.cxx:10
#5 0x00007ffff74d5d44 in gp_Vec::Normalize (this=0x7ffffffe9810) at occt/inc/gp_Vec.lxx:226
#6 0x00007ffff69acbf4 in IntCurveSurface_ComputeTransitions (curve=..., w=0, TransOnCurve=@0x7ffffffe990c: 1041313291, surface=..., u=0.99999999999999978, v=0) at occt/inc/IntCurveSurface_Inter.gxx:1564
0000007 0x00007ffff69ac374 in IntCurveSurface_HInter::AppendPoint ( this=0x7fffffffbe30, curve=..., lw=0, surface=..., su=0.99999999999999978, sv=0) at occt/inc/IntCurveSurface_Inter.gxx:1444
0000008 0x00007ffff69a9716 in IntCurveSurface_HInter::InternalPerform ( this=0x7fffffffbe30, curve=..., polygon=..., surface=..., polyhedron=..., u0=0, v0=-50, u1=1, v1=0) at occt/inc/IntCurveSurface_Inter.gxx:945
0000009 0x00007ffff69a9c1f in IntCurveSurface_HInter::InternalPerform ( this=0x7fffffffbe30, curve=..., polygon=..., surface=..., U1=0, V1=-50, U2=1, V2=0) at occt/inc/IntCurveSurface_Inter.gxx:998
#10 0x00007ffff69a75c5 in IntCurveSurface_HInter::Perform ( this=0x7fffffffbe30, curve=..., surface=..., U1=0, V1=-50, U2=1, V2=0) at occt/inc/IntCurveSurface_Inter.gxx:586
0000011 0x00007ffff69a6e09 in IntCurveSurface_HInter::Perform ( this=0x7fffffffbe30, curve=..., surface=...) at occt/inc/IntCurveSurface_Inter.gxx:507
#12 0x00007fffed6ebe4c in IntTools_BeanFaceIntersector::ComputeAroundExactIntersection (this=0x7fffffffc1c0) at occt/src/IntTools/IntTools_BeanFaceIntersector.cxx:627
0000013 0x00007fffed6eaab3 in IntTools_BeanFaceIntersector::Perform ( this=0x7fffffffc1c0) at occt/src/IntTools/IntTools_BeanFaceIntersector.cxx:422
0000014 0x00007fffed70abf2 in IntTools_EdgeFace::Perform (this=0xd8da38) at occt/src/IntTools/IntTools_EdgeFace.cxx:1262
(0069160)
mkv (tester)
2017-08-07 15:31

Problem described in issue is reproduced on current state of OCCT.
(0070833)
emv (developer)
2017-09-26 08:38

The bopcheck fails because the intersection of some of the pairs of sub-shapes raises exception. Try intersection of the attached shapes:
restore edges.brep c
explode c
bop c_1 c_2

restore edge_face_1.brep c
explode c
bop c_1 c_2

restore edge_face_2.brep c
explode c
bop c_1 c_2
(0071912)
aml (developer)
2017-11-01 14:30

Dear msv,
it seems that problem has been fixed.

Draw[1]> pload MODELING
Draw[2]> restore path3039.brp path3039
path3039
Draw[3]> prism Extrude_path3039 path3039 0 0 50
Draw[4]> bopcheck path3039
 This shape seems to be OK.

Draw[5]> # This shape seems to be OK.
Draw[6]> bopcheck Extrude_path3039
 This shape seems to be OK.
(0072323)
aml (developer)
2017-11-17 16:30

Dear msv,
I propose to close this issue since the problem is fixed in the scope of the 0025104 correction.
(0072324)
msv (developer)
2017-11-17 17:07

I agree to close.

- Issue History
Date Modified Username Field Change
2015-01-08 20:55 shoogen New Issue
2015-01-08 20:55 shoogen Assigned To => msv
2015-01-08 20:55 shoogen File Added: path3035.brp
2015-01-08 23:37 shoogen Note Added: 0035933
2015-01-09 00:07 shoogen File Added: path3039.brp
2015-01-21 10:21 shoogen Tag Attached: BOPAlgo_OperationAborted
2015-01-21 12:29 shoogen Note Added: 0036308
2015-01-21 13:03 shoogen Note Added: 0036310
2017-08-07 15:31 mkv Test case number => bugs moddata_3 bug25693_1, bug25693_2
2017-08-07 15:31 mkv Note Added: 0069160
2017-09-26 08:36 emv File Added: edges.brep
2017-09-26 08:36 emv File Added: edge_face_1.brep
2017-09-26 08:36 emv File Added: edge_face_2.brep
2017-09-26 08:38 emv Note Added: 0070833
2017-09-26 09:00 emv Relationship added related to 0025104
2017-09-26 09:00 emv Relationship added related to 0025879
2017-11-01 14:30 aml Note Added: 0071912
2017-11-01 14:30 aml Assigned To msv => aml
2017-11-01 14:30 aml Status new => assigned
2017-11-17 16:30 aml Note Added: 0072323
2017-11-17 16:30 aml Assigned To aml => msv
2017-11-17 16:30 aml Status assigned => resolved
2017-11-17 17:07 msv Note Added: 0072324
2017-11-17 17:07 msv Assigned To msv => bugmaster
2017-11-17 17:07 msv Status resolved => feedback
2017-11-21 12:05 bugmaster Status feedback => verified
2017-11-21 12:05 bugmaster Resolution open => fixed
2017-11-21 12:06 bugmaster Target Version => 7.3.0
2018-06-29 21:15 user533 Fixed in Version => 7.3.0
2018-06-29 21:19 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker