View Issue Details

IDProjectCategoryView StatusLast Update
0025687Open CASCADEOCCT:Visualizationpublic2016-11-01 19:28
Reporterabv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Target Version6.9.0Fixed in Version6.9.0 
Summary0025687: Visualization, XCAF - eliminate visual artifacts at the edges of faces
DescriptionCurrently backface culling is not used for display of solids in XCAF, at lest when some faces have different color. This results in visual artifacts at the edges of faces, see steps to reproduce.

Apart of culling, perhaps polygon offsets can be tuned to reduce artifacts.
Steps To Reproduce# Make blue box with one red face
pload MODELING VISUALIZATION OCAF XDE
box b 10 10 10
NewDocument D MDTV-XCAF
XAddShape D b
XSetColor D b 0 0 1
explode b f
XSetColor D b_1 1 0 0

# show it from the side opposite to red face
XShow D
vviewparams -proj 1 0.1 0.1
vfit

# there should be no red color visible at the edges
vsetdispmode 1


 
TagsNo tags attached.
Test case numberbugs vis(004) bug25687_1, bug25687_2

Attached Files

  • xde_no_culling.png (8,596 bytes)
  • xde_culling.png (1,784 bytes)

Relationships

related to 0024521 closedbugmaster Visualization - automatic back face culling is not turned on for Solids packed into compound 
related to 0025822 closedbugmaster Visualization, TKOpenGl - front material should be used instead of back material in GLSL when distinguish mode is turned off 
related to 0028036 closedabv Visualization, AIS_ColoredShape - handle correctly nested compounds within Shaded display mode 

Activities

kgv

2015-01-06 18:15

developer   ~0035923

Please don't forget to attach snapshots.

abv

2015-01-06 18:28

manager  

xde_no_culling.png (8,596 bytes)

git

2015-02-04 16:46

administrator   ~0037079

Branch CR25687 has been created by ibs.

SHA-1: a1c419abb1a2d85122de4c0c2d551880f990025d


Detailed log of new commits:

Author: ibs
Date: Mon Feb 2 19:35:47 2015 +0300

    0025687: Visualization, XCAF - visual artifacts at the edges of faces
    
    1. culling is calculated for a colored shape before attribute parsing of the shape
    2. culling is turned on for each shell of the shape

ibs

2015-02-04 16:52

developer  

xde_culling.png (1,784 bytes)

ibs

2015-02-04 16:53

developer   ~0037080

dear kgv,
please review CR25687 occt branch

kgv

2015-02-05 14:09

developer   ~0037116

Last edited: 2015-02-05 14:12

+  else if (StdPrs_ToolShadedShape::IsClosed (myshape))
+  {
+    aClosed = TopoDS::Compound(myshape);

static cast without shape type check.

+  Standard_EXPORT void Add (const Handle(Prs3d_Presentation)& thePrs,

protected methods should start from lower-case, and please move out this new method from section "override presentation computation".

+  switch (theShape.ShapeType())
+  {
+  case TopAbs_COMPOUND:
+  case TopAbs_COMPSOLID:
+  {
+    for

please follow recommended indentation style for "switch/case".

-  if ((theShape.ShapeType() == TopAbs_COMPOUND
-    || theShape.ShapeType() == TopAbs_COMPSOLID
-    || theShape.ShapeType() == TopAbs_SOLID)
-   &&  theToExploreSolids)
+  if ((theShape.ShapeType() == TopAbs_COMPOUND  ||
+       theShape.ShapeType() == TopAbs_COMPSOLID ||
+       theShape.ShapeType() == TopAbs_SOLID       ) &&
+      theToExploreSolids                              )

unrelated change.

+
+
+// =======================================================================

redundant double empty-lines.

-void StdPrs_ShadedShape::Tessellate (const TopoDS_Shape&          theShape,
-                                     const Handle (Prs3d_Drawer)& theDrawer)

what for this method have been moved to another place in the file?

+void StdPrs_ShadedShape::AddWithForcedCulling (const Handle (Prs3d_Presentation)& thePrs,

please avoid writing "Handle (TheClass)" with space in new code.

+  // Triangulation completeness is important for "open-closed" analysis - perform tessellation beforehand
+  Tessellate (theShape, theDrawer);

copy-pasted comment does not make any sense in new location.

+  AddWithForcedCulling (myclass;

name of the new method is confusing.
Please consider changing argument "theToExploreSolids : Boolean from Standard = Standard_True" in original method to enumeration.

+//=======================================================================
+void AIS_ColoredShape::Add (const Handle(Prs3d_Presentation)& thePrs,

please move implementation of this new method right after ::Compute(), so that diff would be able to show changes.

git

2015-02-05 20:02

administrator   ~0037160

Branch CR25687 has been updated forcibly by ibs.

SHA-1: 2aa826d773ed6fdd1209d0ad8730b14ec9453949

ibs

2015-02-05 20:04

developer   ~0037161

all remarks has been taken into account. please review CR25687 occt branch

kgv

2015-02-06 18:22

developer   ~0037197

Last edited: 2015-02-06 18:23

Face visibility flag should be handled in colored shape to disable culling.

git

2015-02-09 17:39

administrator   ~0037244

Branch CR25687 has been updated forcibly by ibs.

SHA-1: 8ce66d010c26c8d53f29953f489d60394b7f3b4f

git

2015-02-09 19:11

administrator   ~0037255

Branch CR25687 has been updated by ibs.

SHA-1: 6550cc61bcd222bc3b9af2e334f303455fd7db80


Detailed log of new commits:

Author: ibs
Date: Mon Feb 9 19:08:03 2015 +0300

    test casses added

ibs

2015-02-09 19:14

developer   ~0037256

Face visibility flash is considered in colored shape to disable culling. Two test cases added. Please review CR25687 occt branch

enum StdPrs_CullingMode is waiting for new name.

kgv

2015-02-10 09:00

developer   ~0037263

+    cout << "set visibility " << endl;

please remove debugging code.

+      if (aChangeSet->Visibility < 0)
+      {
+        aChangeSet->Visibility = 0;
+      }

why you are changing the input?

+    if (Visibility < 0)
+    {
+      std::cout << "Error: the visibility should be greater than 0 (0 - invisible; >0 - visible) (specified " << Visibility << ")\n";

there no much sense to allow specifying values other than 0 and 1.

+            aColDrawer->SetHidden(!(Standard_Boolean)aChangeSet->Visibility);

such casts should not be used.

+      if (aChangeSet->ToSetVisibility == 1)
+      {
+        if (!aColoredPrs.IsNull())
+        {
+          Handle(AIS_ColoredDrawer) aColDrawer = aColoredPrs->CustomAspects (aColoredPrs->Shape());

please omit syntax error in this case.

+  if (aCmdName == "vsetvisibility"
+   || aCmdName == "vsetvis")
+  else if (aCmdName == "vunsetvisibility"
+        || aCmdName == "vunsetvis")
...
+  theCommands.Add("vsetvisibility",

only vsetvisibility has been registered in interpreter.
Anyway, there are no much sense in creation of these new commands at all - vaspects should be enough.

+puts "OCC25687"
+puts "Visualization, XCAF - visual artifacts at the edges of faces"

please don't just copy bug title into the test case - provide sane description of what it actually should test.

+set only_screen 1
\ No newline at end of file

it is preferred to append newline at the end of file.

+if {"[vreadpixel ${x_check_coord} ${y_check_coord} rgb name]" == "GREEN"} {
+  puts "Error: Culling is turned off"

please use other function to check pixel color in the area.

+Standard_Boolean AIS_ColoredShape::isShapeEntireVisible (DataMapOfShapeCompd* theDispatched)

method name is confusing - isEntireShapeVisible() or isShapeEntirelyVisible() would sound better.

git

2015-02-10 10:46

administrator   ~0037267

Branch CR25687_1 has been created by ibs.

SHA-1: 3d9b70359c37930dd6c412a3b58eb55608eea75a


Detailed log of new commits:

Author: ibs
Date: Mon Feb 2 19:35:47 2015 +0300

    0025687: Visualization, XCAF - visual artifacts at the edges of faces
    
    vaspects -setvisibility flag added
    
    calculate back face culling for a colored shape before attribute parsing of the shape
    turn on back face culling for each shell of the shape
    
    test casses added

ibs

2015-02-10 10:48

developer   ~0037268

dear kgv, all remarks have been consider, please review CR25687_1 occt branch. It contains all fixes in one commit

kgv

2015-02-10 12:30

developer   ~0037276

+  if (theMode == AIS_Shaded && myshape.ShapeType() <= TopAbs_FACE)
+  {
+    StdPrs_ShadedShape::ExploreSolids (myshape, aBuilder, aClosed, anOpened);

there are no point in calling ExploreSolids() for Shells and Faces.

+  // myShapeColors + aClosed --> array[TopAbs_ShapeEnum] of map of color-to-compound
+  for (TopoDS_Iterator aSolidIter (aClosed); aSolidIter.More(); aSolidIter.Next())
+  {
+    DataMapOfShapeCompd aDispatchedClosed [(size_t)TopAbs_SHAPE];

please add optimization to avoid this additional split in case when there are no occurrences of hidden attribute in entire map (normal case) - thus solids might be kept in group.

git

2015-02-11 15:13

administrator   ~0037360

Branch CR25687_1 has been updated forcibly by ibs.

SHA-1: 48dd7b14e9eca4b2fca672188e6e9bbc7bc0422a

git

2015-02-11 19:00

administrator   ~0037384

Branch CR25687_1 has been updated by ibs.

SHA-1: eccd6af0b210902b69d3e2e4bd486bb48b9795b5


Detailed log of new commits:

Author: ibs
Date: Wed Feb 11 18:38:06 2015 +0300

    dispatchColors mechanism explorers all contained solids

Author: ibs
Date: Wed Feb 11 16:40:57 2015 +0300

    ExploreSolids not ignores wire,edge and vertex and move they to "open" compound

ibs

2015-02-11 19:05

developer   ~0037387

dear kgv,
please review CR25687_1 occt branch.

ibs

2015-02-13 14:57

developer   ~0037508

Last edited: 2015-02-13 16:04

steps to reproduce issue:

pload MODELING VISUALIZATION OCAF XDE

NewDocument D MDTV-XCAF
XShow D
vsetdispmode 1

box b 10 10 10

XAddShape D b
XSetColor D b 0 0 1
explode b f
XSetColor D b_1 1 0 0

# show it from the side opposite to red face
XShow D
vviewparams -proj 1 0.1 0.1
vfit

git

2015-02-13 15:39

administrator   ~0037512

Branch CR25687_2 has been created by ibs.

SHA-1: 2d998557077852e75c8bf28da9162609d0ee88eb


Detailed log of new commits:

Author: ibs
Date: Fri Feb 13 15:36:39 2015 +0300

    tessellation executes before shape exploring in colored shape

git

2015-02-13 16:19

administrator   ~0037516

Branch CR25687_1 has been updated by ibs.

SHA-1: 2d998557077852e75c8bf28da9162609d0ee88eb


No new revisions were added by this update.

ibs

2015-02-13 16:20

developer   ~0037517

dear kgv,
please review CR25687_1 occt branch.

kgv

2015-02-13 17:35

developer   ~0037522

@@ -424,13 +424,13 @@ void StdPrs_ShadedShape::ExploreSolids (const TopoDS_Shape&    theShape,
     }
     case TopAbs_SHELL:
     case TopAbs_FACE:
+    case TopAbs_WIRE:
+    case TopAbs_EDGE:
+    case TopAbs_VERTEX:
     {
       theBuilder.Add (theOpened, theShape);
       return;
     }
-    case TopAbs_WIRE:
-    case TopAbs_EDGE:
-    case TopAbs_VERTEX:

ExploreSolids() within StdPrs_ShadedShape::Add() should not include wires/edges/vertices, since they displayed beforehand by dedicated algorithm wireframeFromShape().

+
+   enumeration Volume is Volume_Auto, Volume_Closed, Volume_Opened;

enumeration description is missing. Volume_Autodetection would be better than "Auto".

-  -- @param theToExploreSolids when set to true, explodes compound into two groups - with closed Solids and open Shells
+  -- @param theVolume enables/disables back-facing filled for closed/opened solid or turn on autodetection

theVolumeType defines the way how to interpret input shapes - as Closed volumes (to activate back-face culling and capping plane algorithms), as Open volumes (shells or solids with holes) or to perform Autodetection (would split input shape into two groups).

+    if (isContainCompound (theBaseShape, TopoDS::Compound (theKeyShape)))

exception would be thrown in case of TopAbs_COMPSOLID.

+  //! 
+  Standard_EXPORT static void bindSubShapes (DataMapOfShapeShape& theSubshapeKeyshapeMap,

description is empty!

+  //! Add shape to presentation
+  //! @param thePrs         the presentation
+  //! @param theDispatched  the shapes map with unique attributes
+  //! @param theMode        display mode
+  //! @param theVolume      enables/disables back-facing filled for closed/opened solid
+  Standard_EXPORT void add (const Handle(Prs3d_Presentation)& thePrs,

"add" is too short name for this complex class.

git

2015-02-16 16:03

administrator   ~0037571

Branch CR25687_1 has been updated by ibs.

SHA-1: f9c6a87fe705d88712da8de64d396d870a71c772


Detailed log of new commits:

Author: ibs
Date: Fri Feb 13 19:05:52 2015 +0300

    ExploreSolids can ignore 1d subshapes; descriptions of StdPrs_Volume and bindSubShapes methods added;
    
    AIS_ColoredShape::add renamed with addShapesWithCustomVisAndTopoProps
    bindSubShapes behavior corrected
    weird "switch" replaced with "if" statement

ibs

2015-02-16 16:07

developer   ~0037572

dear kgv,
once again :) please review CR25687_1 occt branch.

git

2015-02-16 16:24

administrator   ~0037574

Branch CR25687_3 has been created by ibs.

SHA-1: dbc83a6d31882b096c5be460604a8844b6e5f526


Detailed log of new commits:

Author: ibs
Date: Mon Feb 2 19:35:47 2015 +0300

    0025687: Visualization, XCAF - visual artifacts at the edges of faces
    
    vaspects -setvisibility flag added
    
    calculate back face culling for a colored shape before attribute parsing of the shape
    turn on back face culling for each shell of the shape
    
    if there are no invisible subshapes, solids are not processing separately (dispatch colors and culling applying)
    
    ExploreSolids can ignore 1d subshapes
    
    dispatchColors mechanism explorers all contained solids
    
    test casses added

ibs

2015-02-16 16:25

developer   ~0037575

the patch has been rebased on master

git

2015-02-16 18:56

administrator   ~0037587

Branch CR25687_3 has been updated forcibly by ibs.

SHA-1: 7c10383c0fae4bf00f87d72d14cb090cee9b4d0f

ibs

2015-02-16 20:19

developer   ~0037603

CR25687_3 branch is ready for review

git

2015-02-17 09:20

administrator   ~0037610

Branch CR25687_4 has been created by kgv.

SHA-1: 7117ef5ad2f0b95c3c63b01b68b47eb24fb701b7


Detailed log of new commits:

Author: ibs
Date: Tue Feb 17 09:20:32 2015 +0300

    0025687: Visualization, XCAF - eliminate visual artifacts at the edges of faces
    
    AIS_ColoredShape::Compute() - improve logic to split input shape into Closed and Open volumes
    with back-face culling enabled when possible.
    
    Change last argument of method StdPrs_ShadedShape::Add() from boolean to enumeration StdPrs_Volume
    which controls parsing of Closed/Open volumes within input shape.
    Make method StdPrs_ShadedShape::ExploreSolids() public.
    
    Extend Draw Harness command vaspects with option -setvisibility to hide subshape (using AIS_ColoredShape).
    Add new test cases bugs/bis/bug25687_1 and bugs/bis/bug25687_2.

kgv

2015-02-17 09:21

developer   ~0037611

Please test the patch in branch CR25687_4.

ibs

2015-02-18 19:56

developer   ~0037680

Last edited: 2015-02-18 19:59

there is the unstable behavior of bug24762_coloredshape testcase (RED color of edge not always has higher priority than PING color of wire)

git

2015-02-18 20:05

administrator   ~0037681

Branch CR25687_3 has been updated by ibs.

SHA-1: 39eeb73c18303b515ee4b53a9883a300eda2a524


Detailed log of new commits:

Author: ibs
Date: Wed Feb 18 19:13:52 2015 +0300

    the logic of bindSubShapes method clarified

apv

2015-02-19 14:43

tester   ~0037692

Last edited: 2015-02-19 14:44

Dear BugMaster,

Branch CR25687_4 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 7117ef5ad2f0b95c3c63b01b68b47eb24fb701b7

Number of compiler warnings:
occt component:
   Linux: 18 (18 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 11 (11 on master)
   Windows: 1 (1 on master)

Regressions/Differences:
http://occt-tests/CR25687-4-master-products/Debian60-64/summary.html
http://occt-tests/CR25687-4-master-products/Windows-32-VC10/summary.html
dxf read(004) bug22396

Testing cases:
bugs vis(004) bug25687_1 - OK
http://occt-tests/CR25687-4-master-occt/Debian60-64/bugs/vis/bug25687_1.html
http://occt-tests/CR25687-4-master-occt/Windows-32-VC10/bugs/vis/bug25687_1.html
bugs vis(004) bug25687_2 - OK
http://occt-tests/CR25687-4-master-occt/Debian60-64/bugs/vis/bug25687_2.html
http://occt-tests/CR25687-4-master-occt/Windows-32-VC10/bugs/vis/bug25687_2.html

Testing on Linux:
Total MEMORY difference: 85975651 / 86200086
Total CPU difference: 49833.71000000011 / 48446.16999999995

Testing on Windows:
Total MEMORY difference: 40699394 / 40708321
Total CPU difference: 36177.140625 / 34798.28125

There are differences in images found by testdiff:
http://occt-tests/CR25687-4-master-occt/Debian60-64/diff-Debian60-64.html
http://occt-tests/CR25687-4-master-occt/Windows-32-VC10/diff-Windows-32-VC10.html
bugs xde bug2
bugs xde bug25381
http://occt-tests/CR25687-4-master-products/Debian60-64/diff-Debian60-64.html
http://occt-tests/CR25687-4-master-products/Windows-32-VC10/diff-Windows-32-VC10.html
dxf read F2
dxf read bug25375
dxf read bug23611

git

2015-02-19 15:37

administrator   ~0037702

Branch CR25687_3 has been updated by ibs.

SHA-1: f770e34c1bbe170c7baf1cbbb9700c559d888024


Detailed log of new commits:

Author: ibs
Date: Thu Feb 19 15:20:23 2015 +0300

    in bindSubShapes a higher color priority has lower topological shape (edge has higher priority than wire)

git

2015-02-19 16:52

administrator   ~0037711

Branch CR25687_4 has been updated by ibs.

SHA-1: 834d262c0103baf93457909639619e75d389cdbf


Detailed log of new commits:

Author: ibs
Date: Thu Feb 19 15:20:23 2015 +0300

    AIS_ColoredShape::dispatchColors considers the colors of displayed shapes in connection with specific priority
    
    the color of specific shape can be exported from several ways: the color of this shape, the color of a compound containing this shape. The highest priority has the color of shape than the one of the compound. The color with highest priority will be displayed.
    
    This patch accounts for the highest priority of the shape color.
    
    For example: w - wire has GREEN color; e - edge has RED color; "w" contains "e"; all edges of "w" will be displayed in GREEN color except "e" edge, it will be displayed in RED color

Author: ibs
Date: Wed Feb 18 19:13:52 2015 +0300

    the logic of bindSubShapes method clarified
    
    Conflicts:
    
        src/AIS/AIS_ColoredShape.cxx

kgv

2015-02-19 21:48

developer   ~0037722

Please test updated branch CR25687_4.

git

2015-02-20 14:55

administrator   ~0037745

Branch CR25687_1 has been deleted by ibs.

SHA-1: f9c6a87fe705d88712da8de64d396d870a71c772

git

2015-02-20 14:55

administrator   ~0037746

Branch CR25687_2 has been deleted by ibs.

SHA-1: 2d998557077852e75c8bf28da9162609d0ee88eb

git

2015-02-20 14:56

administrator   ~0037747

Branch CR25687_3 has been deleted by ibs.

SHA-1: f770e34c1bbe170c7baf1cbbb9700c559d888024

git

2015-02-20 18:08

administrator   ~0037759

Branch CR25687_4 has been updated forcibly by apv.

SHA-1: 23d309f3b5551869cef89b36841d6c99333405bd

apv

2015-02-20 18:09

tester   ~0037761

Branch CR25687_4 has been rebased on the current master

git

2015-02-24 07:10

administrator   ~0037789

Branch CR25687_4 has been updated by abv.

SHA-1: fae7528519799dd86c8c684ce516ea0c3ba4ce2a


Detailed log of new commits:

Author: abv
Date: Tue Feb 24 07:09:42 2015 +0300

    Added sample generating model of Intel i7-4790 CPU on which the problem can be reproduced

apv

2015-02-25 19:11

tester   ~0037888

Dear BugMaster,

Branch CR25687_4 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 23d309f3b5551869cef89b36841d6c99333405bd

Number of compiler warnings:
occt component:
   Linux: 18 (18 on master)
   Windows: 2 (2 on master)
products component:
   Linux: 11 (11 on master)
   Windows: 4 (4 on master)

Regressions/Differences:
Not detected

Testing cases:
bugs vis(004) bug25687_1 - OK
http://occt-tests/CR25687-4-master-occt-64/Debian60-64/bugs/vis/bug25687_1.html
http://occt-tests/CR25687-4-master-occt-64/Windows-64-VC10/bugs/vis/bug25687_1.html
bugs vis(004) bug25687_2 - OK
http://occt-tests/CR25687-4-master-occt-64/Debian60-64/bugs/vis/bug25687_2.html
http://occt-tests/CR25687-4-master-occt-64/Windows-64-VC10/bugs/vis/bug25687_2.html

Testing on Linux:
Total MEMORY difference: 91503317 / 91657177
Total CPU difference: 53981.27999999988 / 53741.27000000005

Testing on Windows:
Total MEMORY difference: 53070688 / 53074574
Total CPU difference: 32266.453125 / 34043.96875

git

2015-03-18 13:35

administrator   ~0038539

Branch CR25687 has been deleted by inv.

SHA-1: 6550cc61bcd222bc3b9af2e334f303455fd7db80

git

2015-03-18 13:35

administrator   ~0038540

Branch CR25687_4 has been deleted by inv.

SHA-1: fae7528519799dd86c8c684ce516ea0c3ba4ce2a

Related Changesets

occt: master 5bffb882

2015-02-26 09:50:32

ibs


Committer: bugmaster Details Diff
0025687: Visualization, XCAF - eliminate visual artifacts at the edges of faces

AIS_ColoredShape::Compute() - improve logic to split input shape into Closed and Open volumes
with back-face culling enabled when possible.

Change last argument of method StdPrs_ShadedShape::Add() from boolean to enumeration StdPrs_Volume
which controls parsing of Closed/Open volumes within input shape.
Make method StdPrs_ShadedShape::ExploreSolids() public.

Extend Draw Harness command vaspects with option -setvisibility to hide subshape (using AIS_ColoredShape).
Add new test cases bugs/bis/bug25687_1 and bugs/bis/bug25687_2.

the logic of bindSubShapes method clarified

Conflicts:

src/AIS/AIS_ColoredShape.cxx

AIS_ColoredShape::dispatchColors considers the colors of displayed shapes in connection with specific priority

the color of specific shape can be exported from several ways: the color of this shape, the color of a compound containing this shape. The highest priority has the color of shape than the one of the compound. The color with highest priority will be displayed.

This patch accounts for the highest priority of the shape color.

For example: w - wire has GREEN color; e - edge has RED color; "w" contains "e"; all edges of "w" will be displayed in GREEN color except "e" edge, it will be displayed in RED color

Added sample generating model of Intel i7-4790 CPU on which the problem can be reproduced
Affected Issues
0025687
add - samples/tcl/cpu.tcl Diff File
mod - samples/tcl/dimensions.tcl Diff File
mod - samples/tcl/pencil.tcl Diff File
mod - samples/tcl/xde.tcl Diff File
mod - src/AIS/AIS_ColoredShape.cxx Diff File
mod - src/AIS/AIS_ColoredShape.hxx Diff File
mod - src/StdPrs/StdPrs.cdl Diff File
mod - src/StdPrs/StdPrs_ShadedShape.cdl Diff File
mod - src/StdPrs/StdPrs_ShadedShape.cxx Diff File
mod - src/ViewerTest/ViewerTest.cxx Diff File
add - tests/bugs/vis/bug25687_1 Diff File
add - tests/bugs/vis/bug25687_2 Diff File

Issue History

Date Modified Username Field Change
2015-01-06 16:13 abv New Issue
2015-01-06 16:13 abv Assigned To => kgv
2015-01-06 16:16 abv Relationship added related to 0024521
2015-01-06 18:15 kgv Note Added: 0035923
2015-01-06 18:28 abv File Added: xde_no_culling.png
2015-01-26 14:24 kgv Assigned To kgv => ibs
2015-01-26 14:24 kgv Status new => assigned
2015-02-04 16:46 git Note Added: 0037079
2015-02-04 16:52 ibs File Added: xde_culling.png
2015-02-04 16:53 ibs Note Added: 0037080
2015-02-04 16:53 ibs Assigned To ibs => kgv
2015-02-04 16:53 ibs Status assigned => resolved
2015-02-05 14:09 kgv Note Added: 0037116
2015-02-05 14:09 kgv Assigned To kgv => ibs
2015-02-05 14:09 kgv Status resolved => assigned
2015-02-05 14:12 kgv Note Edited: 0037116
2015-02-05 20:02 git Note Added: 0037160
2015-02-05 20:04 ibs Note Added: 0037161
2015-02-05 20:04 ibs Assigned To ibs => kgv
2015-02-05 20:04 ibs Status assigned => resolved
2015-02-06 18:22 kgv Note Added: 0037197
2015-02-06 18:22 kgv Assigned To kgv => ibs
2015-02-06 18:22 kgv Status resolved => assigned
2015-02-06 18:23 kgv Note Edited: 0037197
2015-02-09 17:39 git Note Added: 0037244
2015-02-09 19:11 git Note Added: 0037255
2015-02-09 19:14 ibs Note Added: 0037256
2015-02-09 19:14 ibs Assigned To ibs => kgv
2015-02-09 19:14 ibs Status assigned => feedback
2015-02-10 09:00 kgv Note Added: 0037263
2015-02-10 09:00 kgv Assigned To kgv => ibs
2015-02-10 09:00 kgv Status feedback => assigned
2015-02-10 10:46 git Note Added: 0037267
2015-02-10 10:48 ibs Note Added: 0037268
2015-02-10 10:48 ibs Assigned To ibs => kgv
2015-02-10 10:48 ibs Status assigned => feedback
2015-02-10 12:30 kgv Note Added: 0037276
2015-02-11 15:13 git Note Added: 0037360
2015-02-11 19:00 git Note Added: 0037384
2015-02-11 19:05 ibs Note Added: 0037387
2015-02-12 10:57 kgv Relationship added related to 0025822
2015-02-13 14:57 ibs Note Added: 0037508
2015-02-13 15:39 git Note Added: 0037512
2015-02-13 16:04 ibs Note Edited: 0037508
2015-02-13 16:19 git Note Added: 0037516
2015-02-13 16:20 ibs Note Added: 0037517
2015-02-13 16:20 ibs Status feedback => resolved
2015-02-13 17:35 kgv Note Added: 0037522
2015-02-13 17:35 kgv Assigned To kgv => ibs
2015-02-13 17:35 kgv Status resolved => assigned
2015-02-16 16:03 git Note Added: 0037571
2015-02-16 16:07 ibs Note Added: 0037572
2015-02-16 16:07 ibs Assigned To ibs => kgv
2015-02-16 16:07 ibs Status assigned => resolved
2015-02-16 16:24 git Note Added: 0037574
2015-02-16 16:25 ibs Note Added: 0037575
2015-02-16 18:56 git Note Added: 0037587
2015-02-16 20:19 ibs Note Added: 0037603
2015-02-17 09:20 git Note Added: 0037610
2015-02-17 09:21 kgv Note Added: 0037611
2015-02-17 09:21 kgv Assigned To kgv => bugmaster
2015-02-17 09:21 kgv Status resolved => reviewed
2015-02-17 09:21 kgv Summary Visualization, XCAF - visual artifacts at the edges of faces => Visualization, XCAF - eliminate visual artifacts at the edges of faces
2015-02-17 18:23 apv Assigned To bugmaster => apv
2015-02-18 19:56 ibs Note Added: 0037680
2015-02-18 19:56 ibs Assigned To apv => ibs
2015-02-18 19:56 ibs Status reviewed => assigned
2015-02-18 19:59 ibs Note Edited: 0037680
2015-02-18 20:05 git Note Added: 0037681
2015-02-19 14:43 apv Note Added: 0037692
2015-02-19 14:44 apv Note Edited: 0037692
2015-02-19 15:37 git Note Added: 0037702
2015-02-19 15:41 apv Test case number => bugs vis(004) bug25687_1, bug25687_2
2015-02-19 15:44 ibs Assigned To ibs => kgv
2015-02-19 15:44 ibs Status assigned => resolved
2015-02-19 16:52 git Note Added: 0037711
2015-02-19 21:48 kgv Note Added: 0037722
2015-02-19 21:48 kgv Assigned To kgv => bugmaster
2015-02-19 21:48 kgv Status resolved => reviewed
2015-02-20 14:11 apv Assigned To bugmaster => apv
2015-02-20 14:55 git Note Added: 0037745
2015-02-20 14:55 git Note Added: 0037746
2015-02-20 14:56 git Note Added: 0037747
2015-02-20 18:08 git Note Added: 0037759
2015-02-20 18:09 apv Note Added: 0037761
2015-02-24 07:10 git Note Added: 0037789
2015-02-25 19:11 apv Note Added: 0037888
2015-02-25 19:11 apv Assigned To apv => bugmaster
2015-02-25 19:11 apv Status reviewed => tested
2015-02-27 16:53 bugmaster Changeset attached => occt master 5bffb882
2015-02-27 16:53 bugmaster Status tested => verified
2015-02-27 16:53 bugmaster Resolution open => fixed
2015-03-18 13:35 git Note Added: 0038539
2015-03-18 13:35 git Note Added: 0038540
2015-05-14 15:29 aiv Status verified => closed
2015-05-14 15:32 aiv Fixed in Version => 6.9.0
2016-11-01 19:28 kgv Relationship added related to 0028036