MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025589Community[OCCT] OCCT:Meshpublic2014-12-10 16:422019-07-06 14:30
Reporterdrazmyslovich 
Assigned Todrazmyslovich 
PrioritynormalSeverityminor 
StatusfeedbackResolutionopen 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0025589: BRepMesh_WireInterferenceChecker doesn't report all cases of self-intersecting wires
DescriptionBRepMesh_WireInterferenceChecker currently doesn't detected all intersections of edges and therefore some faces couldn't be properly meshed.
Steps To ReproduceN/A
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0035272)
git (administrator)
2014-12-10 16:44

Branch CR25589 has been created by drazmyslovich.

SHA-1: 30d665dfb036fce22aae37386e711ac13cde7391


Detailed log of new commits:

Author: razmyslovich
Date: Wed Dec 10 14:43:53 2014 +0100

    0025589: modify the wire interference checker to detect all types of intersections
(0035274)
drazmyslovich (developer)
2014-12-10 16:44

The modification is provided, please, review
(0035331)
oan (developer)
2014-12-11 13:43

Dear Dima,

thank you for this fix! Could you please also provide a test case or problematic shape/face using which the problem can be reproduced?
(0074128)
abv (manager)
2018-02-25 21:10

Apparently we will not get any test data
(0080652)
msv (developer)
2018-11-02 17:50

Dear Dmitry, please check the bug state after integration of the fix for 0026106.
(0085445)
drazmyslovich (developer)
2019-07-05 16:32

I checked the latest state of OCC 7.4. The new FaceChecker class still doesn't report all cases of self-intersecting wires. But as the face and edge discretization logic was improved, the final meshing result is ok.
(0085454)
oan (developer)
2019-07-06 14:30

Hi Dima,

>>> But as the face and edge discretization logic was improved, the final meshing result is ok.
 
that sounds great!

>>> The new FaceChecker class still doesn't report all cases of self-intersecting wires.

Could you please attach some shapes demonstrating this problem?
If we got some, it would be possible to reproduce it and then improve the component.

If it is impossible to provide such use cases due to some reasons or commercial agreements, I suppose the issue can be closed.

- Issue History
Date Modified Username Field Change
2014-12-10 16:42 drazmyslovich New Issue
2014-12-10 16:42 drazmyslovich Assigned To => oan
2014-12-10 16:44 git Note Added: 0035272
2014-12-10 16:44 drazmyslovich Note Added: 0035274
2014-12-10 16:44 drazmyslovich Status new => resolved
2014-12-10 16:44 drazmyslovich Steps to Reproduce Updated View Revisions
2014-12-11 13:43 oan Note Added: 0035331
2014-12-11 13:43 oan Assigned To oan => drazmyslovich
2014-12-11 13:43 oan Status resolved => feedback
2015-04-17 10:16 oan Target Version 6.9.0 => 7.1.0
2016-10-25 17:40 oan Target Version 7.1.0 => 7.2.0
2017-07-20 12:43 oan Target Version 7.2.0 => 7.3.0
2018-02-25 21:09 abv Target Version 7.3.0 => 7.4.0*
2018-02-25 21:10 abv Note Added: 0074128
2018-02-25 21:10 abv Assigned To drazmyslovich => oan
2018-02-25 21:10 abv Status feedback => resolved
2018-11-02 17:50 msv Note Added: 0080652
2018-11-02 17:50 msv Assigned To oan => drazmyslovich
2018-11-02 17:50 msv Status resolved => feedback
2019-07-05 16:32 drazmyslovich Note Added: 0085445
2019-07-05 16:32 drazmyslovich Assigned To drazmyslovich => oan
2019-07-05 16:32 drazmyslovich Status feedback => resolved
2019-07-06 14:30 oan Note Added: 0085454
2019-07-06 14:30 oan Assigned To oan => drazmyslovich
2019-07-06 14:30 oan Status resolved => feedback


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker