View Issue Details

IDProjectCategoryView StatusLast Update
0025521CommunityOCCT:Modeling Algorithmspublic2022-02-14 10:55
Reportershoogen Assigned Tomsv  
PrioritynormalSeverityminor 
Status assignedResolutionopen 
PlatformLinuxOSDebian 6.0 
Product Version6.8.0 
Summary0025521: Fillet creates shell with bad orientation of SubShape
DescriptionFilleting the attached shape results in the shell being reported to have a bad orientation of subshape
Steps To Reproduce#generated by FreeCAD 0.15.4212 +7 (Git)
pload MODELING
restore fillet-suborient3-draw-s1.brep s1
ttranslate s1 0 0 3
explode s1 E
blend Fillet s1 2 s1_4
donly Fillet
checkshape Fillet
#Shape faulty_1 on shape faulty_2 :
#BRepCheck_BadOrientationOfSubshape
TagsNo tags attached.
Test case numberbugs modalg_7 bug25521

Attached Files

  • fillet-suborient3.zip (5,929 bytes)

Activities

shoogen

2014-11-26 19:24

reporter  

fillet-suborient3.zip (5,929 bytes)

mkv

2017-08-04 12:01

tester   ~0069107

Problem described in issue is reproduced on current state of OCCT.

chennes

2022-02-13 04:53

developer   ~0106879

Per downstream ticket here: https://github.com/FreeCAD/FreeCAD/issues/5634 this issue no longer occurs with recent builds of OpenCASCADE.

msv

2022-02-14 10:54

developer   ~0106884

I am sorry, but testing the proposed steps to reproduce reveal that the problem is still present.

Issue History

Date Modified Username Field Change
2014-11-26 19:24 shoogen New Issue
2014-11-26 19:24 shoogen Assigned To => msv
2014-11-26 19:24 shoogen File Added: fillet-suborient3.zip
2017-08-04 12:01 mkv Test case number => bugs modalg_7 bug25521
2017-08-04 12:01 mkv Note Added: 0069107
2022-02-13 04:53 chennes Status new => resolved
2022-02-13 04:53 chennes Note Added: 0106879
2022-02-14 10:54 msv Note Added: 0106884
2022-02-14 10:55 msv Status resolved => assigned