MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025448Open CASCADE[OCCT] OCCT:Codingpublic2014-11-05 15:362016-12-09 16:38
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0025448: Coding - remove useless header Quantity_Color_1.hxx
DescriptionHeader file Quantity_Color_1.hxx is useless and should be deleted, with its content moved to Quantity_Color.cxx
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0000176closedbugmaster Documentation: Values returned by Quantity_TOC_HLS' parameters ! 

-  Notes
(0034050)
git (administrator)
2014-11-05 15:40

Branch CR25448 has been created by abv.

SHA-1: e9e6ab2f26d0376bcaa6bf1d2ba7b51e892bf04f


Detailed log of new commits:

Author: abv
Date: Wed Nov 5 15:39:49 2014 +0300

    0025448: Coding - remove useless header Quantity_Color_1.hxx
    
    Useless header file Quantity_Color_1.hxx is deleted, its content moved to Quantity_Color.cxx
(0056317)
git (administrator)
2016-07-31 11:47

Branch CR25448 has been updated forcibly by kgv.

SHA-1: e0d150e3f3f5143a024cda5c96af3f3282af6698
(0056318)
git (administrator)
2016-07-31 12:09

Branch CR25448 has been updated by kgv.

SHA-1: 7318985c61a293021fc3bdb07f9fa061b76dc293


Detailed log of new commits:

Author: kgv
Date: Sun Jul 31 12:09:26 2016 +0300

    Quantity_Color - document special Hue value -1.0

(0056319)
git (administrator)
2016-07-31 12:13

Branch CR25448_1 has been created by kgv.

SHA-1: 6363e6bffb61af94ce85224ec1e68232c815fc1f


Detailed log of new commits:

Author: abv
Date: Sun Jul 31 12:13:06 2016 +0300

    0025448: Coding - remove useless header Quantity_Color_1.hxx
    
    Useless header file Quantity_Color_1.hxx is deleted, its content moved to Quantity_Color.cxx
    The meaning of special Hue value -1.0 has been added to Quantity_Color methods description.
(0056320)
kgv (developer)
2016-07-31 12:14

Please check compilation of the patch in branch CR25448_1.
Regression testing is not needed.
(0056399)
apv (tester)
2016-08-02 18:05

During building of branch CR25448_1 (SHA-1: 6363e6bffb61af94ce85224ec1e68232c815fc1f) from occt git-repository (and master from products git-repository) compilation errors have been detected.
On Linux:
http://jenkins-test-07.nnov.opencascade.com/view/CR25448_1-master/job/CR25448_1-master-OCCT-Debian70-64-opt-compile/1/parsed_console/ [^]
On Windows:
http://jenkins-test-07.nnov.opencascade.com/view/CR25448_1-master/job/CR25448_1-master-OCCT-Windows-64-VC10-opt-compile/1/parsed_console/ [^]
On MacOS:
http://jenkins-test-07.nnov.opencascade.com/view/CR25448_1-master/job/CR25448_1-master-OCCT-MacOS-opt-compile/1/parsed_console/ [^]
(0056400)
apv (tester)
2016-08-02 18:06

Dear Kirill,

Branch CR25448_1 has been rejected due to:
- compilation errors
(0056401)
git (administrator)
2016-08-02 18:10

Branch CR25448_1 has been updated forcibly by kgv.

SHA-1: 14230ffdc536438e4813b4798000cd3546aa10cf
(0056402)
kgv (developer)
2016-08-02 18:11

Misprint has been corrected in updated CR25448_1 - please re-check compilation.
(0056436)
apv (tester)
2016-08-03 14:00
edited on: 2016-08-03 14:01

Dear BugMaster,

Branch CR25448_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms.
SHA-1: 14230ffdc536438e4813b4798000cd3546aa10cf

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1132

(0057171)
git (administrator)
2016-08-26 16:25

Branch CR25448_1 has been deleted by inv.

SHA-1: 14230ffdc536438e4813b4798000cd3546aa10cf
(0057180)
git (administrator)
2016-08-26 16:25

Branch CR25448 has been deleted by inv.

SHA-1: 7318985c61a293021fc3bdb07f9fa061b76dc293

- Related Changesets
occt: master 82cf4904
Timestamp: 2016-08-02 15:11:41
Author: abv
Committer: bugmaster
Details ] Diff ]
0025448: Coding - remove useless header Quantity_Color_1.hxx

Useless header file Quantity_Color_1.hxx is deleted, its content moved to Quantity_Color.cxx
The meaning of special Hue value -1.0 has been added to Quantity_Color methods description.
mod - src/Quantity/FILES Diff ] File ]
mod - src/Quantity/Quantity_Color.cxx Diff ] File ]
mod - src/Quantity/Quantity_Color.hxx Diff ] File ]
rm - src/Quantity/Quantity_Color_1.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-11-05 15:36 abv New Issue
2014-11-05 15:36 abv Assigned To => kgv
2014-11-05 15:40 git Note Added: 0034050
2014-11-05 15:41 abv Status new => resolved
2015-11-17 16:46 kgv Relationship added related to 0000176
2015-11-17 16:57 kgv Target Version 7.0.0 => 7.1.0
2016-07-31 11:47 git Note Added: 0056317
2016-07-31 12:09 git Note Added: 0056318
2016-07-31 12:13 git Note Added: 0056319
2016-07-31 12:14 kgv Note Added: 0056320
2016-07-31 12:14 kgv Assigned To kgv => bugmaster
2016-07-31 12:14 kgv Status resolved => reviewed
2016-08-01 18:13 apv Assigned To bugmaster => apv
2016-08-02 18:05 apv Note Added: 0056399
2016-08-02 18:05 apv Assigned To apv => kgv
2016-08-02 18:05 apv Status reviewed => assigned
2016-08-02 18:06 apv Note Added: 0056400
2016-08-02 18:10 git Note Added: 0056401
2016-08-02 18:11 kgv Note Added: 0056402
2016-08-02 18:11 kgv Assigned To kgv => bugmaster
2016-08-02 18:11 kgv Status assigned => resolved
2016-08-02 18:11 kgv Status resolved => reviewed
2016-08-02 19:21 apv Assigned To bugmaster => apv
2016-08-03 13:59 apv Test case number => Not needed
2016-08-03 14:00 apv Note Added: 0056436
2016-08-03 14:00 apv Assigned To apv => bugmaster
2016-08-03 14:00 apv Status reviewed => tested
2016-08-03 14:01 apv Note Edited: 0056436 View Revisions
2016-08-05 13:30 bugmaster Changeset attached => occt master 82cf4904
2016-08-05 13:30 bugmaster Status tested => verified
2016-08-05 13:30 bugmaster Resolution open => fixed
2016-08-26 16:25 git Note Added: 0057171
2016-08-26 16:25 git Note Added: 0057180
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker