MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025362Open CASCADE[OCCT] OCCT:Samplespublic2014-10-13 15:452016-12-09 16:39
Reporterapn 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0025362: Samples - Conversion to B-Spline doesn't show bspline surface on Windows 8
DescriptionSample Conversion to B-Spline doesn't show bspline surface on Windows 8.
Steps To Reproduce1. Launch sample "Conversion to B-Spline" (mfc Convert sample)
2. Click next\previous sample
3. Build surface should be highlighted (by orange color for wires, by blue color for shapes), first sample is correct, others are not
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0060078)
abv (manager)
2016-11-09 11:20

Sergey, please check the current behavior
(0060138)
ski (developer)
2016-11-09 17:30

Dear abv,

i have checked mfc Convert sample on my local station Windows 10 vc10 win64 Release, bug can be reproduced, only first example works correctly, others are not.

In case of Windows 7 via remote desktop - an exception appears on the example number 5 (pipe).
(0060564)
abv (manager)
2016-11-18 21:05

Sergey, please investigate to know the reason
(0060703)
git (administrator)
2016-11-23 10:24

Branch CR25362 has been created by ski.

SHA-1: 722091d36e1fb4c3b2987cbcfd5b5e1e363ce6d0


Detailed log of new commits:

Author: ski
Date: Wed Nov 23 10:24:20 2016 +0300

    0025362: Samples - Conversion to B-Spline doesn't show bspline surface on Windows 8
    
    Added constants WM_MOUSEFIRST and WM_PAINT in WaitForInput method for correct handling of system messages.
(0060704)
git (administrator)
2016-11-23 10:33

Branch CR25362 has been updated forcibly by ski.

SHA-1: 81fe266d55fe7c67bcd3b66f78fd2bc14c35e8f2
(0060721)
ski (developer)
2016-11-23 13:16
edited on: 2016-11-23 13:16

Dear Andrey,

OCCT branch CR25362 contains changes for correct handling of system messages.

I have checked it on my local station (Windows 10 64-bit) - all is OK.

In case of crash on Windows 7 (via remote desktop) it seems that the reason is remote desktop. I propose to create separate issue if it is needed.

Please, review.

(0060770)
abv (manager)
2016-11-25 10:34

No remarks, please integrate
(0061231)
git (administrator)
2016-12-07 11:30

Branch CR25362 has been deleted by kgv.

SHA-1: 81fe266d55fe7c67bcd3b66f78fd2bc14c35e8f2

- Related Changesets
occt: master 168077a6
Timestamp: 2016-11-23 07:24:20
Author: ski
Committer: apn
Details ] Diff ]
0025362: Samples - Conversion to B-Spline doesn't show bspline surface on Windows 8

Added constants WM_MOUSEFIRST and WM_PAINT in WaitForInput method for correct handling of system messages.
mod - samples/mfc/standard/10_Convert/src/OCCDemo_Presentation.cpp Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-10-13 15:45 apn New Issue
2014-10-13 15:45 apn Assigned To => bugmaster
2014-10-13 15:45 apn Test case number => Not needed
2014-10-13 15:45 apn Assigned To bugmaster => aba
2014-10-13 15:45 apn Status new => assigned
2015-11-10 10:24 kgv Relationship added related to 0026794
2015-11-16 16:43 abv Target Version => 7.0.0
2015-12-28 11:31 kgv Target Version 7.0.0 => 7.1.0
2015-12-28 11:31 kgv Summary Sample Conversion to B-Spline doesn't show bspline surface on Windows 8 => Samples - Conversion to B-Spline doesn't show bspline surface on Windows 8
2016-11-09 11:20 abv Note Added: 0060078
2016-11-09 11:20 abv Assigned To aba => ski
2016-11-09 11:20 abv Status assigned => feedback
2016-11-09 17:30 ski Note Added: 0060138
2016-11-09 17:30 ski Assigned To ski => abv
2016-11-18 21:05 abv Note Added: 0060564
2016-11-18 21:05 abv Assigned To abv => ski
2016-11-18 21:05 abv Status feedback => assigned
2016-11-23 10:24 git Note Added: 0060703
2016-11-23 10:33 git Note Added: 0060704
2016-11-23 13:16 ski Note Added: 0060721
2016-11-23 13:16 ski Assigned To ski => abv
2016-11-23 13:16 ski Status assigned => resolved
2016-11-23 13:16 ski Steps to Reproduce Updated View Revisions
2016-11-23 13:16 ski Note Edited: 0060721 View Revisions
2016-11-25 10:34 abv Note Added: 0060770
2016-11-25 10:34 abv Assigned To abv => bugmaster
2016-11-25 10:34 abv Status resolved => reviewed
2016-11-25 14:42 apn Changeset attached => occt master 168077a6
2016-11-25 14:42 apn Assigned To bugmaster => apn
2016-11-25 14:42 apn Status reviewed => verified
2016-11-25 14:42 apn Resolution open => fixed
2016-12-07 11:30 git Note Added: 0061231
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker