MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025347Open CASCADE[OCCT] OCCT:Visualizationpublic2014-10-09 16:232016-04-20 15:48
Reporterdbp 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0025347: Visualization - Provide gamma correction in OCCT ray-tracing core
DescriptionTo provide right perception of rendered image it must be converted to non-linear space using gamma-correction filter (gamma = 1.0/2.2). On the other hand, textures are already converted, and thus require inverse gamma correction (gamma = 2.2) before shading calsulations. Please note that gamma-correction should be provided as option, because we need to support OpenGL-like output.
Steps To ReproduceNot required
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0043004)
duv (developer)
2015-07-14 16:20

Already implemented in 0025201: Visualization - Implementing soft shadows and ambient occlusion in OCCT ray-tracing core.
(0043005)
duv (developer)
2015-07-14 16:21

Dear bugmaster,

please close the issue.
(0043348)
bugmaster (administrator)
2015-07-23 16:41

Moved to status VERIFIED after integration fix for 0025201

- Issue History
Date Modified Username Field Change
2014-10-09 16:23 dbp New Issue
2014-10-09 16:23 dbp Assigned To => duv
2014-10-09 16:24 dbp Description Updated View Revisions
2014-10-17 09:01 kgv Target Version 6.8.0 => 7.1.0
2015-07-14 16:18 duv Status new => resolved
2015-07-14 16:18 duv Steps to Reproduce Updated View Revisions
2015-07-14 16:18 duv Status resolved => assigned
2015-07-14 16:19 duv Status assigned => resolved
2015-07-14 16:20 duv Note Added: 0043004
2015-07-14 16:20 duv Assigned To duv => bugmaster
2015-07-14 16:20 duv Status resolved => reviewed
2015-07-14 16:21 duv Note Added: 0043005
2015-07-23 16:41 bugmaster Note Added: 0043348
2015-07-23 16:41 bugmaster Status reviewed => feedback
2015-07-27 10:27 bugmaster Status feedback => tested
2015-07-27 10:28 bugmaster Status tested => verified
2015-07-27 10:28 bugmaster Resolution open => fixed
2015-07-31 14:44 bugmaster Target Version 7.1.0 => 7.0.0
2016-04-20 15:44 aiv Fixed in Version => 7.0.0
2016-04-20 15:48 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker