MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025346Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2014-10-09 16:112015-05-14 15:32
Reporteremv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0025346: Wrong result of General Fuse operation
DescriptionThe result of General Fuse operation for the shapes used in the test case boolean bcut_complex J8 is wrong.
Steps To Reproduce# 1. General Fuse operation
restore [locate_data_file CTO902_pro14235a.rle] b1
restore [locate_data_file CTO902_pro14235b.rle] b2
bclearobjects; bcleartools
baddobjects b1; baddtools b2
bfillds -s
bbuild r
nbshapes r
# there are 2 solids in the result instead of 3

# 2. Boolean COMMON operation
restore [locate_data_file CTO902_pro14235a.rle] b1
restore [locate_data_file CTO902_pro14235b.rle] b2
bop b1 b2
bopcommon r
# r is an empty compound
TagsNo tags attached.
Test case numberbugs modalg_5 bug25346_1 bug25346_2
Attached Files

- Relationships

-  Notes
(0036429)
emv (developer)
2015-01-23 11:13

Dear APN,
The problem is not reproduced in current master. Could you please create test cases for the issue and close it.
(0036649)
git (administrator)
2015-01-26 15:21

Branch CR25346 has been created by apn.

SHA-1: 1d47eebfeb353a60a8cd40e798791e24f9085683


Detailed log of new commits:

Author: apn
Date: Mon Jan 26 15:20:52 2015 +0300

    0025346: Wrong result of General Fuse operation
    
    Added test cases bugs/modalg_5/bug25346_1 bug25346_2
(0038513)
git (administrator)
2015-03-18 13:33

Branch CR25346 has been deleted by inv.

SHA-1: 1d47eebfeb353a60a8cd40e798791e24f9085683

- Related Changesets
occt: master bdde45c3
Timestamp: 2015-01-26 12:20:52
Author: apn
Committer: bugmaster
Details ] Diff ]
0025346: Wrong result of General Fuse operation

Added test cases bugs/modalg_5/bug25346_1 bug25346_2
add - tests/bugs/modalg_5/bug25346_1 Diff ] File ]
add - tests/bugs/modalg_5/bug25346_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-10-09 16:11 emv New Issue
2014-10-09 16:11 emv Assigned To => emv
2015-01-23 11:13 emv Note Added: 0036429
2015-01-23 11:13 emv Assigned To emv => apn
2015-01-23 11:13 emv Status new => resolved
2015-01-23 11:13 emv Status resolved => reviewed
2015-01-26 15:21 git Note Added: 0036649
2015-01-26 15:21 apn Test case number => bugs modalg_5 bug25346_1 bug25346_2
2015-01-26 15:21 apn Assigned To apn => bugmaster
2015-01-26 15:21 apn Status reviewed => tested
2015-01-26 15:21 apn Target Version => 6.9.0
2015-01-30 14:00 bugmaster Changeset attached => occt master bdde45c3
2015-01-30 14:00 bugmaster Status tested => verified
2015-01-30 14:00 bugmaster Resolution open => fixed
2015-03-18 13:33 git Note Added: 0038513
2015-05-14 15:29 aiv Status verified => closed
2015-05-14 15:32 aiv Fixed in Version => 6.9.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker