MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025338Open CASCADE[OCCT] OCCT:Samplespublic2014-10-08 12:102016-08-02 14:45
Reporteraba 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0025338: MFC standard samples: 3D selection rectangle blinking.
DescriptionSelection rectangle drawn blinks in samples with 3D view.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0025789closedbugmaster Open CASCADE Visualization - get rid of obsolete 2d layers implementation 
parent of 0027039closedbugmaster Open CASCADE Draw Harness, ViewerTest - Fix rubber-band blinking 
related to 0025284closedbugmaster Open CASCADE Problems with standard MFC samples 
related to 0027736closedbugmaster Open CASCADE Samples - rectangle selection issues within MFC sample Viewer3d 
child of 0025508closedbugmaster Open CASCADE Visualization - redesign of 2d layers in TKV3d 

-  Notes
(0048389)
git (administrator)
2015-11-19 18:37

Branch CR25338 has been created by aba.

SHA-1: 97cf3ed58710e121227165a0aa9074d0fe1ed392


Detailed log of new commits:

Author: aba
Date: Thu Nov 19 18:35:20 2015 +0300

    0025338: MFC standard samples: 3D selection rectangle blinking
    - Added new interactive object OCC_RubberRect to draw selection rectangle
(0048390)
git (administrator)
2015-11-19 18:44

Branch CR25338 has been updated forcibly by aba.

SHA-1: b630588d5f201b2ac34853369d2c7964d1d720ec
(0048397)
kgv (developer)
2015-11-19 21:10
edited on: 2015-11-19 21:10

Just preliminary considerations:

+class OCC_RubberRect : public AIS_InteractiveObject

this object might be reusable, so it is better to place it in AIS package (e.g. AIS_RubberBand).

+  Standard_Real  myMinX;
+  Standard_Real  myMinY;
+  Standard_Real  myMaxX;
+  Standard_Real  myMaxY;

please unify implementation for both use cases - polygonal and rectangular selection using NCollection_Sequence<Graphic3d_Vec2i>. The should be a method defining rectangle and additional methods adding / removing last point and accessing entire array.

+Quantity_NameOfColor OCC_RubberRect::Color() const

it does not look reasonable defining a method returned color name instead of color itself.

+  myDrawer->SetLineAspect (new Prs3d_LineAspect (theColor, theType, theWidth));

it is better to declare face aspect as well for filled rubber band.
Thus methods should be corrected (LineColor(), FillColor(), LineType(), FillTransparency()). 1.0 transparency would mean no filling.

(0048517)
git (administrator)
2015-11-24 15:10

Branch CR25338 has been updated forcibly by aba.

SHA-1: 3bec781f0bd167b25d317420785146e246d0e1b7
(0049254)
git (administrator)
2015-12-17 19:36

Branch CR25338 has been updated by aba.

SHA-1: f4995053c249f35dd3f9d67a4ef02e034b3e62d4


Detailed log of new commits:

Author: aba
Date: Thu Dec 17 19:35:46 2015 +0300

    Remarks

(0049257)
git (administrator)
2015-12-18 10:18

Branch CR25338_2 has been created by aba.

SHA-1: fcbdc868c5238a52d3d70db59fb8b2ac40b57074


Detailed log of new commits:

Author: aba
Date: Fri Dec 18 10:17:18 2015 +0300

    0025338: MFC standard samples: 3D selection rectangle blinking
    
    - Added new interactive object AIS_RubberBand to draw rubber rectangle or polygon
    - Added using of AIS_RubberBand in DRAW view for rectangular selection
    - Added using of AIS_RubberBand in MFC samples for rectangular selection
(0049258)
git (administrator)
2015-12-18 10:19

Branch CR25338 has been updated forcibly by aba.

SHA-1: f6192d97b4d6584f76099f937079139308514ceb
(0049261)
git (administrator)
2015-12-18 10:58

Branch CR25338_2 has been updated forcibly by aba.

SHA-1: abd748991b7edd3bbeda498ed008c45c5790844a
(0049265)
git (administrator)
2015-12-18 11:36

Branch CR25338_2 has been updated forcibly by aba.

SHA-1: ab1a67770611aead32c2c83ba0f16174e1afb347
(0049266)
aba (developer)
2015-12-18 11:37

Dear kgv,

could you please review the branch CR25338_2?
(0049272)
git (administrator)
2015-12-18 12:00

Branch CR25338_2 has been updated forcibly by aba.

SHA-1: 0f339268198b7a29c19eda61e7186a082b8e1673
(0049273)
git (administrator)
2015-12-18 12:04

Branch CR25338_2 has been updated forcibly by aba.

SHA-1: 0290af987dc5b60ffda9165140bb08801fc71b10
(0049275)
git (administrator)
2015-12-18 12:06

Branch CR25338_2 has been updated forcibly by aba.

SHA-1: 6e47b2b3020d24a3bf88985326fd1ff5b5ceca09
(0049276)
kgv (developer)
2015-12-18 12:08

Please test the patch, and Draw Harness + modified samples interactively.
(0049308)
git (administrator)
2015-12-18 16:13

Branch CR25338_2 has been updated forcibly by apv.

SHA-1: 6a9b343600727565d1e9b50c6dc607baa3771935
(0049309)
apv (tester)
2015-12-18 16:14

Branch CR25338_2 has been rebased on the current master
(0049347)
apv (tester)
2015-12-21 11:56

Dear BugMaster,

Branch CR25338_2 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 6a9b343600727565d1e9b50c6dc607baa3771935

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 134 (134 on master)
products component:
   Linux: 37 (37 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
http://occt-tests/CR25338-2-master-occt-64/Windows-64-VC10/summary.html [^]
bugs modalg_5 bug23952_1, bug23952_2

Testing on Linux:
Total MEMORY difference: 89782861 / 89711172 [+0.08%]
Total CPU difference: 19317.939999999984 / 19353.450000000063 [-0.18%]

Testing on Windows:
Total MEMORY difference: 54641052 / 54644507 [-0.01%]
Total CPU difference: 17679.172127298945 / 18196.90824609882 [-2.85%]
(0049348)
apv (tester)
2015-12-21 11:57

Dear aba,

Branch CR25338_2 has been rejected due to:
- regressions/differences/improvements
(0049350)
kgv (developer)
2015-12-21 12:23

Dear bugmaster,

> Regressions/Differences:
> bugs modalg_5 bug23952_1, bug23952_2
it doesn't look like the patch might affect these test cases in anyway.
Could you please re-check the problem on current master?
(0049382)
apv (tester)
2015-12-21 17:04
edited on: 2015-12-21 17:04

Dear BugMaster,

Branch CR25338_2 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 6a9b343600727565d1e9b50c6dc607baa3771935

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 134 (134 on master)
products component:
   Linux: 37 (37 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 89782861 / 89711172 [+0.08%]
Total CPU difference: 19317.939999999984 / 19353.450000000063 [-0.18%]

Testing on Windows:
Total MEMORY difference: 54641052 / 54644507 [-0.01%]
Total CPU difference: 17679.172127298945 / 18196.90824609882 [-2.85%]

(0049383)
apv (tester)
2015-12-21 17:05

Dear aba,

Branch CR25338_2 has been rejected due to:
- problem with rectangular selection in samples
(0049407)
kgv (developer)
2015-12-21 20:16

Dear apv,

- problem with rectangular selection in samples

if testing has been performed using RDP as discussed with Anastasia - then this is not proper way for testing visualization functionality.

Please retest samples locally.
(0049422)
apv (tester)
2015-12-22 12:32

Samples have been tested locally. Problem with rectangular selection has not been detected. Current issue is tested.
(0052979)
git (administrator)
2016-04-17 13:54

Branch CR25338 has been deleted by kgv.

SHA-1: f6192d97b4d6584f76099f937079139308514ceb
(0052980)
git (administrator)
2016-04-17 13:54

Branch CR25338_2 has been deleted by kgv.

SHA-1: 6a9b343600727565d1e9b50c6dc607baa3771935

- Related Changesets
occt: master b12e1c7b
Timestamp: 2015-12-18 07:17:18
Author: aba
Committer: bugmaster
Details ] Diff ]
0025338: MFC standard samples: 3D selection rectangle blinking

- Added new interactive object AIS_RubberBand to draw rubber rectangle or polygon
- Added using of AIS_RubberBand in DRAW view for rectangular selection
- Added using of AIS_RubberBand in MFC samples for rectangular selection
mod - samples/mfc/standard/01_Geometry/src/GeometryView2D.cpp Diff ] File ]
mod - samples/mfc/standard/Common/OCC_2dView.cpp Diff ] File ]
mod - samples/mfc/standard/Common/OCC_2dView.h Diff ] File ]
mod - samples/mfc/standard/Common/OCC_3dView.cpp Diff ] File ]
mod - samples/mfc/standard/Common/OCC_3dView.h Diff ] File ]
mod - samples/mfc/standard/Common/OCC_BaseDoc.h Diff ] File ]
mod - samples/mfc/standard/Common/OCC_BaseView.cpp Diff ] File ]
mod - samples/mfc/standard/Common/OCC_BaseView.h Diff ] File ]
add - src/AIS/AIS_RubberBand.cxx Diff ] File ]
add - src/AIS/AIS_RubberBand.hxx Diff ] File ]
mod - src/AIS/FILES Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-10-08 12:10 aba New Issue
2014-10-08 12:10 aba Assigned To => aba
2014-10-08 12:11 aba Status new => assigned
2014-10-08 12:11 aba Relationship added related to 0025284
2014-10-09 14:39 kgv Target Version 6.8.0 => 7.1.0
2015-11-10 10:32 kgv Relationship added related to 0025789
2015-11-10 10:32 kgv Relationship added child of 0025508
2015-11-19 18:37 git Note Added: 0048389
2015-11-19 18:44 git Note Added: 0048390
2015-11-19 21:10 kgv Note Added: 0048397
2015-11-19 21:10 kgv Note Edited: 0048397 View Revisions
2015-11-24 15:10 git Note Added: 0048517
2015-12-17 19:36 git Note Added: 0049254
2015-12-18 10:18 git Note Added: 0049257
2015-12-18 10:19 git Note Added: 0049258
2015-12-18 10:58 git Note Added: 0049261
2015-12-18 11:36 git Note Added: 0049265
2015-12-18 11:37 aba Note Added: 0049266
2015-12-18 11:37 aba Assigned To aba => kgv
2015-12-18 11:37 aba Status assigned => resolved
2015-12-18 11:37 aba Steps to Reproduce Updated View Revisions
2015-12-18 12:00 git Note Added: 0049272
2015-12-18 12:04 git Note Added: 0049273
2015-12-18 12:06 git Note Added: 0049275
2015-12-18 12:08 kgv Note Added: 0049276
2015-12-18 12:08 kgv Status resolved => reviewed
2015-12-18 12:08 kgv Target Version 7.1.0 => 7.0.0
2015-12-18 12:08 kgv Assigned To kgv => bugmaster
2015-12-18 16:01 apv Assigned To bugmaster => apv
2015-12-18 16:13 git Note Added: 0049308
2015-12-18 16:14 apv Note Added: 0049309
2015-12-21 11:54 apv Test case number => Not needed
2015-12-21 11:56 apv Note Added: 0049347
2015-12-21 11:56 apv Assigned To apv => aba
2015-12-21 11:56 apv Status reviewed => assigned
2015-12-21 11:57 apv Note Added: 0049348
2015-12-21 12:23 kgv Note Added: 0049350
2015-12-21 12:23 kgv Assigned To aba => bugmaster
2015-12-21 12:23 kgv Status assigned => feedback
2015-12-21 12:33 apv Assigned To bugmaster => apv
2015-12-21 17:04 apv Note Added: 0049382
2015-12-21 17:04 apv Assigned To apv => aba
2015-12-21 17:04 apv Status feedback => assigned
2015-12-21 17:04 apv Note Edited: 0049382 View Revisions
2015-12-21 17:05 apv Note Added: 0049383
2015-12-21 20:16 kgv Note Added: 0049407
2015-12-21 20:16 kgv Assigned To aba => apv
2015-12-21 20:16 kgv Status assigned => feedback
2015-12-22 12:32 apv Note Added: 0049422
2015-12-22 12:32 apv Assigned To apv => bugmaster
2015-12-22 12:32 apv Status feedback => tested
2015-12-23 17:46 kgv Relationship added related to 0022172
2015-12-25 15:54 kgv Relationship added parent of 0027039
2015-12-25 19:04 bugmaster Changeset attached => occt master b12e1c7b
2015-12-25 19:04 bugmaster Status tested => verified
2015-12-25 19:04 bugmaster Resolution open => fixed
2016-04-17 13:54 git Note Added: 0052979
2016-04-17 13:54 git Note Added: 0052980
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed
2016-08-02 14:45 kgv Relationship added related to 0027736


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker